Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Fin the Human

Low Framerate in Far Cry 4

Recommended Posts

Posted · Original PosterOP

So I recently built a PC with a 1080 and 1800x, I have a 75hz 1080p panel(I haven't upgraded yet) but, in Far Cry 4 my FPS is in the 60s to 80s, when it should be in the hundreds. This is causing screen tearing, but even when I put the settings from Ultra to Low, it is still in that framerate range.  Why doesn't it just stay locked at 75 like Fallout 4?  Thank you!


PC 1:

CPU: AMD Ryzen 7 1800X    GPU: EVGA Superclocked GeForce GTX 1080

RAM: 2x8GB Corsair Vengeance LPX 3000MHz DDR4    SSD: Crucial MX500 500GB

PSU: Corsair CX750M V2   HDD: Seagate Barracuda Compute 3TB 7200RPM

Case: Phanteks Eclipse P400STG Red/Black   MOBO: ASRock X370 Killer SLI/ac

OS: Windows 10 Pro  Keyboard:  Corsair K68 Red  Mouse:  Corsair M65 Pro RGB 

 

PC 2:

CPU: Intel Pentium E5800   GPU: AMD HD6450 512MB

RAM: 1x2GB Kingston 1066MHz DDR3    HDD: Seagate Barracuda 250GB 7200RPM

PSU: Sparkle-Power 300W     Case: Nobilis Micro ATX OEM  MOBO: Intel DG41WV 775   

OS: Windows 10 Home  Keyboard:  Apple A1048  Mouse:  Rosewill Fusion C40

 

PC 3:

CPU: Intel Core 2 Duo E7500   GPU: AMD HD8490 1GB

RAM: 2x2GB Apacer 1333MHz DDR3    HDD: Seagate Barracuda 250GB 7200RPM

PSU: Generic HP 300W     Case: Nobilis Micro ATX OEM  MOBO: Intel DG31PR 775   

OS: Ubuntu LTS 18.04  Keyboard:  Microsoft RT2300  Mouse:  Rosewill Fusion C40

 

PC 4:

CPU: Intel 486DX2 50 MHz   GPU: Western Digital 90C24

RAM: 4MB Generic    HDD: 340MB Generic

PSU: IBM Charger     Case: ThinkPad 755C  MOBO: IBM Proprietary 

OS: Windows 3.1  Keyboard: Built In Keyboard  Mouse: Built In Nipple

 

Consoles: Wii, SNES, NES, N64, Atari 7800, Commodore VIC-20, Genesis, Dreamcast, PS1, PS2, and Steam Link.

 

Car: 2002 Subaru Outback Limited (Red)

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, AimTuxx said:

How much Ram is in your System?

16GB of DDR4 3000MHz.


PC 1:

CPU: AMD Ryzen 7 1800X    GPU: EVGA Superclocked GeForce GTX 1080

RAM: 2x8GB Corsair Vengeance LPX 3000MHz DDR4    SSD: Crucial MX500 500GB

PSU: Corsair CX750M V2   HDD: Seagate Barracuda Compute 3TB 7200RPM

Case: Phanteks Eclipse P400STG Red/Black   MOBO: ASRock X370 Killer SLI/ac

OS: Windows 10 Pro  Keyboard:  Corsair K68 Red  Mouse:  Corsair M65 Pro RGB 

 

PC 2:

CPU: Intel Pentium E5800   GPU: AMD HD6450 512MB

RAM: 1x2GB Kingston 1066MHz DDR3    HDD: Seagate Barracuda 250GB 7200RPM

PSU: Sparkle-Power 300W     Case: Nobilis Micro ATX OEM  MOBO: Intel DG41WV 775   

OS: Windows 10 Home  Keyboard:  Apple A1048  Mouse:  Rosewill Fusion C40

 

PC 3:

CPU: Intel Core 2 Duo E7500   GPU: AMD HD8490 1GB

RAM: 2x2GB Apacer 1333MHz DDR3    HDD: Seagate Barracuda 250GB 7200RPM

PSU: Generic HP 300W     Case: Nobilis Micro ATX OEM  MOBO: Intel DG31PR 775   

OS: Ubuntu LTS 18.04  Keyboard:  Microsoft RT2300  Mouse:  Rosewill Fusion C40

 

PC 4:

CPU: Intel 486DX2 50 MHz   GPU: Western Digital 90C24

RAM: 4MB Generic    HDD: 340MB Generic

PSU: IBM Charger     Case: ThinkPad 755C  MOBO: IBM Proprietary 

OS: Windows 3.1  Keyboard: Built In Keyboard  Mouse: Built In Nipple

 

Consoles: Wii, SNES, NES, N64, Atari 7800, Commodore VIC-20, Genesis, Dreamcast, PS1, PS2, and Steam Link.

 

Car: 2002 Subaru Outback Limited (Red)

Link to post
Share on other sites
Posted · Original PosterOP

Also my GPU stays at 60% usage and my CPU 40%.


PC 1:

CPU: AMD Ryzen 7 1800X    GPU: EVGA Superclocked GeForce GTX 1080

RAM: 2x8GB Corsair Vengeance LPX 3000MHz DDR4    SSD: Crucial MX500 500GB

PSU: Corsair CX750M V2   HDD: Seagate Barracuda Compute 3TB 7200RPM

Case: Phanteks Eclipse P400STG Red/Black   MOBO: ASRock X370 Killer SLI/ac

OS: Windows 10 Pro  Keyboard:  Corsair K68 Red  Mouse:  Corsair M65 Pro RGB 

 

PC 2:

CPU: Intel Pentium E5800   GPU: AMD HD6450 512MB

RAM: 1x2GB Kingston 1066MHz DDR3    HDD: Seagate Barracuda 250GB 7200RPM

PSU: Sparkle-Power 300W     Case: Nobilis Micro ATX OEM  MOBO: Intel DG41WV 775   

OS: Windows 10 Home  Keyboard:  Apple A1048  Mouse:  Rosewill Fusion C40

 

PC 3:

CPU: Intel Core 2 Duo E7500   GPU: AMD HD8490 1GB

RAM: 2x2GB Apacer 1333MHz DDR3    HDD: Seagate Barracuda 250GB 7200RPM

PSU: Generic HP 300W     Case: Nobilis Micro ATX OEM  MOBO: Intel DG31PR 775   

OS: Ubuntu LTS 18.04  Keyboard:  Microsoft RT2300  Mouse:  Rosewill Fusion C40

 

PC 4:

CPU: Intel 486DX2 50 MHz   GPU: Western Digital 90C24

RAM: 4MB Generic    HDD: 340MB Generic

PSU: IBM Charger     Case: ThinkPad 755C  MOBO: IBM Proprietary 

OS: Windows 3.1  Keyboard: Built In Keyboard  Mouse: Built In Nipple

 

Consoles: Wii, SNES, NES, N64, Atari 7800, Commodore VIC-20, Genesis, Dreamcast, PS1, PS2, and Steam Link.

 

Car: 2002 Subaru Outback Limited (Red)

Link to post
Share on other sites

maybe the game is not balanced/adjusted for hardware that you have, it happends in some games, like i got a gtx 1060 and new cod bo4 on low settings gets me 50-60fps and it crashes like every 45minutes.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×