Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Darell3

Need help with portforwarding Modem to external router.

Recommended Posts

Posted · Original PosterOP

So before i got a new gigabit router, my portforwards on the old current modem/router work fine. But when i bought a gigabit router and bridge the to together with a ethernet cable, WAN port on gigabit router to ethernet port on the modem, My portfowards no longer work. Default gateways changed, i know old modem (192.168.1.1) new one (192.168.0.1) I was aware of the change and i changed my settings to fit the new router.. I am using the gigabit router to connect to the internet, everything works fine. I portforwarded with portforward.com and when i went to listen to the port on canyouseeme.org the port will either say 'Connection timed out' or 'No route to Host' both the modem and router have DHCP enabled. Is there anyway to fix that i can use portforwards on my new router?

 

Gigabit router : TP-Link WR1043ND

 

 

Thanks,


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites

So before i got a new gigabit router, my portforwards on the old current modem/router work fine. But when i bought a gigabit router and bridge the to together with a ethernet cable, WAN port on gigabit router to ethernet port on the modem, My portfowards no longer work. Default gateways changed, i know old modem (192.168.1.1) new one (192.168.0.1) I was aware of the change and i changed my settings to fit the new router.. I am using the gigabit router to connect to the internet, everything works fine. I portforwarded with portforward.com and when i went to listen to the port on canyouseeme.org the port will either say 'Connection timed out' or 'No route to Host' both the modem and router have DHCP enabled. Is there anyway to fix that i can use portforwards on my new router?

 

Gigabit router : TP-Link WR1043ND

 

 

Thanks,

So your pc/ server is connected to the gb router, which is connected to the old one which the forward used to work fine on?

Have a look at this.

http://portforward.com/help/doublerouterportforwarding.htm

Link to post
Share on other sites

Your new router will have a different MAC. Reset it back up with a static DHCP lease or set the new router up with a static IP, either will work. Then set up the port forwards on your new router to your PC. Gateways changing makes no difference in your situation.

 

I would also recommend flashing the firmware with OpenWRT. Better speeds, more open firmware with more flexibility.

Link to post
Share on other sites
Posted · Original PosterOP

So your pc/ server is connected to the gb router, which is connected to the old one which the forward used to work fine on?

Have a look at this.

http://portforward.com/help/doublerouterportforwarding.htm

Currently, theres no computer connected to the modem apart from the router connecting via ethernet cable. Ive tried the link you sent me, i forwarded ports on modem to forward it to router. And from there i portwarded the ports to my computer, but still no luck. Ive tried DMZ on modem to router, no luck as well. Still getting connection timed out. Firewalls on my computer are off.

 

If this helps in anyway. KtxWyRi.png


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites
Posted · Original PosterOP

Your new router will have a different MAC. Reset it back up with a static DHCP lease or set the new router up with a static IP, either will work. Then set up the port forwards on your new router to your PC. Gateways changing makes no difference in your situation.

 

I would also recommend flashing the firmware with OpenWRT. Better speeds, more open firmware with more flexibility.

The new router does have a static IP.


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites
Posted · Original PosterOP

Wanna post the port forwarding page for both :D

I forwarded the specific port i needed. I also added the routers IP to DMZ, that does not work as well.

 

NmYcaQN.png

 

 

Tplink router:

 

dFdgB4d.png


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites

So if i have this right, 192.168.0.108 is your computer and 192.168.1.8 is your gb router?
You are running the server/service when you are testing right?

Link to post
Share on other sites
Posted · Original PosterOP

So if i have this right, 192.168.0.108 is your computer and 192.168.1.8 is your gb router?

You are running the server/service when you are testing right?

 

Yes my computer is 192.168.0.108 and yes the gb router is 192.168.1.8

 

and yes i am running the server/service when im testing.


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites

Yes my computer is 192.168.0.108 and yes the gb router is 192.168.1.8

 

and yes i am running the server/service when im testing.

Damn, that makes it hard :P

I'm afraid that everything looks like it is done well and should be working no problem.

I pulled an old router out of my cupboard and did this same thing and it worked fine, so good luck figuring it out! :D

Link to post
Share on other sites
Posted · Original PosterOP

Damn, that makes it hard :P

I'm afraid that everything looks like it is done well and should be working no problem.

I pulled an old router out of my cupboard and did this same thing and it worked fine, so good luck figuring it out! :D

hmm, thanks for the suggestions:)


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites
Posted · Original PosterOP

Damn, that makes it hard :P

I'm afraid that everything looks like it is done well and should be working no problem.

I pulled an old router out of my cupboard and did this same thing and it worked fine, so good luck figuring it out! :D

 

ALSO to mention, on my modem on port LAN1 i have the cable connecting to WAN port on my router. Do you think changing the port of the router instead of WAN port to the LAN port of the router then changing the LAN port IP to 198.168.1.8?

 

 

and is that two different IP address i see?

KUUYkG6.png

 

 

Anddd..... I cant setup bridge mode on the modem because it uses a PPPoA connection to the ISP, and router only supports PPPoE.


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites
Posted · Original PosterOP

This is darn weird, PS4 is connected to router and getting NAT type 2 (which means ports are open for it) uTorrent goes through UPnP for the ports. Damn it


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites

ALSO to mention, on my modem on port LAN1 i have the cable connecting to WAN port on my router. Do you think changing the port of the router instead of WAN port to the LAN port of the router then changing the LAN port IP to 198.168.1.8?

 

 

and is that two different IP address i see?

KUUYkG6.png

 

 

Anddd..... I cant setup bridge mode on the modem because it uses a PPPoA connection to the ISP, and router only supports PPPoE.

 

The External IP and Gateway are fine. With regards to the PPPoA/E, it might work. We deploy our routers with the option to have a bridge option where it will bridge DSL interfaces and present the client with an ethernet interface for ease of transition from VDSL to Fibre in the future, so I'd give it a go if I were you.

Link to post
Share on other sites
Posted · Original PosterOP

The External IP and Gateway are fine. With regards to the PPPoA/E, it might work. We deploy our routers with the option to have a bridge option where it will bridge DSL interfaces and present the client with an ethernet interface for ease of transition from VDSL to Fibre in the future, so I'd give it a go if I were you.

Ive tried to set the modem onto bridge mode, and i went on the router and typed the info on, and still no luck because connection on the modem is PPPoA and router only accepts Dynamic IP,StaticIP and PPPoE. Went back on the router restored it and typed the info and internet worked. So i guess maybe the router does not support PPPoA or it does not want to co-operate with the router. Or maybe i did the bridge mode configuration wrong. All i did was log in on modem as advanced and went to the WAN section and clicked next until it showed an option of bridge then from there i kept clicking next and restart modem. (did i do that wrong?)


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites

Ive tried to set the modem onto bridge mode, and i went on the router and typed the info on, and still no luck because connection on the modem is PPPoA and router only accepts Dynamic IP,StaticIP and PPPoE. Went back on the router restored it and typed the info and internet worked. So i guess maybe the router does not support PPPoA or it does not want to co-operate with the router. Or maybe i did the bridge mode configuration wrong. All i did was log in on modem as advanced and went to the WAN section and clicked next until it showed an option of bridge then from there i kept clicking next and restart modem. (did i do that wrong?)

 

I'm not entirely sure. If you can get internet connectivity behind the TP-Link router than it sounds like you're doing it right, and it's having a fit about the port forwards, or it would indicate the software listening or connecting on that port isn't working.

Link to post
Share on other sites
Posted · Original PosterOP

I'm not entirely sure. If you can get internet connectivity behind the TP-Link router than it sounds like you're doing it right, and it's having a fit about the port forwards, or it would indicate the software listening or connecting on that port isn't working.

Internet and everything works fine, its just i think that problem is double NAT'd on the modem making the portforwards not work. I have already added the routers IP for DMZ on the modem, and i put my portforwards on the router but still no luck :| I tried a UPnP program and when i listen for the port on canyouseeme.org instead of it saying 'Connection timed out' It says 'No route to host'. I tried bridge mode again today on the modem WAN and continued to brdige, then restarted modem, internet connectivity went off, went to my router, clicked on PPPoE typed in xxxx@vodafone.co.nz and the password, then i restarted router, But i dnt get internet connectivity.


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites
Posted · Original PosterOP

It seems that the port is going through the router, but the modem is blocking it.


| CPU: INTEL i5 6600k @ 4.6Ghz @ 1.328v | Motherboard: ASUS Z170-AR | Ram: G.SKILL 2x8GB 2400Mhz | CPU Cooler : Corsair H100i V2

| GPU: GIGABYTE GTX980Ti G1 GAMING | SSD: SAMSUNG 840 EVO 250GB  Storage: WD 1TB GREEN | OS: Windows 10 Pro 64bit | PSU: FSP 650W AURUM S |

<<<<< BLK-Phant0m >>>>>

 

Link to post
Share on other sites

If there is a way to disable the firewall on the modem, I would do that. (Basically forward all ports from modem to router). I feel like I am missing a fundamental part of the story though.


Spoiler

CPU: Intel Core i7 3770K  CPU Cooler: Corsair H100 (2x SP120 Quiet Edition)  Motherboard: ASUS Sabertooth Z77  RAM: Corsair Vengeance 8GB 1866MHz  PSU: Corsair AX850  GPU: EVGA GTX 670 FTW 2GB  SSD: Samsung 850 Evo 500GB

 
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×