Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
John.U

AMD GPU doesn't feel like 60fps

Recommended Posts

Posted · Original PosterOP

I have a Intel and Nvidia setup with a gtx 560 ti and 3570k for my personal rig, but this is the second time I've built a  AMD based gpu rig with the 7000 series and while playing games it does not feel nearly as smooth as my computer, even though they are both running at 60fps. The AMD rig seems to microstutter/stutter. Is this just a common thing with AMD gpu's, and is there any fix? Also I've tried the Riva Tuner fix where you cap the fps to 59.

Link to post
Share on other sites

which 7xxx series gpu did you use? there's a significant difference between a 7750 and a 7970


-The Bellerophon- Obsidian 550D-i5-3570k@4.5Ghz -Asus Sabertooth Z77-16GB Corsair Dominator Platinum 1866Mhz-x2 EVGA GTX 760 Dual FTW 4GB-Creative Sound Blaster XF-i Titanium-OCZ Vertex Plus 120GB-Seagate Barracuda 2TB- https://linustechtips.com/main/topic/60154-the-not-really-a-build-log-build-log/ Twofold http://linustechtips.com/main/topic/121043-twofold-a-dual-itx-system/ How great is EVGA? http://linustechtips.com/main/topic/110662-evga-how-great-are-they/#entry1478299

Link to post
Share on other sites

Some people reported microstuttering issues with certain 7xxx cards, though its a very low percentage. i also have a 7970, but never had any problems with it.

Edit: Always try to use latest beta driver available, if you have AMD :)


CPU: i7-4770k (LM modded) - MB: GA-Z87X-UD3H - RAM: HyperX, 16GB 1866MHz - GPU: Palit GTX 980Ti Super - Storage: 1TB HDD + 500GB/120GB SSD (850 Evo/840) - Monitor: Predator XB271HU - PSU: 700W BeQuiet 80+ Gold

Link to post
Share on other sites

both running a 60fps ?

AMD released a fix a while ago PCper and anand proved that they fixed the issue


If your grave doesn't say "rest in peace" on it You are automatically drafted into the skeleton war.

Link to post
Share on other sites

both running a 60fps ?

AMD released a fix a while ago PCper and anand proved that they fixed the issue

Amd frame pacing technology only works on crossfire setups
Link to post
Share on other sites

I'm running two HD 7950s in crossfire, and I don't notice any stutter at all....

 

 

I would hope not....


"A picture is starting to form here... I wonder if it's accurate? Some pieces don't quite seem to fit. Or maybe I just don't like the way it looks."

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×