Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
GGWP1337

Rog 1070 Temps Help?

Recommended Posts

Posted · Original PosterOP

Case I am using is the Phanteks P400S Tempered Glass. I have always had the silent "trays" on the top, i have only the 2 fans in the case back and front, that was with the card.

All My GPU is the 1070 ROG Strix. from September 16. Been cleaned a few times cause of dust. Ryzen 1700 with stock cooler, running stock of course.

Here is the funny part, and I have asked about it a lot. But after i cleaned my gpu from dust i suddenly increased 2-3 degress in my games my ambient temp as for now is 27.1 degress (I don't know how accurate, give or take 1-2 degress)

But it seems like my gpu still idles at the same temp for this heat 40-41 degress. I don't feel like I have done anything to "damage" the card, i had some trouble putting in back in, but i then got it (Maybe i have pressed a bit on the shroud to the fans, but they are all running and not different) I used a CompuCleaner Xpert to clean it.

Here is from a benchmark few days ago: https://i.imgur.com/B0DY4VS.png (It's heavens on Ultra extreme 1080p) Are the fan speed, temp and fan rpm too much for a card like mine? Could I possible have damaged something in my card?

Also here i've gotten confirmed that the heatsink is still making fully contact to the chip. QbyUjgK.jpg?1

Anyone knows if i am just unckly and have done something to my card, or what?

Link to post
Share on other sites

I wouldn’t worry it, you are still well within the safe temperature threshold. 


******If you paste in text into your post, please click the "remove formatting" button for night theme users.******

CPU- Intel 6700k OC to 4.69 Ghz GPU- NVidia Geforce GTX 970 (MSI) RAM- 16gb DDR4 2400 SSD-2x500gb samsung 850 EVO(SATA) Raid 0 HDD- 2tb Seagate Case- H440 Red w/ custom lighting Motherboard - MSI Z170 Gaming A OS- Windows 10 Mouse- Razer Naga Epic Chroma, Final Mouse 2016 turney proKeyboard- Corsair k70 Cherry MX brown

Link to post
Share on other sites
Posted · Original PosterOP
59 minutes ago, bgibbz said:

I wouldn’t worry it, you are still well within the safe temperature threshold. 

Okay, it's just some of the reviews I read they hit 62-65 max. :)

Link to post
Share on other sites

I think it runs slightly hotter than it should. Try removing the side panel to see if it's an airflow issue since P400S isn't the greatest case for airflow. 

 

My OC'd Strix GTX 1070 won't go past 66C under load when fans are running at 1450 RPM (quiet fan profile). If I remove the side panel, temps drop down to 63C. My case is Fractal Design Define Mini C with 2 x 140mm intake fans and 1 x 120mm exhaust.


Intel Core i5 9600K 4.9Ghz / Gigabyte Z390 M Gaming / Thermalright HR-02 Macho Rev.B / 16GB DDR4 2800Mhz / Asus Strix GTX 1070 8GB / Samsung EVO 970 250GB / Samsung EVO 850 250GB / Crucial BX100 250GB / WD Blue 2TB / Corsair RM550x / Fractal Design Define Mini C / Windows 10 / 

Link to post
Share on other sites

i agree with lare add more fans or better ones if your that concerned i have the same case and gpu with a x470 mb and ryzen 5 2600x with a AIO cpu cooler on push/pull with a 120mm and 140mm exhaust fans so i have total 5 120mm and 1 140mm

Link to post
Share on other sites
Posted · Original PosterOP
16 hours ago, Lare111 said:

I think it runs slightly hotter than it should. Try removing the side panel to see if it's an airflow issue since P400S isn't the greatest case for airflow. 

 

My OC'd Strix GTX 1070 won't go past 66C under load when fans are running at 1450 RPM (quiet fan profile). If I remove the side panel, temps drop down to 63C. My case is Fractal Design Define Mini C with 2 x 140mm intake fans and 1 x 120mm exhaust.

Well, im living in a "hotter" apartment at the times. I have the two top covers on to keep some dust out, as well as I only have 2 fans, but still wonder why the temp raised after cleaning, and when i gamed before i cleaned it.

I just need to know if i might have broken anything.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×