Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
bounty96

2,5" SSD become "SATAFIRM S11"

Recommended Posts

Posted · Original PosterOP

Hello all, I have a question.

 

I recently bought two SSD's. "ViperTeq UP Series 120GB Sata3" (2,5").

One for a Laptop and one for a AIO PC.

 

I plugged them in and formatted with NTFS under Windows 7 - all good.

But them I tried to clone my normal HDD's with Acronis True Image 2018 to the SSD's an there was an error. Something like: "can't read sector xxxxx from drive 1..."

 

And now BOTH SSD's on both computers are shown as "SATAFIRM S11" in the BIOS. (Before there are shown as "ViperTeq UP..."

 

I have tried the SSD's in other PC's (new ones with UEFI and old ones with BIOS) but in all PC's the SSD is shown as "SATAFIRM S11" in the BIOS.

And Windows can't put a partition on it. I can't even initialize it.

 

I searched in google about this problem, but there are only some unresolved forum threads or some russian pages where I can't see a solution.

I have tried some linux live systems, but they can't work with the SSD's to.

 

How can I fix that problem? Can I solve that at all? Or is there no solution for a normal person?

Foto 13.06.18, 10 47 51.jpg

Link to post
Share on other sites

Have you tried different SATA cables?

Check if the connectors aren't loose

 

You sure this is a legit and not a counterfeit drive? Usually the second ones will only work under windows and have a hacked firmware that reports a different capacity than the one the drives actually has, some manufacturers just use cheap 16GB SD cards and a firm that reports the drive is 240GB or something like that and if you try to reformat it or create partitions the drive dies

With that said...

57 minutes ago, bounty96 said:

But them I tried to clone my normal HDD's with Acronis True Image 2018

That program always causes trouble, I remember my old 80GB dissapearing from everywhere too, the drive itself was intact but the MBR and a ton of sectors were corrupted, it took me days to get it working again using HDD Regenerator (tried all of the other tools and DOS commands to fix MBR and none of them worked because acronis caused a disaster)

 

So don't worry, this can be fixed... I'd start by booting some repair tools using a floppy disk or a CD (Hiren's Boot CD)

If you can get at least the partition table fixed you could repair the rest of it.

Oh and next time you want to clone use a program that runs outside Windows, like Clonezilla, gl


ASUS X470-PRO • R7 1700 4GHz • Corsair H110i GT P/P • 2x MSI RX 480 8G • Corsair DP 2x8 @3466 • EVGA 750 G2 • Corsair 730T • Crucial MX500 250GB • WD 4TB

Link to post
Share on other sites
Posted · Original PosterOP

I have tried them on different Sata Ports (with my other drives plugged and as a single drive without my other drives).

I tried it in a external 2,5" USB Case. I plugged it even in another PC. But the same problem on all connections.

About the drive I don't know if it's not a fake one... this is where I get it:

https://www.ebay.de/itm/ViperTeq-UP-Serie-interne-SSD-Solid-State-Drive-NAND-Flash-2-5-SAT-120GB/302754380368?hash=item467d913a50:g:31EAAOSw8OpbDtE3

 

After the SSD become "SATAFIRM S11" instead of the real name I have tried with a Knoppix Live Linux CD and with GParted Live CD. But they are all show me

"searching for /dev/sda" and stock by this message.

 

I used the live boot medium which I created with Acronis under Windows and then booted from it.

I used it because the original HDD was 320GB (but only 60GB used) and it can clone on smaller drives (like my 120GB SSD).

 

But the next time I shrink the partitions on the HDD to fit into the smaller and use clonezilla instead.

 

I have heard of HDD Regenerator so I think I give it a try. And I don't care if the SSD will be formated because I have the files on the HDD and I only want the SSD to work.

 

But one more question: Even if I can fix the partition table, is the SSD still shown as "SATAFIRM S11" in the BIOS? Or is that fixed too?

Because I think the name which is shown in the BIOS is more on the "firmware level" on the drive instead on the "partition level"?

Or am I wrong with that?

Link to post
Share on other sites

This problem is related to the phison controller firmware. I've found a post elsewhere with a possible fix for kingston drives, don't know if it would work with your drive though. The official solution for kingston a400 drives that also have this problem is to RMA AFAIK.

Link to post
Share on other sites

Hello, I have a Kingston A400 240GB [SA400S37/240G, native firmware on label: SBFK71B1] with the infamous SATAFIRM S11 problem, happened last week after 1,5 years of usage. I have backups of my data, so what I am looking for is to restore the health of the drive in order to keep using it; I don't care if the data is wiped in the process: I am prepared to reinstall the OS.

 

I have tried running repairS11 utility by vlo.name when using a SATA-to-USB adapter phison_flash_id detects PS3108 Controller so the repair utility refuses to run; when using built-in SATA port on my Laptop (AHCI mode set in BIOS) the detected Controller is PS3111, the repair utility ends correctly with a success message, but the problem remains. What else can I do?

 

By any chance has anyone tried using PhisonToolBox v1.17 by usbdev.ru? By all means I just want to exit from 'Safe Mode' state, restore 'Ready' state of the drive and just reinstall my operating system over it, I do not care about the data because I have backups.

 

Another user claimed he restored the same drive model using SBFKB1C3.zip (media.kingston.com) and s11-flasher 2.0 (vlo.name). Does this actually give a new life to the SSD (even if it erases the data) and will it void the remaining warranty of the unit?

phison_flash_id.txt


All my contacts, social media and more! https://shark.lost-soldiers.org

Link to post
Share on other sites

Yes, this seems to be a Phison S11 issue. Usually you want to Secure Erase when you have SSD issues but this prevents that. Shark.93 is correct: you need to use other tools. Specifically the S11 firmware upgrade tool (USBDev) if VLO's S11 repair doesn't work (VLO also provides the S11 firmware flasher v2). Specifically in the S11 firmware flasher v2 it says: "If you want to start the operation (fixing) of the 'SATFIRM S11', remove it with the following:
http://vlo.namehaps000/tmph/repairs11.rar." If you need to use the USBDev tool, you start with UpgradeFW_SBFM71.0 which reinitializes the firmware.

Link to post
Share on other sites
12 minutes ago, NewMaxx said:

If you need to use the USBDev tool, you start with UpgradeFW_SBFM71.0 which reinitializes the firmware.

Oh, thank you for the helpful tip! Have you gone through this procedure before? I did not know that you should reinitialize the firmware, I thought you would just flash the upgraded firmware onto the SSD and with fingers crossed it should restore the drive (I've just emailed Kingston Support and they indeed said "the SATAFIRM issue has been addressed via a firmware patch and all new builds now ship with this firmware").

 

Oh, wait, I have mentioned two possible softwares and I was thinking to try firmware flasher v2; instead you were talking about PhisonToolBox when referring to UpgradeFW_SBFM71.0. One thing I am not totally sure is if I should run s11-flasher2-toshiba.cmd or s11-flasher2-micron.cmd, I suppose it's the latter but I am not sure what is the actual version number: "run S11-flasher-toshiba.cmd or s11-flasher-micron.cmd depending on firmware version"

Spoiler

The firmware version must match the flash used.
list of known standard firmware:
0x.x - mlc / tsb15
1x.x - tlc / tsb15
2x.x - mlc / micron3d (32L)
5x.x - tlc / hynix (16nm)
6x.x - tlc / tsb3d (bics2 - 48L and bics3 - 64L, bics4 - 96L), bics4 support probably from 61.3 from 2019
7x.x - tlc / micron3d (B0KB)
8x.x - mlc / tsb15 (ufs?)
9x.x - mlc / tsb15
Ax.x - tlc / intel3d (L06B-> B0KB)
Bx.x - tlc / micron3dv2 (64L - B16A / B17A)
BA.x - tlc / micron3dv2 (64L - B17A)
Kx.x - qlc / intel3dv2 (64L - N18A)
Ex.x - tlc / hynix3d (72L)
Jx.x - tlc / micron3dv3 (96L - B27A) ???
Kingston, transcend firmware numbering obey the same system.

ocz:
10.x - tlc / tsb15 (tl100) - an analogue of the standard 1x.x
12.x - tlc / bics3 (tr200) - an analogue of the standard 6x.x
13.x - tlc / bics3 (tr200) - an analogue of the standard 6x.x
15.x - tlc / bics4 (tr200)
17.x -? (tr200)

No firmware versions were found at the time of writing this file:
Ax.x, Kx.x, Jx.x

 


All my contacts, social media and more! https://shark.lost-soldiers.org

Link to post
Share on other sites

I own no Phison S11 drives because I know how unreliable they can be. In fact I own no Phison drives whatsoever! No small feat since I'm swimming in SSDs.

 

However the procedure is basically the same regardless of controller. You need to match the flash type though, yes. Typically the A400 and its clones came with either 2D/planar Toshiba TLC or Intel/Micron's 32L/384GB TLC depending on region. Usually you ID this by checking VLO's S11 ID tool although it's possible to guess if you know the firmware revision (CrystalDiskInfo), Kingston labels their NAND so you can't know by looking at it directly although the configuration/style of package can tell you what it is in some cases (with non-A400s, you can just look at the flash). It looks like you found the list for firmware/flash combination. But yes a firmware update should fix this - reason I list those two flash types as this issue seems to be with earlier firmware which relates to the older flash.

Link to post
Share on other sites

Here is how i got it fixedup , for some reason Windows 10 broke the drive i formated it under Linux and it started showing 120gb statafirm. i downloaded  Phison S11 firmware flasher v2 and Phison S12 flash id

 from here  http://vlo.name:3000/ssdtool/ and the firmwares from here http://www.usbdev.ru/?wpfb_dl=6583 .

You  need flasher id to check your firmwarevarsion and the memory if it is micron or toshiba. 

When you see them you can unzip the fw zip find yours name it fw.bin and put it in the same directory as Phison S11 flasher ,  run 1  of the  2 bin files toshiba or micron depending on your memory , it will  make fw.exe to be able to run now . 

Run it update the firmware  , restart the pc and you shoud be able to see your ssd again 

mine was kingston A400 120g

Link to post
Share on other sites

Thank you very much, I have posted in other forums and vlo himself told me (by looking at the phison_flash_id.txt file) that the "number of defects" on my drive is already at the limit for a 240GB SSD (he refers to "Defects All (per plane) Early Later" inside the file); so I guess in the end I will hand it to the RMA Team. Still, has anyone tried Secure Erase, maybe through Linux? It is said to have worked some times, to recover an SSD in this state.


All my contacts, social media and more! https://shark.lost-soldiers.org

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×