Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Get Booda

Windows 10 1803 microphone woes

6 minutes ago, Get Booda said:

Hello all, it's surely been a long time since I've seen any of you wonderful people, to the point where I forgot the name of my account! Anyway, I've been having some trouble with my microphones on the new windows 10 build 1803. My blue snowball iCE is recognized in windows and says is working properly, however no matter what settings I use the mic never has any levels. I've tried it on macOS and it works fine, and I've tried my other microphone, a rock band mic (also connects via USB) and I've had the same issue. My mic worked perfectly fine until a few days ago, presumably when windows auto updated to 1803 (grrrrr). Any ideas?

 

Open up settings, go to "privacy", then select Microphone.

 

Ensure "Microphone access for this device" is on, and ensure that individual apps are not disallowed from accessing it.

 

mic.png

Recommended Posts

Posted · Original PosterOP

Hello all, it's surely been a long time since I've seen any of you wonderful people, to the point where I forgot the name of my account! Anyway, I've been having some trouble with my microphones on the new windows 10 build 1803. My blue snowball iCE is recognized in windows and says is working properly, however no matter what settings I use the mic never has any levels. I've tried it on macOS and it works fine, and I've tried my other microphone, a rock band mic (also connects via USB) and I've had the same issue. My mic worked perfectly fine until a few days ago, presumably when windows auto updated to 1803 (grrrrr). Any ideas?

Link to post
Share on other sites
Posted (edited) · Best Answer
6 minutes ago, Get Booda said:

Hello all, it's surely been a long time since I've seen any of you wonderful people, to the point where I forgot the name of my account! Anyway, I've been having some trouble with my microphones on the new windows 10 build 1803. My blue snowball iCE is recognized in windows and says is working properly, however no matter what settings I use the mic never has any levels. I've tried it on macOS and it works fine, and I've tried my other microphone, a rock band mic (also connects via USB) and I've had the same issue. My mic worked perfectly fine until a few days ago, presumably when windows auto updated to 1803 (grrrrr). Any ideas?

 

Open up settings, go to "privacy", then select Microphone.

 

Ensure "Microphone access for this device" is on, and ensure that individual apps are not disallowed from accessing it.

 

mic.png

Edited by Tabs
Fixed broken pic
Link to post
Share on other sites
6 minutes ago, Get Booda said:

Hello all, it's surely been a long time since I've seen any of you wonderful people, to the point where I forgot the name of my account! Anyway, I've been having some trouble with my microphones on the new windows 10 build 1803. My blue snowball iCE is recognized in windows and says is working properly, however no matter what settings I use the mic never has any levels. I've tried it on macOS and it works fine, and I've tried my other microphone, a rock band mic (also connects via USB) and I've had the same issue. My mic worked perfectly fine until a few days ago, presumably when windows auto updated to 1803 (grrrrr). Any ideas?

Roll back to 1709, 1703 or anything before 1803

http://www.thewindowsclub.com/rollback-uninstall-windows-10-creators-update


Fine you want the PSU tier list? Have the PSU tier list: https://linustechtips.com/main/topic/1116640-psu-tier-list-40-rev-103/

 

Stille (Desktop)

i7-8700k @5.15Ghz (Delidded) - Cryorig H7 Ultimate - 16GB Vengeance LPX - MSI Armor GTX 1080 - SanDisk Plus 480GB - Crucial MX500 500GB - Intel 660P 1TB SSD - (2x) WD Red 2TB - EVGA G3 650w - Corsair 760T

Evoo Gaming 15" (Finally got rid of the MacBook :D
i7-9750H - 16GB DDR4 - GTX 1660Ti - 480GB SSD M.2 - 1TB 2.5" BX500 SSD 

El-Sleep (ProxMox server)

2x Xeon E5-2667  - 48GB ECC DDR3 - Quadro 4000 - Dell H310 HBA (Flashed with IT firmware) -500GB Crucial MX500 (Proxmox Host) Kingston 128GB SSD (FreeNAS dev/ID passthrough) - 4x4TB Toshiba N300 HDD

Toys: Oculus Rift CV1, Oculus Quest, about half a dozen raspberry Pis (2b to 4), Arduino Uno, Arduino Mega, Arduino nano (x3), Arduino nano pro, Atomic Pi. 

Link to post
Share on other sites

Go to your settings (you can press the windows key and type settings) then select privacy. Next click microphone on the left side of the privacy window and ensure that the microphone is enabled.

 

Link to post
Share on other sites

Privacy option in the Settings panel, your program is blocked from the microphone.

You had a pop-up notification informing you this

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, GoodBytes said:

Privacy option in the Settings panel, your program is blocked from the microphone.

You had a pop-up notification informing you this

I guess I should start paying attention to those ;p Funny enough windows didn't detect level at all, but the mere act of going into that settings panel and not changing anything made it work... I don't know, windows is weird. Anyway, thanks you guys are a great community.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×