Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Greta

Microphone only works when "Listen to this device" is active

Recommended Posts

Posted · Original PosterOP

To clear some things up, while I can hear my microphone and it shows that it recognizes sound when "Listen to this device" is active, it doesn't work in example discord, I will add a video below where I show this off. 

 

In the video I'm always making a noise, so even when "Listen to this device" is disabled I am still making sounds. Also, the sound you can hear is not directly from the microphone, however it the desktop sound that is coming from the mic.

 

 

 

Link to post
Share on other sites

I'm having this exact issue too since last night!


i7 4790K, EVGA GTX 780 Ti SC w/ACX, MSI Z97 Gaming 7, NZXT Phantom 530, Samsung 850 Pro 512GB, BenQ XL2411T 1080p 144Hz, BenQ GL2250 1080p 60Hz, Razer Arctosa, Logitech G400s, Roccat Savu, Audio Technica ATH M50X, Behringer Xenyx 1204USB Mixer

Link to post
Share on other sites

Seen this in a couple of places on the forum too recently; have any updates been installed in the past short while?


Desktop: i7-4790k Build - ALMOST COMPLETE Mobile: OnePlus 5T | Bell Unlimited National Calling & Texting + 10GB Data
Laptop: Dell XPS 15 9560 (the real 15" MacBook Pro that Apple didn't make) Tablet: HP Touchpad (Android) | ASUS ME302C
Camera: Canon SX280 + Rebel T1i (500D) | Sony HDR-AS50R | Panasonic DMC-TS20D Music: Spotify Premium (CIRCA '08)

Link to post
Share on other sites
38 minutes ago, Greta said:

-snip-

Hey, sorry for this not being relevant but how did you make your Windows UI look that way? Specifically the lack of a background for the task bar and the dark theme?


“I have a dream that my four little children will one day live in a nation where they will not be judged by the color of their skin, but by the content of their character.” - Martin Luther King Jr.


The Desktops

Main Rig: CPU: Intel Core i7-7700K | RAM: 16GB DDR4-2400 | Motherboard: Asus Strix Z270E | Storage: 256GB SSD, 2x1TB HDD | GPU: GTX 1080 Strix O8G

Cooling: Dual 240mm AIOs | Case: Fractal Design Meshify C (modified) | PSU: EVGA GS 550W

VR Rig: CPU: Intel Core i5-3570 | RAM: 8GB DDR3-1600 | Motherboard: Gigabyte GA-Z68X-UD3H-B3 | Storage: 256GB SSD + 750GB HDD | GPU: GTX 1060 6GB SSC Cooling: 92mm Tower Cooler Push/Pull | Case: Silverstone GD09B | PSU: Cooler Master Silent Pro M 700W | HMD: Oculus Rift CV1 with 2 sensors

Server: CPU: 2x Intel Xeon E5645 | RAM: 16GB DDR3-1333 ECC | Motherboard: Supermicro X8DAi | GPU: Sparkle GTX 550 Ti

Cooling: 92mm Tower Cooler, Zalman CNPS9900MAX-R | Storage: 128GB SSD + 1TB HDD | Case: Phanteks Enthoo Evolv ATX TG | PSU: Corsair CX550M


The Portables

Lenovo X230: CPU: Intel Core i5-3210M | RAM: 8GB DDR3-1600 | Storage: 128GB SSD | GPU: Intel HD 4000 | Lenovo 44+ 84Wh Battery

MacBook Air (Early 2015, A1466) 13": CPU: Intel Core i5-5250M | RAM: 4GB DDR3-1600 | Storage: 256GB SSD | GPU: Intel HD 6000

iPhone XS Max 64GB Space Grey | Apple Watch Series 2 42mm | AirPods (2nd Generation)

Link to post
Share on other sites

 

This fixed it for me. Allow apps to use microphone in Windows privacy settings.

 

 


i7 4790K, EVGA GTX 780 Ti SC w/ACX, MSI Z97 Gaming 7, NZXT Phantom 530, Samsung 850 Pro 512GB, BenQ XL2411T 1080p 144Hz, BenQ GL2250 1080p 60Hz, Razer Arctosa, Logitech G400s, Roccat Savu, Audio Technica ATH M50X, Behringer Xenyx 1204USB Mixer

Link to post
Share on other sites

I am having an issue identical to the OP on Windows 10. Issue first started 4 days ago (May 10) and affects any/all sound input devices I have tried. (Microphones and mixers, both 3.5mm and USB.)

 

The "allow apps in Windows privacy settings" does not fix this issue for me, and at this point I've also tried removing all audio devices and drivers via the Device Manager and recognizing/reinstalling them one by one. The only thing that appears to function is the, "Listen to this device" option. No clue if this is relevant, but while Windows and the Device Manager clearly see the microphone and allow me to adjust settings; no form of input is recognized through any software or apps I've tried thus far.

 

As far as updates: I'm not certain, but this issue may have coincided with a system update for me (I can't remember if there was an actual system update, or simply some Windows Defender patch).

 

Not sure what to do at this point beyond an OS refresh (blargh), so any help is greatly appreciated. I'd also like to know from the OP whether or not the privacy settings fixes your issue (if so, then maybe I've just done something wrong on my end). Thanks.

Link to post
Share on other sites

EDIT: A restart after changing the privacy settings has fixed it for me.

 

Same issue here. 

 

Privacy settings did not change anything for me.

 

Issue started with the latest windows update.

 

Also, even when I have "listen to this device" checked and I can hear myself, discord still doesn't pick up my mic.

Link to post
Share on other sites

I found a fix, and hopefully it works for you too.
If you go to "Sound" ( Where you can view "Playback, Recording, Etc."
Click on the communications tab.
It should be marked on "Do nothing", but if you change it to "Mute all other sounds" then reset it to "Do nothing" (If you dont, it will mute your audio), it should re - enable your mic. Its what worked for me

 

Link to post
Share on other sites

UPDATE: Fixed the issue.  To anybody getting drivers from the manufacturer, don't.  Most the time they are outdated.  It pains me to say this, but I used the free version of DriverEasy.

 

New member here... created an account just to find a fix for this issue.

I am having the same issue, just updated Windows 10 last night and I am now having this issue.  So I can say with 99% confidence the update caused the problem.  

I have tried:

-reinstalling drivers

-disabling drivers, testing, then re-enabling

-different mic inputs (two headsets and laptop mic, none work)

-enabling mic use under privacy settings

-going to sound->communications tab-> changing what is checked  (I have changed it back to "Do Nothing")

 

All help is appreciated, thanks everyone!

 

laptop: Gigabyte Aero 15

Link to post
Share on other sites
On 5/16/2018 at 10:06 PM, glacierr said:

I found a fix, and hopefully it works for you too.
If you go to "Sound" ( Where you can view "Playback, Recording, Etc."
Click on the communications tab.
It should be marked on "Do nothing", but if you change it to "Mute all other sounds" then reset it to "Do nothing" (If you dont, it will mute your audio), it should re - enable your mic. Its what worked for me

 

This fix courtesy of Glacierr worked for me, though I also allowed apps to use my mic from trying earlier tips. Additionally, I cycled between "mute" and "do nothing" a few times, before noticing that it actually worked. Also had to hang up and reconnect to the discord call I was in.

Link to post
Share on other sites
On 5/16/2018 at 10:06 PM, glacierr said:

I found a fix, and hopefully it works for you too.
If you go to "Sound" ( Where you can view "Playback, Recording, Etc."
Click on the communications tab.
It should be marked on "Do nothing", but if you change it to "Mute all other sounds" then reset it to "Do nothing" (If you dont, it will mute your audio), it should re - enable your mic. Its what worked for me

 

This fixed it for me.

Link to post
Share on other sites

I found a solution that atleast works for me.

 

Just go to Settings > Privacy > Microphone, and then you see a ''allow apps to acces your microphone''. Put that on and right there baby your mic works again.

 

 

Link to post
Share on other sites

I would just like to personal thank every one here, spent 4h trying to get one of my clients mics to work after a windows update broke it, Every website saying "uninstall and reinstall drivers" but the "listen to this device" worked, apon using this advice it has worked again!

So thank you all for the fix!, this windows 10 update issue is still going on till today so this tread is very useful <3

Link to post
Share on other sites
On 5/14/2018 at 7:09 PM, spencermehta said:

 

This fixed it for me. Allow apps to use microphone in Windows privacy settings.

 

 

I Feel So Dumb xD thank you. I Disabled everything as Microsoft is poopy xD. and i guess when i did that i forgot to turn the microphone back on like i normally do xD Or Maybe it wasn't my fault? as some people were saying windows update turned it off? Who knows tbh xD

(Yes alot of happy faces XD)

Link to post
Share on other sites
On 5/14/2018 at 3:09 PM, spencermehta said:

 

This fixed it for me. Allow apps to use microphone in Windows privacy settings.

 

 

Thanks very much for that. Thought I was losing my mind. Frustrating to say the least. =D

Link to post
Share on other sites
On 5/31/2018 at 10:02 PM, dapeep said:

This fixed it for me.

I've had this issue for awhile now, and this fixed it for me along with changing my microphone to allow apps, but after  changint the setting to allow apps to use it the issue wasn't fixed until I changed it to do nothing.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×