Jump to content
bomberblyat

Windows 10 Update is going on without permission

fuck it xD  i will just update it and hope i dont get bsod hell

Recommended Posts

Posted · Original PosterOP

Hi!

 

I updated windows once, then i stopped windows update from services.msc (i set it disabled and stop so it should not go on, this has worked before), because i do not want to update more windows 10, it deletes my disable from windows 10 updates everytime i reboot my pc or something. Any help is appreciated

(Reason why i want to stop windows 10 updating is, it pops up random shit that i couldnt give a fuck some security bs etc, and i do not want it to fuckup my pc, like random reboots coz windows needs to update n stuff, DO NOT QUESTION my reasons)

 

Link to post
Share on other sites

Disable automatic updates

 

Settings -> Windows Update -> Advance Options

 


Intel i7-4770K - Asus Maximus Hero VI - 2x8GB 2400Mhz G.SKill Trident - AMD 7950 3GB - Noctua DH-N14 - Samsung 840 250GB - CM Storm Trooper - Corsair AX760 - Asus Xonar Essence STX

 

Link to post
Share on other sites
3 minutes ago, TheFlyingSquirrel said:

Disable automatic updates

 

Settings -> Windows Update -> Advance Options

 

Pretty sure that you can't interrupt updates permanently on Windows 10 Home. It was a pro feature iirc.


PC Specs - AMD Ryzen 7 2700X MSI X370 Gaming Plus 16GB Corsair Vengeance LPX DDR4-3000 - Asus GTX1060 Dual 6GB OC Intel 600p 256GB & Crucial M550 512GB Fractal Define R5 CM G650M W8.1Pro

Link to post
Share on other sites

Set your connection as metered as well, this way it will never auto-download updates, but will ask permission.

Settings>Network>Status>Change connection properties>Metered (Yes)

Link to post
Share on other sites
12 minutes ago, bomberblyat said:

Hi!

 

I updated windows once, then i stopped windows update from services.msc (i set it disabled and stop so it should not go on, this has worked before), because i do not want to update more windows 10, it deletes my disable from windows 10 updates everytime i reboot my pc or something. Any help is appreciated

(Reason why i want to stop windows 10 updating is, it pops up random shit that i couldnt give a fuck some security bs etc, and i do not want it to fuckup my pc, like random reboots coz windows needs to update n stuff, DO NOT QUESTION my reasons)

 

Windows 10 doesn't restart your PC, unless you ignore the multiple warnings.

I don't know what pop-up you are talking about. All I can think about is Windows Defender telling you the scan result, which you can turn off.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, GoodBytes said:

Windows 10 doesn't restart your PC, unless you ignore the multiple warnings.

I don't know what pop-up you are talking about. All I can think about is Windows Defender telling you the scan result, which you can turn off.

Alright, but do you know any way to stop windows update come on, on every reboot 

Link to post
Share on other sites
1 minute ago, bomberblyat said:

Alright, but do you know any way to stop windows update come on, on every reboot 

yes install the updates - like any sane person does these days :-)

Link to post
Share on other sites
19 minutes ago, ItsTheDuckAgain said:

yes install the updates - like any sane person does these days :-)

so im not sane (inane?) because i do this exact thing too?

Link to post
Share on other sites
24 minutes ago, bomberblyat said:

Alright, but do you know any way to stop windows update come on, on every reboot 

You should have at worst 1 update per week (beside Windows Defender ones, but those don't need to restart your PC).

If it is the same update coming back, then something is definitely wrong (obviously), and we need to see in trying to correct the problem so that the update is successful, and it stops bugging you.

 

Oh, also, in Windows, something that will probably interest you, you can set your "Active Hours". It is found under the Windows Update section in the Settings panel. It tells Windows to not do Windows updates during a large time frame that represent a time where you don't want any down time, slow down, or detraction from it. And the cool thing about it, is that  even if you manually trigger a Windows Update during your Active Hour period, once it will need a restart, it will tell you that it will do after you are past the defined active hours, and even prompt you again to be sure when the time comes.

 

Also, make sure this option is turned on:

 

Capture.PNG.64ea0f6409bc63f29d75ac4ab187056e.PNG

 

(Settings > Update & Security > Windows Update > Advance Options)

 

And it might also interest you that, Windows Update has the ability to have it's download throttled, to reduce the impact on your internet activity.

Again under Windows Update section in the Settings panel, go under "Delivery Optimization". :)

 

 

Link to post
Share on other sites

I've had to take to blocking windows update at router level since I also noticed the old trick of disabling the service was no longer reliable. Windows can't update if it can't reach the servers. I only turn off that rule when I choose to do the updates, not when MS thinks is good. That reminds me, now is a good time to install the February updates before the March ones come out. I don't like to be first to update. Someone else can work out what's broken.


Coffee tasting: Asrock Z370 Pro4, i3-8350k @ 5.0 GHz, Noctua D15, G.Skill TridentZ 3000C14 @ 3866C17 2x8GB, R7 260X, ancient OCZ PSU, Corsair 600C, Crucial BX300 120GB

Main rig: Asus Maximus VIII Hero, i7-6700k stock, Noctua D14, G.Skill Ripjaws V 3200 2x8GB, Asus 1080 Ti Strix OC, Corsair HX750i, In Win 303 NVIDIA, Samsung SM951 512GB, Optane 900p 280GB, Crucial MX200 1TB, Sandisk 960GB, WD Blue 1TB, Acer Predator XB241YU

Ryzen rig: Asus Prime X370-Pro, R7 1700, Corsair H110i GTX, Crucial Ballistix 2666 2x4GB, Vega 56, Corsair CX550M, CoolerMaster MasterBox, Kingston 240GB, Acer RT280K

VR rig: Asus Z170I Pro Gaming, i7-6700k stock, Silverstone TD03-E, Kingston Hyper-X 2666 2x8GB, Zotac 1070 FE, Corsair CX450M, NZXT Manta, Samsung PM951 256GB, HTC Vive

Gaming laptop: Asus FX503VD, i5-7300HQ, 2x8GB DDR4, GTX 1050, Sandisk 256GB SSD

Total CPU heating: i7-7800X, 2x i7-6700k, i7-6700HQ, i5-6600k, i5-5675C, i5-4570S, i3-8350k, i3-6100, i3-4360, 2x i3-4150T, E5-2683v3, 2x E5-2650, R7 1700, 1600

Link to post
Share on other sites
39 minutes ago, bomberblyat said:

Hi!

 

I updated windows once, then i stopped windows update from services.msc (i set it disabled and stop so it should not go on, this has worked before), because i do not want to update more windows 10, it deletes my disable from windows 10 updates everytime i reboot my pc or something. Any help is appreciated

(Reason why i want to stop windows 10 updating is, it pops up random shit that i couldnt give a fuck some security bs etc, and i do not want it to fuckup my pc, like random reboots coz windows needs to update n stuff, DO NOT QUESTION my reasons)

 

add these to your desktop for ease of use and make a shortcut of ''stop windows update'' to the startup folder.

start windows update.bat

stop windows update.bat

Link to post
Share on other sites
Just now, porina said:

I've had to take to blocking windows update at router level since I also noticed the old trick of disabling the service was no longer reliable. Windows can't update if it can't reach the servers. I only turn off that rule when I choose to do the updates, not when MS thinks is good. That reminds me, now is a good time to install the February updates before the March ones come out. I don't like to be first to update. Someone else can work out what's broken.

Well actually you are not first. Those who join the insiders program are first. :)

Link to post
Share on other sites
1 minute ago, GoodBytes said:

Well actually you are not first. Those who join the insiders program are first. :)

They don't find all the bugs that a wider general deployment does.

 

I admit, my use case is niche, but I feel simply not catered for by MS in Win10. Win8 and earlier did not have this artificial limitation. I simply can't have PCs rebooting when they like if unattended. I'm not going to pay more for the Pro version to get more control features just for this. I don't want to auto-login to try and resume, as it is not always possible. I don't want to run it as a service if I even can. And Linux isn't a great option either. Even if it doesn't reboot, I also don't like it installing updates in the background as it reduces system performance while it does so. I do like the Win7 approach I still have on those systems. Disable automatic updates. Once a month, check and install, reboot, done. A lot less fuss and stress.

 

Bring back Windows 2000! The ones before the later service packs anyway. It was the last Windows version not to nag you in any way. 


Coffee tasting: Asrock Z370 Pro4, i3-8350k @ 5.0 GHz, Noctua D15, G.Skill TridentZ 3000C14 @ 3866C17 2x8GB, R7 260X, ancient OCZ PSU, Corsair 600C, Crucial BX300 120GB

Main rig: Asus Maximus VIII Hero, i7-6700k stock, Noctua D14, G.Skill Ripjaws V 3200 2x8GB, Asus 1080 Ti Strix OC, Corsair HX750i, In Win 303 NVIDIA, Samsung SM951 512GB, Optane 900p 280GB, Crucial MX200 1TB, Sandisk 960GB, WD Blue 1TB, Acer Predator XB241YU

Ryzen rig: Asus Prime X370-Pro, R7 1700, Corsair H110i GTX, Crucial Ballistix 2666 2x4GB, Vega 56, Corsair CX550M, CoolerMaster MasterBox, Kingston 240GB, Acer RT280K

VR rig: Asus Z170I Pro Gaming, i7-6700k stock, Silverstone TD03-E, Kingston Hyper-X 2666 2x8GB, Zotac 1070 FE, Corsair CX450M, NZXT Manta, Samsung PM951 256GB, HTC Vive

Gaming laptop: Asus FX503VD, i5-7300HQ, 2x8GB DDR4, GTX 1050, Sandisk 256GB SSD

Total CPU heating: i7-7800X, 2x i7-6700k, i7-6700HQ, i5-6600k, i5-5675C, i5-4570S, i3-8350k, i3-6100, i3-4360, 2x i3-4150T, E5-2683v3, 2x E5-2650, R7 1700, 1600

Link to post
Share on other sites
37 minutes ago, bomberblyat said:

fuck it xD  i will just update it and hope i dont get bsod hell

On your way of settings up Windows to your need, schedule also Windows maintenance time.

Start > type: Maintenance > Security & Maintenance. You'll get a Windows 7 panel. In it, expand Maintenance, and click on the blue link "Change maintenance settings"

 

Once you setup the OS to do the stuff it needs to do around you, then it doesn't affect you anymore, or just a hint

Link to post
Share on other sites
6 hours ago, liquidmagma said:

so im not sane (inane?) because i do this exact thing too?

if you say so ... :-)

well now that say so yourself: I think the same thing too.

 

Not installing updates and then come crying for help when shit hit the fan and something bad happened. We recently had a discussion with that kind of people, we laught and moved on.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.


×