Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Plat3

High CPU Usage when Streaming (i7-6700k)

Just figured it out, in game I opened Task Manager and set my game's affinity settings to use the first 4 of the 8 cores, lowering my usage from 95%-100% down to 70%-80% without degrading stream or game performance.

 

Cheers for the replies

Recommended Posts

Posted · Original PosterOP

As the title says, i get high CPU usage when streaming, but it hasn't always been like this. One day my stream just didn't wanna be smooth at all even though i used those settings daily. 

 

After a few weeks I kinda fixed the choppy stream, but my CPU still lingers in 94%-100%, what confuses me the most is that i don't seem to feel any performance loss in game and my stream isn't taking the hit from what i see, so why so high? It just started doing this recently, when before I would stream my games with only about 70%-80% usage was going on

 

Link to post
Share on other sites

The software you are using to stream might have gotten an update that utilizes more cpu, even on the same encoder.

There could be something else running in the background that is utilizing too much of your cpu (A virus scan might be utilizing you cpu while you dont notice)

 

What type of encoding settings are you using on cpu ? What bitrate? 

 

It also depends on what game you are streaming?

Link to post
Share on other sites

What software are you using to stream? There's likely been something that disabled hardware acceleration. Just go into setting and set it to use QuickSync, VCE or NVENC.

Link to post
Share on other sites
Posted · Original PosterOP
4 minutes ago, MaorRX said:

The software you are using to stream might have gotten an update that utilizes more cpu, even on the same encoder.

There could be something else running in the background that is utilizing too much of your cpu (A virus scan might be utilizing you cpu while you dont notice)

 

What type of encoding settings are you using on cpu ? What bitrate? 

 

It also depends on what game you are streaming?

I mostly stream Rainbow Six: SIege, bitrate of 2600, 720p60fps using the x264

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, Snooli said:

What software are you using to stream? There's likely been something that disabled hardware acceleration. Just go into setting and set it to use QuickSync, VCE or NVENC.

Ill try out the nvenc, im using OBS

Link to post
Share on other sites
2 minutes ago, Plat3 said:

Ill try out the nvenc, im using OBS

Try to use QuickSync instead, it has better quality/bitrate and runs on the iGPU, a chip you're likely not using.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Snooli said:

Try to use QuickSync instead, it has better quality/bitrate and runs on the iGPU, a chip you're likely not using.

I do run my second monitor directly plugged into my motherboard, will it affect how well that uses Quicksync?

Link to post
Share on other sites

nvenc will work great with almost no performance drops but lower quality

 

when using x264 what cpu preset are you on in obs?

also make sure your keyframe interval is on 2

and set profile on main

 

also a thing that could happen is you're cpu temps are to high and your cpu is throttling and struggling with encoding so check temps as well just incase

 


Recent build: Meshify C / The 1080TI Strix Noctua modDefine S X58 Xeon build  / Specs: i7 8700k 5.1GHz - Asus GTX 1080TI Strix OC - Corsair vengeance 16GB - Asus Z370 ROG Maximus X Hero - Fractal Meshify C TG White - EVGA 850W Supernova G2 80+ Gold - Fractal Celsius S36

Link to post
Share on other sites
Just now, Plat3 said:

I do run my second monitor directly plugged into my motherboard, will it affect how well that uses Quicksync?

It might, but likely won't. Just stick to NVENC then.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, wildthing said:

nvenc will work great with almost no performance drops but lower quality

 

when using x264 what cpu preset are you on in obs?

also make sure your keyframe interval is on 2

and set profile on main

 

also a thing that could happen is you're cpu temps are to high and your cpu is throttling and struggling with encoding so check temps as well just incase

 

My CPU preset is veryfast, my keyframes are at 2 and profile is on main

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Snooli said:

It might, but likely won't. Just stick to NVENC then.

Ill test them both and see how well they do

Link to post
Share on other sites
2 minutes ago, Plat3 said:

My CPU preset is veryfast, my keyframes are at 2 and profile is on main

what about your cpu temps under load?


Recent build: Meshify C / The 1080TI Strix Noctua modDefine S X58 Xeon build  / Specs: i7 8700k 5.1GHz - Asus GTX 1080TI Strix OC - Corsair vengeance 16GB - Asus Z370 ROG Maximus X Hero - Fractal Meshify C TG White - EVGA 850W Supernova G2 80+ Gold - Fractal Celsius S36

Link to post
Share on other sites
Posted · Original PosterOP
9 minutes ago, wildthing said:

what about your cpu temps under load?

Under load while streaming is about 65-70c

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

Just figured it out, in game I opened Task Manager and set my game's affinity settings to use the first 4 of the 8 cores, lowering my usage from 95%-100% down to 70%-80% without degrading stream or game performance.

 

Cheers for the replies

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×