Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Deko-sama

BSOD error: THREAD STUCK IN DEVICE DRIVER

Recommended Posts

Posted · Original PosterOP

Hello guys!

 

So I experienced a BSOD with the error "THREAD STUCK IN DEVICE DRIVER". I learned after a bit of research that it meant that there is a bad or faulty driver (usually the graphics card driver) and its caught in a loop while it waits for the hardware to enter an idle state. I've also learned that the fix is to update the drivers which seems easy enough but this is where stuff gets a bit complicated.

 

I tried booting into safe mode and downloaded the AMD driver patch 18.2.1 and tried installing it but it says that the drivers aren't digitally signed. So I tried looking for a fix and found that I can disable driver signature enforcement. Easy right? I tried restarting my laptop to this mode and then I get the same BSOD crash. Like the nature of the BSOD crash, I'm also stuck in a loop haha. I tried rolling back drivers and none of them fixed the problem. So I lost hope and turned to the only place that could probably help.

 

I'm using a Lenovo Ideapad 305-14 with a Intel Core i3 5005U, an AMD Radeon R5 M330 Graphics and running Windows 10. I've also attached pictures of what's currently happening when I update my driver and when I try to start the AMD settings application.

 

Thank you guys!

Opening AMD Settings in Safe mode.png

Running the downloaded Installer.png

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×