Jump to content
Lazyteen

I need help with this black screen, can't see but i can hear everything going on (gaming,youtube,spotify...)

Recommended Posts

Posted · Original PosterOP

Hello guys i need some help, so about 2 years ago I was experiencing black screens whenever i started playing games, so i ignored this problem and i carried on... less than a month later my pc wasn't even recognizing the screen so i took it to a "specialist" and he said it was my MSI GTX 970 gpu or possibly my motherboard, so I quickly bought a GA-Z97X-Gaming 3 motherboard and asked him to swap it out for me, brought the pc home with the gpu not plugged in and the pc was working but very weirdly so I decided not to go back to this guy because he made things worst, 2 years go by im finally able to get spare cash for a new graphics card (thinking that was the problem) and bought  a MSI GeForce GTX 1050ti and it arrived today.

I installed it correctly and now the same problem is happening, not even 1 hour into League of Legends and it black screened on me.

  • I can't get a refund/claim warranty on the 970
  • Its not the HDMI
  • I have formatted the computer completely clean and started fresh
  • Drivers are up to date

I have included some pics for you guys to get an idea, please help me :(

27042814_1388862777891007_832743056_n.jpg

27042982_1388863174557634_147630803_n.jpg

27043484_1388862837891001_1888358016_n.jpg

27156951_1388862751224343_435544433_n.jpg

27157402_1388862821224336_1258460677_n.jpg

27157445_1388863157890969_1413220667_n.jpg

27157464_1388862771224341_1373357952_n.jpg

Link to post
Share on other sites

When you say 

7 minutes ago, Lazyteen said:

it black screened on me.

do you mean to say, it just goes black for a moment and then back to normal. 

Or does it stay black? 

What exactly happens?

Link to post
Share on other sites

Have you checked temps? It looks like one of the fans on your radiator isn't even running.


Desktop: Xeon 1231-v3, 16GB RAM, 1TB SSD, Rosewill 550w Capstone PSU, ASrock ITX Z97 board, Gigabyte 970, Phanteks Evolv ITX.

Laptop: Alienware 18 (2014). I7 4810MQ, 16GB RAM, 500GB 840Evo, 1TB HDD, GTX 880m SLI

Laptop: Razer Blade 14 mid 2016. I7 6700hq, 16GB RAM, 512GB SSD, 970m 6GB.

 

 

Link to post
Share on other sites
Posted · Original PosterOP
21 minutes ago, ElSeniorTaco said:

When you say 

do you mean to say, it just goes black for a moment and then back to normal. 

Or does it stay black? 

What exactly happens?

it stays black, however if i got spotify running or any game i can still hear everything just not see :/

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, Theguywhobea said:

Have you checked temps? It looks like one of the fans on your radiator isn't even running.

oh yes all fans run perfectly fine its not due to temps, yes i do have a few not plugged, those are just extras for when or if i add more

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.


×