Jump to content
Kapejog

Trying to made WAN to LAN working

Recommended Posts

Posted · Original PosterOP

Hello. I recently got an TP-Link WR841N router, and i thinked about connecting my first router (Huawei B315) to speedup the internet a little bit.

I actually have problems to configure IP's to work. I'm doing all steps from this tutorial, and im getting now a little bit mindfu*ked.

In the tutorial the ip's of first router is 192.168.1.1. Mine first router ip is 192.168.8.1 (Huawei). Second router ip is 192.168.0.1 (TP-Link).

I set the first router DHCP IP's from 192.168.8.2 to 192.168.8.50 (Picture 1). Then i went to second router and changed WAN IP to 192.168.8.51, subnet mask to 255.255.255.0 and gateway to 192.168.8.1 (DNS are set to google DNS).

Then i stuck on step 7 of the tutorial. As it says: 

Spoiler

Configure the DHCP server on the secondary router. If you are creating a LAN-to-LAN network, the DHCP service should be turned off on the secondary router. If you are creating a LAN-to-WAN network, the DHCP server on the secondary router should hand out addresses between 192.168.2.2 and 192.168.2.50.

I set my DHCP IP's to 192.168.8.2-50 and it showed my error 2005: "Bad IP address pool (the Starting or Ending IP address), please input another one."

At this point i don't know to configure it properly. Can someone help me and say how to configure these ip's? I'm not good at router configuration, sadly :( 

Picture_1.png

Link to post
Share on other sites

Try to increment up.

 

for example I use for wireless DHCP 200-250, and below 100-200 for lan based dhcp.

 

from the how to go:

 

Connect your first router to your interwebs cable and configure it accordingly. turn off DHCP on that one. 

 

For example hand out the IP 192.168.8.1 for that one. 

 

On the second router you set the default gateway to 192.168.8.1, and hand it the IP 192.168.8.2.

 

Activate wireless with dhcp on your second router, giving it the range from for example 192.168.8.50-192.168.8.100.

 

Then try if wireless is working accordingly with your smartphone or laptop or other wireless device.


2 Main Systems (mine and my late wifes): AsRock Fatal1ty Z77 Pro, Core I5 3570k @4300, 16 GB Ram DDR3 2133, some SSD, and a 2 TB HDD each, Gainward Phantom 760GTX. 

 

On the Road: Acer Aspire 5 Model A515-51G-54FD, Intel Core i5 7200U, 8 GB DDR4 Ram, 120 GB SSD, 1 TB HDD, Intel CPU GFX and Nvidia MX 150, Full HD IPS display

 

Media System: Asrock ASRock Z87 Extreme4/TB4, Intel Core i5 4460, 16 GB Ram DDR3 1600 ADATA XPG, 1 275 GB SSD, 2 Seagate 500 GB HDD, Gainward Phantom 560 GTX

 

(Abit Fatal1ty FP9 IN SLI, C2Duo E8400, 6 GB Ram DDR2 800, far too less diskspace, Gainward Phantom 560 GTX broken need fixing)

 

Nostalgia: Amiga 1200, Tower Build, CPU/FPU/MMU 68EC020, 68030, 68882 @50 Mhz, 10 MByte ram (2 MB Chip, 8 MB Fast), Fast SCSI II, 2 CDRoms, 2 1 GB SCSI II IBM Harddrives, 512 MB Quantum Lightning HDD, self soldered Sync changer to attach VGA displays, WLAN

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Lurick said:

Why not just do LAN-to-LAN and not do DHCP on the second router?

Will it work as i want it to work?

Link to post
Share on other sites
Just now, Kapejog said:

Will it work as i want it to work?

Yah, and the setup is much simpler on the second router since you don't do DHCP, NAT, or really any of the other functions.


Build Log:

 

Link to post
Share on other sites
Posted · Original PosterOP

Turning off DHCP ends in that i cant connect to router via wifi or lan :/ And i needed to reset the settings.

 

Link to post
Share on other sites
30 minutes ago, Kapejog said:

Turning off DHCP ends in that i cant connect to router via wifi or lan :/ And i needed to reset the settings.

 

After connecting LAN to LAN?


Build Log:

 

Link to post
Share on other sites
Posted · Original PosterOP
22 hours ago, Lurick said:

After connecting LAN to LAN?

yeah, but just made it work properly, thanks for help anyway :P

Link to post
Share on other sites
51 minutes ago, Kapejog said:

yeah, but just made it work properly, thanks for help anyway :P

You don't want to run two DHCP servers on the same subnet. Even if they have different pools, it can cause confusion to the clients, because they're not sure which DHCP server to request an address from.

 

The second router should:

1. Have a static IP on the same subnet as the first router (Eg: 1st router x.x.8.1, second router x.x.8.2)

2. Disable DHCP, NAT, Firewall, routing, etc.

3. Connect the 1st router to one of the LAN ports (not WAN) on the 2nd router.

 

Now, some routers have automatic modes that will do all of this for you, and generally you use the WAN port in this case, but only do so if the manufacturer has official instructions on that.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.


×