Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Cyberspirit

Razer Deathadder Elite random double clicks?

Recommended Posts

Posted · Original PosterOP

So for the past two days I've noticed that sometimes it feels like a single mouse click registers as two but it doesn't happen all the time.

I didn't touch any settings and i only bought this mouse like 3 months ago so it shouldn't be broken.

 

Any idea what could cause this?


Make sure to quote or tag people, so they get notified.

 

 

 

UP THE HAMMERS & DOWN THE NAILS
MAY THE LORDS OF LIGHT BE WITH YOU
BLESSED BE
HAIL CROM
HAIL ODIN
HAIL THOR
HAIL THE MANILLAN EMPIRE
HAIL TO THE BRETHREN OF THE HAMMER

Rest in peace Mark \m/

1957-2018

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, rip said:

razer is known for their bad wuality mouse. welcome

Well i got this mouse because a lot of people recommended the older ones so i thought i'll get the newer ones and we'll see.

The mouse itself is great i really liked it so far but this double clicking is concerning since this damn thing is like months old.


Make sure to quote or tag people, so they get notified.

 

 

 

UP THE HAMMERS & DOWN THE NAILS
MAY THE LORDS OF LIGHT BE WITH YOU
BLESSED BE
HAIL CROM
HAIL ODIN
HAIL THOR
HAIL THE MANILLAN EMPIRE
HAIL TO THE BRETHREN OF THE HAMMER

Rest in peace Mark \m/

1957-2018

Link to post
Share on other sites

i had this issue with my deathadder 2013 just after 5 months of use, bought a g403 instead.

 

RMA it!


My Build:
 CPU - i7-4790k @ 4.7ghz (overclocked)
 Ram - 16GB Corsair Vengeance DDR3 (overclocked)
 Motherboard - Asus Republic Of Gamers (ROG) Maximus VII Hero
 Cpu Cooler - Corsair H100i GTX Liquid cooler
 Case - Cooler Master MasterCase Pro 5
 PSU - Corsair Rm1000 Gold Certified
 SSD - Samsung 850pro 256GB SSD
 HDD - 1x WD Black 4TB/256mb cache, 2x Seagate Barracuda 2TB HDD
 GPU - Zotac Gtx 1080Ti Amp! Extreme! edition
 Keyboard - HyperX Alloy mechanical_Cherry-MX RED (main) , Asus Cerberus (secondary)
 Mouse - Logitech G403 Prodigy (Main) , Razer Deathadder 2013(secondary), Logitech m235 wireless mouse (secondary)
 Mouse pad - CM-Storm Swift-RX (Main), Steelseries Qck (secondary)
 Mic - Blue Snowball ICE
 Headphones - HyperX Cloud Core
 Monitor - Acer Predator XB271HU 2560x1440 144hz Gsync (Main), Dell S2216H 1920x1080 60hz (secondary)

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, Sanchit_technogeek said:

i had this issue with my deathadder 2013 just after 5 months of use, bought a g403 instead.

 

RMA it!

Well i'm gonna be reaally mad if i have to RMA it because that would mean that i have to travel to our capital city just to send this damn thing back to the shop and believe me Budapest's traffic is as bad as LA's so it's really stressful to go anywhere in Budapest if you rarely go in there.

 

I wrote an E-mail to Razer support and we'll see what's their answer.


Make sure to quote or tag people, so they get notified.

 

 

 

UP THE HAMMERS & DOWN THE NAILS
MAY THE LORDS OF LIGHT BE WITH YOU
BLESSED BE
HAIL CROM
HAIL ODIN
HAIL THOR
HAIL THE MANILLAN EMPIRE
HAIL TO THE BRETHREN OF THE HAMMER

Rest in peace Mark \m/

1957-2018

Link to post
Share on other sites
1 minute ago, Cyberspirit said:

Well i'm gonna be reaally mad if i have to RMA it because that would mean that i have to travel to our capital city just to send this damn thing back to the shop and believe me Budapest's traffic is as bad as LA's so it's really stressful to go anywhere in Budapest if you rarely go in there.

 

I wrote an E-mail to Razer support and we'll see what's their answer.

I wrote an email to them as well, they just told me to get it replaced by the seller.
ask if they (razer) or the store (if they are the authorized distributor of razer) can arrange for on-site pickup!


My Build:
 CPU - i7-4790k @ 4.7ghz (overclocked)
 Ram - 16GB Corsair Vengeance DDR3 (overclocked)
 Motherboard - Asus Republic Of Gamers (ROG) Maximus VII Hero
 Cpu Cooler - Corsair H100i GTX Liquid cooler
 Case - Cooler Master MasterCase Pro 5
 PSU - Corsair Rm1000 Gold Certified
 SSD - Samsung 850pro 256GB SSD
 HDD - 1x WD Black 4TB/256mb cache, 2x Seagate Barracuda 2TB HDD
 GPU - Zotac Gtx 1080Ti Amp! Extreme! edition
 Keyboard - HyperX Alloy mechanical_Cherry-MX RED (main) , Asus Cerberus (secondary)
 Mouse - Logitech G403 Prodigy (Main) , Razer Deathadder 2013(secondary), Logitech m235 wireless mouse (secondary)
 Mouse pad - CM-Storm Swift-RX (Main), Steelseries Qck (secondary)
 Mic - Blue Snowball ICE
 Headphones - HyperX Cloud Core
 Monitor - Acer Predator XB271HU 2560x1440 144hz Gsync (Main), Dell S2216H 1920x1080 60hz (secondary)

Link to post
Share on other sites
Posted · Original PosterOP
12 minutes ago, Sanchit_technogeek said:

Ask if they (razer) or the store (if they are the authorized distributor of razer) can arrange for on-site pickup!

Will ask the store i bought it from later. Currently it's 2:25 am here hehe.

An on-site pickup would be wonderful and i really hope it an be one here in Hungary as well.


Make sure to quote or tag people, so they get notified.

 

 

 

UP THE HAMMERS & DOWN THE NAILS
MAY THE LORDS OF LIGHT BE WITH YOU
BLESSED BE
HAIL CROM
HAIL ODIN
HAIL THOR
HAIL THE MANILLAN EMPIRE
HAIL TO THE BRETHREN OF THE HAMMER

Rest in peace Mark \m/

1957-2018

Link to post
Share on other sites

Unlucky. Most likely will have to RMA it. This is a pretty common issue that can occur with all mice (not just Razer).


Intel Xeon E3-1230 V2 | CM Hyper 212 Evo | MSI ZH77A-G43 | HyperX Fury DDR3 8GBx2 | MSI GTX 1060 GAMING X 3GB

Lian-Li PC-A05FN | SanDisk Ultra II 240GB | WD 1TB Blue | Cooler Master Silent Pro Gold 550W | ASUS MG248Q

 

Cherry G80-3000 (blue) | Ducky 9008 Shine 2 (black/blue LED) | Ducky 9087 Shine 2 Year of the Dragon (brown/yellow LED)

Ducky Mini Year of the Horse (white/blue+red LED) | Steelseries 6Gv2 (black) | Leopold FC660M (red) | Vortex Race 3 (blue)

 

Logitech G400s | Razer Abyssus Mirror Edition | Razer Goliathus Speed

Steelseries Sensei RAW | SteelSeries Qck | Zowie EC1-ASteelseries Qck+ Fnatic edition

 

Link to post
Share on other sites
Posted · Original PosterOP
11 hours ago, exousia7 said:

Unlucky. Most likely will have to RMA it. This is a pretty common issue that can occur with all mice (not just Razer).

So it doesn't seem to do it right now but we'll see what happens after gaming for an hour or so.

Yesterday i switched from the Usb 3.0 port to the Usb 3.1 after switching it still happened but now after i restarted my PC it seems fine but as i said we'll see what happens after a couple hours of normal use.

 

EDIT: So after a while (Without gaming) it started to happen again so i really don't know why it's doing this.


Make sure to quote or tag people, so they get notified.

 

 

 

UP THE HAMMERS & DOWN THE NAILS
MAY THE LORDS OF LIGHT BE WITH YOU
BLESSED BE
HAIL CROM
HAIL ODIN
HAIL THOR
HAIL THE MANILLAN EMPIRE
HAIL TO THE BRETHREN OF THE HAMMER

Rest in peace Mark \m/

1957-2018

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×