Jump to content
TristanG.Arellano

Uncommit memory in Windows 10

Recommended Posts

Posted · Original PosterOP

Hello, I was wondering if anyone had any idea why my memory keeps getting commuted in Windows 10. I’ve had 16GB of ddr4 until about three days ago, now I have 9.8GB commuted and 4.5 avalible. I keep being kicked out of games due to insufficient memory. It’s very annoying and I was wondering if there’s a way to fix it. I already tried a clean instal of Windows 10 but upon installation the memory was commuted again.

Link to post
Share on other sites

There's no way to "uncommit memory" unless you close applications. You can check out which applications are consuming a lot of memory by going to the "Details" tab in Task Manager, then going to View -> Select Columns... in the menu bar and select "Commit Size". Then sort by Commit Size.

Link to post
Share on other sites
Posted · Original PosterOP
8 minutes ago, M.Yurizaki said:

There's no way to "uncommit memory" unless you close applications. You can check out which applications are consuming a lot of memory by going to the "Details" tab in Task Manager, then going to View -> Select Columns... in the menu bar and select "Commit Size". Then sort by Commit Size.

it happens when nothing is open, on a clean install of windows.

Link to post
Share on other sites

I want a screenshot of the "Details" tab as well

 

Also there's another problem, Windows is only using half your RAM. You can attempt to fix that by doing:

  • Open up the Start Menu and type in msconfig in the search bar
  • Open the application the search comes with
  • Go to the "Boot" tab
  • Press the "Advanced options..." button
  • If "Maximum Memory" is checked, uncheck it and reboot
  • If "Maximum Memory" is unchecked, check and put 16384 and reboot
Link to post
Share on other sites
Posted · Original PosterOP
17 minutes ago, M.Yurizaki said:

I want a screenshot of the "Details" tab as well

 

Also there's another problem, Windows is only using half your RAM. You can attempt to fix that by doing:

  • Open up the Start Menu and type in msconfig in the search bar
  • Open the application the search comes with
  • Go to the "Boot" tab
  • Press the "Advanced options..." button
  • If "Maximum Memory" is checked, uncheck it and reboot
  • If "Maximum Memory" is unchecked, check and put 16384 and reboot

 

Screenshot (27).png

Link to post
Share on other sites
4 minutes ago, TristanG.Arellano said:

going to msconfig changed nothing

Your RAM might be installed incorrectly on the motherboard. Make sure they're in the same colored slots if they're colored different or you've populated them in the correct order (some motherboards don't like it if you populate slots 2 and 4 instead of 1 and 3, for example)

Link to post
Share on other sites
1 hour ago, TristanG.Arellano said:

everything is installed correctly I haven't had a problem until the past few days and I built my pc back in may

If you made any changes in the past few days, I'd recommend undoing them. Otherwise run with one stick of RAM and see if everything is good, then run with the other stick.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, M.Yurizaki said:

If you made any changes in the past few days, I'd recommend undoing them. Otherwise run with one stick of RAM and see if everything is good, then run with the other stick.

only changes I made was buying and installing rainbow six siege and players unkown, ill updateonce I check to see if both sticks are working thanks for the help

 

 

Link to post
Share on other sites
Posted · Original PosterOP
25 minutes ago, M.Yurizaki said:

If you made any changes in the past few days, I'd recommend undoing them. Otherwise run with one stick of RAM and see if everything is good, then run with the other stick.

I tested both sticks in each slot all of them work put in a different hard drive with Windows 10 fresh install nothing else on it. Could it be a bios thing?

Link to post
Share on other sites
14 hours ago, TristanG.Arellano said:

I tested both sticks in each slot all of them work put in a different hard drive with Windows 10 fresh install nothing else on it. Could it be a bios thing?

And the fresh install only sees 8GB?

 

If you haven't touched the BIOS in a while, I don't see that being a problem. Though just to see if it is a problem, revert BIOS to default settings if you changed anything.

Link to post
Share on other sites
Posted · Original PosterOP
13 hours ago, M.Yurizaki said:

And the fresh install only sees 8GB?

 

If you haven't touched the BIOS in a while, I don't see that being a problem. Though just to see if it is a problem, revert BIOS to default settings if you changed anything.

Still nothing, only showing 8GB. Clean install, reset and cleared bios updated to the later bio from MSI. I think I’m just going to get a different motherboard and try it out.

Link to post
Share on other sites

Something is weird because it says Hardware reserved is 8gb. I don't think it should be that high. Windows is seeing all 16gb but it's only allowing 8gb to be used for programs. Have you set up any Ram cache recently or anything like that??


 Current System:

CPU: Ryzen 7 1700x  Board: Asus ROG C6H  Ram: G.Skill TridentZ 32gb 3000  Case: NZXT S340 Elite White

GPU: Asus ROG Strix GTX 1070 OC M.2: Samsung 960 Evo 250gb SSD: Samsung 850 Pro 512gb  HDD: Seagate Barracuda 3TB

PSU: Corsair RM850x White  Cooler: NZXT Kraken x62.2 Extras: Hue+ w/NZXT 120mm RGB Fans

Backup System:

FX-8350 @ 4.7ghz, Asus TUF Sabertooth 990fx r3.0, Asus ROG Strix GTX 1070 OC, Crucial Balistix Tracer 32gb, M.2 Samsung 960 Evo 250, Seagate Firecudda 2tb, Seagate Barracuda 2tb, DeepCool Genome II Case w/360 Radiator

Link to post
Share on other sites
Posted · Original PosterOP
7 hours ago, Santo22 said:

Something is weird because it says Hardware reserved is 8gb. I don't think it should be that high. Windows is seeing all 16gb but it's only allowing 8gb to be used for programs. Have you set up any Ram cache recently or anything like that??

no I have not, I haven't changed any settings or anything and then my computer just reset and says that I only have 8GB

 

Link to post
Share on other sites

might be a stretch. But are you using the integrated GPU? possibly having set in your bios a specific amount of memory to use for the GPU?


Quote

"Human beings, who are almost unique in having the ability to learn from the experience of others, are also remarkable for their apparent disinclination to do so." - Douglas Adams

System: R7-1700, MSI Tomahawk B350, Nvidia Geforce 1070. 16GB DDR4.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.


×