Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Ryou-kun

My BIOS still register my RAM is 8GB not 16GB

3 minutes ago, Ryou-kun said:

Nope. I don't see a setting for it. 

okay. try reseating it, but in a different slot configuration. so try slot 1 and 2, 1 and 3 etc. 

Recommended Posts

Posted · Original PosterOP

Hello LTT,

I need your help.

 

When I first upgrade my PC to AMD Ryzen and slap a good 16GB RAM that I found on sale. I thought I was set until my PC register the RAM is 7.95GB usable and my BIOS register it as 8GB RAM. I have no idea how to fix it and I assume it was due to the RAM not compatible. I also did replace my old Ryzen mobo because the Bios driver got corrupted while mid-updating.

I waited until I recently order a different 16GB RAM that is actually supported by my motherboard supplied vendor. When I pop the baby in, it still register the RAM as 8GB. I have tried to remove the CMOS battery and waited 5-10 mins before installing it back in. I update my latest BIOS driver. Nothing. Not sure what is going on. 

 

PC Specs:

 

Windows 10 Pro 64-bit

AMD Ryzen 1700 @ 3.9 GHz

G.Skill TridenZ Series 16GB 3000 MHz (8GBx2) ----> Corsair Vengeance LPX 16GB DDR4 3200 MHz (8GBx2)

Corsair H100i v2

ASUS Prime B350-Plus ----> MSI x370 SLI Plus

GTX 670 ----> GTX 980 ti ACX

Corsair HX 750W

 

Thank you,

Link to post
Share on other sites

Can you take a look in CPU-Z or something in the OS and see what it says? Under the SPD tab?


Sig under construction.

Link to post
Share on other sites

Check that both sticks are in the proper slots and seated properly. Move them around until they work or you find which one doesn't work.


Quote me to see my reply!

SPECS:

CPU: Xeon X5650 OC'd to 4.4GHz @ 1.36V (courtesy of @XR6) Motherboard: Asus Sabertooth X58 RAM: 4x4GB G.Skill DDR3 1866MHz GPU: Asus RX 570 Strix Storage: WD Blue 1TB and a 128GB Kingston UV400 PSU: EVGA 600B Case: Fractal Design Define C Monitor: 3x Dell P2210 on a Steelcase Eyesite triple monitor stand Mouse: Logitech G403 Prodigy Wireless Keyboard: It changes, but usually Focus FK-9000 Mousepad: Steelseries QcK XL Headphones:  Sennheiser HD598SE

 

 

 

 

i use arch btw

Link to post
Share on other sites
Posted · Original PosterOP
16 minutes ago, Tedster said:

Can you take a look in CPU-Z or something in the OS and see what it says? Under the SPD tab?

 

Link to post
Share on other sites
Posted · Original PosterOP
10 minutes ago, kelvinhall05 said:

Check that both sticks are in the proper slots and seated properly. Move them around until they work or you find which one doesn't work.

I have check and make sure the RAM are seated properly.

I did swap the RAM around. 

Link to post
Share on other sites

check the memory tab in cpu-z. that should come up with the total ram. 


She/Her pls :) 

Phone: iPhone 6s | 64GB iOS

PC: ASUS Z370-P | Core i3 8100 R9 290X | 16GB RAM500GB SSD + 250GB SSD | Ubuntu 20.04

Link to post
Share on other sites

What does CPUz show for slot #2?


CPU: AMD Sempron 2400+ / MOBO: Abit NF7-S2G / GPU: WinFast A180BT 64MB / RAM: Mushkin DDR333 256MBx2 / HDD: Seagate Barracuda 7200RPM 120GB

Link to post
Share on other sites
Posted · Original PosterOP
18 minutes ago, firelighter487 said:

check the memory tab in cpu-z. that should come up with the total ram. 

Memory Tab in CPU-Z said it is 16GB.

Link to post
Share on other sites
19 minutes ago, Ryou-kun said:

Memory Tab in CPU-Z said it is 16GB.

then it should be fine... what about task manager?


She/Her pls :) 

Phone: iPhone 6s | 64GB iOS

PC: ASUS Z370-P | Core i3 8100 R9 290X | 16GB RAM500GB SSD + 250GB SSD | Ubuntu 20.04

Link to post
Share on other sites
Just now, Ryou-kun said:

 

8 gb hardware reserved...wow...

 

is there a setting for reserving memory in the bios?


She/Her pls :) 

Phone: iPhone 6s | 64GB iOS

PC: ASUS Z370-P | Core i3 8100 R9 290X | 16GB RAM500GB SSD + 250GB SSD | Ubuntu 20.04

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, firelighter487 said:

8 gb hardware reserved...wow...

 

is there a setting for reserving memory in the bios?

Hmm, I don't see anything about it. I will try again and see.

Link to post
Share on other sites
Posted · Original PosterOP
16 minutes ago, firelighter487 said:

8 gb hardware reserved...wow...

 

is there a setting for reserving memory in the bios?

Nope. I don't see a setting for it. 

Link to post
Share on other sites
Posted · Best Answer
3 minutes ago, Ryou-kun said:

Nope. I don't see a setting for it. 

okay. try reseating it, but in a different slot configuration. so try slot 1 and 2, 1 and 3 etc. 


She/Her pls :) 

Phone: iPhone 6s | 64GB iOS

PC: ASUS Z370-P | Core i3 8100 R9 290X | 16GB RAM500GB SSD + 250GB SSD | Ubuntu 20.04

Link to post
Share on other sites
23 hours ago, Ryou-kun said:

Hello LTT,

I need your help.

 

When I first upgrade my PC to AMD Ryzen and slap a good 16GB RAM that I found on sale. I thought I was set until my PC register the RAM is 7.95GB usable and my BIOS register it as 8GB RAM. I have no idea how to fix it and I assume it was due to the RAM not compatible. I also did replace my old Ryzen mobo because the Bios driver got corrupted while mid-updating.

I waited until I recently order a different 16GB RAM that is actually supported by my motherboard supplied vendor. When I pop the baby in, it still register the RAM as 8GB. I have tried to remove the CMOS battery and waited 5-10 mins before installing it back in. I update my latest BIOS driver. Nothing. Not sure what is going on. 

 

PC Specs:

 

Windows 10 Pro 64-bit

AMD Ryzen 1700 @ 3.9 GHz

G.Skill TridenZ Series 16GB 3000 MHz (8GBx2) ----> Corsair Vengeance LPX 16GB DDR4 3200 MHz (8GBx2)

Corsair H100i v2

ASUS Prime B350-Plus ----> MSI x370 SLI Plus

GTX 670 ----> GTX 980 ti ACX

Corsair HX 750W

 

Thank you,

Remove one stick of ram, boot up then shut down and put the ram stick back in. Do this with all of your ram sticks. Let me know how it goes for you

Link to post
Share on other sites
1 minute ago, Intel HD Graphics said:

Remove one stick of ram, boot up then shut down and put the ram stick back in. Do this with all of your ram sticks. Let me know how it goes for you

If it's being recognised properly, which we've already determined with certainty, either the hardware isn't capable of working with it properly (which certainly wouldn't be the case on this sort of system), or the software is at fault, which what I've posted above seems to agree with.


Sig under construction.

Link to post
Share on other sites
Posted · Original PosterOP
On 8/24/2017 at 6:34 PM, firelighter487 said:

okay. try reseating it, but in a different slot configuration. so try slot 1 and 2, 1 and 3 etc. 

Sorry about taking a while. I felt a bit lazy for a day, lol. Now, I am back and actually did it.

I finally got it to work. Apparently, I have to put it in a Slot 1 and Slot 2 and it finally register as 16GB RAM! :D

I always thought to either place a RAM in either Slot 1 and 3 or Slot 2 and Slot 4. 

I guess it is case close then. Thanks for the help along with everyone. 

I was very close to formatting my PC, lol. 

 

Sadly, I have tried doing my G.Skill RAM, and it doesn't work like it won't even boot up the Bios. PC turns on but the RAM prevents it from doing anything else beside turning on the PC. If only the G.Skill RAM work, I would've return the Corsair LPX and get my money back. 

 

I guess I could either return the G.Skill RAM for RMA and either sell it or keep it for the next future build that I believe either my dad or my little bro are planning to upgrade ... 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×