Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Wrenn123

Why is my PC running like shit

Recommended Posts

Posted · Original PosterOP

These are my specs. They aren't great but I dont think they should be this poor at performance. I've been playing PUBG a lot recently and on very low with the lowest settings possible the best fps i can get is 27. And on other games my fps has been bery low compared to a while ago. I was wondering what I could upgrade/replace to make this pc back to life. Any help would be appreciated, thanks!

5291db21aed6985d790f2c6a9db6038d.png

Link to post
Share on other sites
Posted · Original PosterOP
Just now, nerdslayer1 said:

do you have anything running in the background? 

are all your drivers up to date? 

very minimal things in the backround and all my drivers are up to date

Link to post
Share on other sites
Posted · Original PosterOP
Just now, itsmyjobtoknow said:

Might help if you use DDU to nuke all the graphics drivers files, and install driver freshly. 

I was thinking it could be my ram or cpu or an ssd but thanks ill try that!

Link to post
Share on other sites
Just now, Wrenn123 said:

I was thinking it could be my ram or cpu or an ssd but thanks ill try that!

Your CPU is more than capable. You have more then enough ram. An SSD will speed up OS and load time, and make the user experience better, but most likely not gaming performance. 

Link to post
Share on other sites

Nothing needs an upgrade, but something's definitely wrong. DDU clean install drivers and if that doesn't work fresh Windows install.


-----> Official Unofficial Favorite Keyswitch Type Survey <-----

 OWNER OF THE FASTEST INTEL GPU ON LTT UNIGINE SUPERPOSITION [lol]

MY RIG "ALCATRAZ"

CPU i7-4770K OC @ 4.3GHz and pushing | COOLING Cryorig M9i (review| MOTHERBOARD ASUS Z87-PROGPU HD 4600 (no heavy gaming on this rig!) | RAM  16GB Crucial Ballistix Sport DDR3 1600 MHzSSD Samsung 860 Evo 500GB | HDD Toshiba 3TB 7200RPMPSU EVGA SuperNOVA 750WCASE  NZXT H230 | KEYBOARD Corsair STRAFE - Cherry MX Brown | MOUSE  Logitech G602 MONITOR LG 34UM58-P 34" 2560x1080 Ultrawide

HOLA NIGHT THEMERS

GET YOUR ASS ON NIGHT THEME

OTHER TECH I OWN:

2017 Audi Q7 | iPhone Xs Max | Apple Watch Series 3 42mm | 2018 MacBook Pro 15" [i7/560X/16GB/256GB] | Lenovo Flex 3 [i7-5500U, HD5500 (fastest on the forum), 8GB RAM, 256GB Samsung 840 Evo] | Xbox One [Home Theater setup] | DJI Phantom 3 Standard | Sony WH-1000XM3 | Jaybird Freedom (x2) & X2 [long story, PM if you want to know why I have 3 pairs of Jaybirds]

 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Shiv78 said:

Nothing needs an upgrade, but something's definitely wrong. DDU clean install drivers and if that doesn't work fresh Windows install.

 

1 minute ago, itsmyjobtoknow said:

Your CPU is more than capable. You have more then enough ram. An SSD will speed up OS and load time, and make the user experience better, but most likely not gaming performance. 

thanks guys, also would the speed of my ram be effecting anything? as i have basic crucial ones in my pc nothing too speedy

Link to post
Share on other sites
4 minutes ago, Wrenn123 said:

thanks guys, also would the speed of my ram be effecting anything? as i have basic crucial ones in my pc nothing too speedy

nope, RAM affects FPS a bit but not enough to make a huge difference (maybe 5-10 fps max on MODERN intel and virtually none on your 3770)


-----> Official Unofficial Favorite Keyswitch Type Survey <-----

 OWNER OF THE FASTEST INTEL GPU ON LTT UNIGINE SUPERPOSITION [lol]

MY RIG "ALCATRAZ"

CPU i7-4770K OC @ 4.3GHz and pushing | COOLING Cryorig M9i (review| MOTHERBOARD ASUS Z87-PROGPU HD 4600 (no heavy gaming on this rig!) | RAM  16GB Crucial Ballistix Sport DDR3 1600 MHzSSD Samsung 860 Evo 500GB | HDD Toshiba 3TB 7200RPMPSU EVGA SuperNOVA 750WCASE  NZXT H230 | KEYBOARD Corsair STRAFE - Cherry MX Brown | MOUSE  Logitech G602 MONITOR LG 34UM58-P 34" 2560x1080 Ultrawide

HOLA NIGHT THEMERS

GET YOUR ASS ON NIGHT THEME

OTHER TECH I OWN:

2017 Audi Q7 | iPhone Xs Max | Apple Watch Series 3 42mm | 2018 MacBook Pro 15" [i7/560X/16GB/256GB] | Lenovo Flex 3 [i7-5500U, HD5500 (fastest on the forum), 8GB RAM, 256GB Samsung 840 Evo] | Xbox One [Home Theater setup] | DJI Phantom 3 Standard | Sony WH-1000XM3 | Jaybird Freedom (x2) & X2 [long story, PM if you want to know why I have 3 pairs of Jaybirds]

 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Shiv78 said:

nope, RAM affects FPS a bit but not enough to make a huge difference (maybe 5-10 fps max on intel)

thanks bro i appreciate the info

Link to post
Share on other sites
1 minute ago, Shiv78 said:

nope, RAM affects FPS a bit but not enough to make a huge difference (maybe 5-10 fps max on intel)

On older platforms like OP's Ivy Bridge it makes no difference at all.


|PSU Tier List /80 Plus Efficiency| PSU stuff if you need it. 

My system: PCPartPicker || For Corsair support tag @Corsair Josephor @Corsair Nick || My 5MT Legacy GT Wagon ||

Link to post
Share on other sites

Where did you get your graphics card? GTX 1070s all have 8GB VRAM. With only 4 on your card, you might have a refreshed old card with 1070 VBIOS. Pf course it could be the app showing false info

 


CPU: i7-2600K 4751MHz 1.44V (software) --> 1.47V at the back of the socket Motherboard: Asrock Z77 Extreme4 (BCLK: 103.3MHz) CPU Cooler: Noctua NH-D15 RAM: Adata XPG 2x8GB DDR3 (XMP: 2133MHz 10-11-11-30 CR2, custom: 2203MHz 10-11-10-26 CR1 tRFC:230 tREFI:14000) GPU: Asus GTX 1070 Dual (Super Jetstream vbios, +70(2025-2088MHz)/+400(8.8Gbps)) SSD: Samsung 840 Pro 256GB (main boot drive), Transcend SSD370 128GB PSU: Seasonic X-660 80+ Gold Case: Antec P110 Silent, 5 intakes 1 exhaust Monitor: AOC G2460PF 1080p 144Hz (150Hz max w/ DP, 121Hz max w/ HDMI) TN panel Keyboard: Logitech G610 Orion (Cherry MX Blue) with SteelSeries Apex M260 keycaps Mouse: BenQ Zowie FK1

 

Model: HP Omen 17 17-an110ca CPU: i7-8750H (0.125V core & cache, 50mV SA undervolt) GPU: GTX 1060 6GB Mobile (+80/+450, 1650MHz~1750MHz 0.78V~0.85V) RAM: 8+8GB DDR4-2400 18-17-17-39 2T Storage: 1TB HP EX920 PCIe x4 M.2 SSD + 1TB Seagate 7200RPM 2.5" HDD (ST1000LM049-2GH172), 128GB Toshiba PCIe x2 M.2 SSD (KBG30ZMV128G) gone cooking externally Monitor: 1080p 126Hz IPS G-sync

 

Desktop benching:

Cinebench R15 Single thread:168 Multi-thread: 833 

SuperPi (v1.5 from Techpowerup, PI value output) 16K: 0.100s 1M: 8.255s 32M: 7m 45.93s

Link to post
Share on other sites
Just now, STRMfrmXMN said:

On older platforms like OP's Ivy Bridge it makes no difference at all.

my bad, will fix!


-----> Official Unofficial Favorite Keyswitch Type Survey <-----

 OWNER OF THE FASTEST INTEL GPU ON LTT UNIGINE SUPERPOSITION [lol]

MY RIG "ALCATRAZ"

CPU i7-4770K OC @ 4.3GHz and pushing | COOLING Cryorig M9i (review| MOTHERBOARD ASUS Z87-PROGPU HD 4600 (no heavy gaming on this rig!) | RAM  16GB Crucial Ballistix Sport DDR3 1600 MHzSSD Samsung 860 Evo 500GB | HDD Toshiba 3TB 7200RPMPSU EVGA SuperNOVA 750WCASE  NZXT H230 | KEYBOARD Corsair STRAFE - Cherry MX Brown | MOUSE  Logitech G602 MONITOR LG 34UM58-P 34" 2560x1080 Ultrawide

HOLA NIGHT THEMERS

GET YOUR ASS ON NIGHT THEME

OTHER TECH I OWN:

2017 Audi Q7 | iPhone Xs Max | Apple Watch Series 3 42mm | 2018 MacBook Pro 15" [i7/560X/16GB/256GB] | Lenovo Flex 3 [i7-5500U, HD5500 (fastest on the forum), 8GB RAM, 256GB Samsung 840 Evo] | Xbox One [Home Theater setup] | DJI Phantom 3 Standard | Sony WH-1000XM3 | Jaybird Freedom (x2) & X2 [long story, PM if you want to know why I have 3 pairs of Jaybirds]

 

Link to post
Share on other sites
Just now, Jurrunio said:

Where did you get your graphics card? GTX 1070s all have 8GB VRAM. With only 4 on your card, you might have a refreshed old card with 1070 VBIOS. Pf course it could be the app showing false info

 

Speecy....isn't necessarily the most accurate at reporting system info. 

Link to post
Share on other sites
2 minutes ago, Jurrunio said:

Where did you get your graphics card? GTX 1070s all have 8GB VRAM. With only 4 on your card, you might have a refreshed old card with 1070 VBIOS. Pf course it could be the app showing false info

 

 

1 minute ago, itsmyjobtoknow said:

Speecy....isn't necessarily the most accurate at reporting system info. 

Yeah Speccy isn't great... device manager or CPUZ/GPUZ is usually better


-----> Official Unofficial Favorite Keyswitch Type Survey <-----

 OWNER OF THE FASTEST INTEL GPU ON LTT UNIGINE SUPERPOSITION [lol]

MY RIG "ALCATRAZ"

CPU i7-4770K OC @ 4.3GHz and pushing | COOLING Cryorig M9i (review| MOTHERBOARD ASUS Z87-PROGPU HD 4600 (no heavy gaming on this rig!) | RAM  16GB Crucial Ballistix Sport DDR3 1600 MHzSSD Samsung 860 Evo 500GB | HDD Toshiba 3TB 7200RPMPSU EVGA SuperNOVA 750WCASE  NZXT H230 | KEYBOARD Corsair STRAFE - Cherry MX Brown | MOUSE  Logitech G602 MONITOR LG 34UM58-P 34" 2560x1080 Ultrawide

HOLA NIGHT THEMERS

GET YOUR ASS ON NIGHT THEME

OTHER TECH I OWN:

2017 Audi Q7 | iPhone Xs Max | Apple Watch Series 3 42mm | 2018 MacBook Pro 15" [i7/560X/16GB/256GB] | Lenovo Flex 3 [i7-5500U, HD5500 (fastest on the forum), 8GB RAM, 256GB Samsung 840 Evo] | Xbox One [Home Theater setup] | DJI Phantom 3 Standard | Sony WH-1000XM3 | Jaybird Freedom (x2) & X2 [long story, PM if you want to know why I have 3 pairs of Jaybirds]

 

Link to post
Share on other sites

I had a problem earlier today where I was getting massive FPS dips that brought my GTX 1080 to 2-20 fps. Task Manager showed some abnormally high RAM usage coming from PUBG even after I had closed it and a quick End Process didn't resolve. I ultimately restarted my PC and it seemed to fix the FPS issues. Not sure on what was really causing it and whether or not PUBG was the true culprit.

Link to post
Share on other sites
Posted · Original PosterOP
7 minutes ago, Shiv78 said:

 

Yeah Speccy isn't great... device manager or CPUZ/GPUZ is usually better

 

9 minutes ago, itsmyjobtoknow said:

Speecy....isn't necessarily the most accurate at reporting system info. 

 

10 minutes ago, Jurrunio said:

Where did you get your graphics card? GTX 1070s all have 8GB VRAM. With only 4 on your card, you might have a refreshed old card with 1070 VBIOS. Pf course it could be the app showing false info

 

Does this help at all? 

a6d8dda71aac51e7ae2cb77a2fa1471a.png

Link to post
Share on other sites

you may want to just try a fresh and install and see if it helps to see if its your windows install that is fucked 

Link to post
Share on other sites

Try run malawarebytes couldnt hurt.


My Rig

CPU - Ryzen 5 1600@3.8ghz          GPU - XFX XXX RX580 8g          Cooler - Arctic Freezer 33 eSports edition green          Motherboard - Gigabyte AB350 Gaming 3          Ram -  G.Skill 2x8 Ripjaws 5 2666                   Case - Pahntecs P400s TGE Modded with Green accents          PSU - Seasonic M1211 evo 620w          SSD - Samsung 960 evo 500 GB          HDD - Seagate Barracuda 7200rpm 2tb       

 Fans - 2 be quiet SilentWings 3         OS - Windows 10 Home 64-Bit         Cables - Cable Mod Green Cable Extension

 Peripherals

Mouse - Logitech G502          Keyboard - k95 Platinum Brown          Headset - Philips SHP9500s + Vmoda Boom Pro          Monitor - LG 29UM69GB

Webcam - USB webcam for Wii Fitness game xD

Link to post
Share on other sites

What resolution are you playing on? You should get 60+ fps fps at 1080 p for sure with those settings my 770 with a 4690 gets 60+. Did you check the utilisation of your CPU and gpu during pubg yet? Something like msi afterburner will show that great. 

Link to post
Share on other sites

Broken Fan causing thermal throttling?

Dust?

Maybe some screenshots in game with MSI afterburner might help show any temperature issues.

Link to post
Share on other sites
On 8/6/2017 at 0:42 AM, EPENEX said:

Install Linux.

How unfunny

 

OT, PUBG is not optimized like stated before..Try doing a fresh install of your gpu driver. Also make sure your monitor's cable is connected to your GPU not the one on your mobo


Don't call me a nerd, it makes me look slightly smarter than you

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×