Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
bgibbz

Unable to set refresh rate

Actually... I seemed to have fixed it. I simply uninstalled the monitor from device manager and rebooted and now it works... which is weird because i did that several times before posting this to no avail :/

Recommended Posts

Posted · Original PosterOP

I clean installed windows yesterday, but i am having an issue getting my display (benq xl2720z) to correctly run at 144 hz. Previously, i went to nvidia control panel, set resolution, then the refresh rate dropdown would have an option for 144hz. It does not however. I then created a custom resolution, manually set the refresh rate to be 144hz, but the custom resolution doesnt apear to be saving. I am unable to select 144hz as an option from within games, so i assume that somehow the monitor isnt being recognized as 144hz. I manually installed the drivers from benqs website, and gpu drivers are up to date. Rest of my system specs are in my Sig. Thanks for any help!


******If you paste in text into your post, please click the "remove formatting" button for night theme users.******

CPU- Intel 6700k OC to 4.69 Ghz GPU- NVidia Geforce GTX 970 (MSI) RAM- 16gb DDR4 2400 SSD-2x500gb samsung 850 EVO(SATA) Raid 0 HDD- 2tb Seagate Case- H440 Red w/ custom lighting Motherboard - MSI Z170 Gaming A OS- Windows 10 Mouse- Razer Naga Epic Chroma, Final Mouse 2016 turney proKeyboard- Corsair k70 Cherry MX brown

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

Actually... I seemed to have fixed it. I simply uninstalled the monitor from device manager and rebooted and now it works... which is weird because i did that several times before posting this to no avail :/


******If you paste in text into your post, please click the "remove formatting" button for night theme users.******

CPU- Intel 6700k OC to 4.69 Ghz GPU- NVidia Geforce GTX 970 (MSI) RAM- 16gb DDR4 2400 SSD-2x500gb samsung 850 EVO(SATA) Raid 0 HDD- 2tb Seagate Case- H440 Red w/ custom lighting Motherboard - MSI Z170 Gaming A OS- Windows 10 Mouse- Razer Naga Epic Chroma, Final Mouse 2016 turney proKeyboard- Corsair k70 Cherry MX brown

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×