Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Carrots

Doom FPS bottleneck

Recommended Posts

Posted · Original PosterOP

I recently reinstalled Doom (2016) on my new laptop and its capping at 20 fps in menus and in game. I updated my nvidia drivers, I went through the game settings and turned everything to low, I've tried the vulkan and opengl API for the game. I've made sure vertical sync is off in game and in my global settings. I've made physx run off of my gpu instead of my integrated graphics (in the nvidia control panel.) I've changed the power management mode in the 3D settings to prefer maximum performance. I've verified my steam files. 

Specs:

GPU: NV GTX 1050 4GB GDDR5

Memory: 8GB DDR4 2400 (8GBx1)

Cpu: i7-7700HQ Quad Core

Hard drives: 1TB sata + 128GB ssd

 

This is the exact laptop I have: https://www.amazon.com/gp/product/B06XFGF7SN/ref=oh_aui_detailpage_o03_s00?ie=UTF8&psc=1

Link to post
Share on other sites

That is a strange one. The menus have no reason to be capped at 20fps. The only other thing I can think of is maybe a framerate cap you stuck on by mistake with something like MSI Afterburner (More specifically Riva Tuner Statistics Server that comes with it). Additionally, make sure you're running dedicated fullscreen. The latter shouldn't make or break your framerate, but gotta start somewhere.


OS: W10 | MB: ASUS Sabertooth P67 | CPU: i7 2600k @ 4.6 | RAM: 2x8GB Corsair Vengeance 1600mhz | GPU: x2 MSI GTX 980 Gaming 4G | Storage: x2 WD CB 1TB, x1 WD CB 500GB | PSU: Corsair RM850x | Spare a moment for Night Theme Users:

Spoiler

I'm an erudite cave-dwelling Troglodyte
I frequent LinusTechTips past midnight
Dark backgrounds I crave 
For my sun-seared red gaze
I'll molest you if you don't form your text right

 

Link to post
Share on other sites

must be running on the IGPU:

 

Quote

To correct the launch issues, simply open nvida control panel. In the program settings tab, select DOOM from the list (If it is not in the list already, add it manually. The EXE can most likely be found in this location C:\Program Files (x86)\Steam\steamapps\common\DOOM.) In the box #2, select "High Performance NVIDIA processor" from the list. Feel free to adjust any of the graphics settings available as well. If you were experiencing the same issue as me, you should now be able to launch the game and actually play! Be sure you are also using the latest driver from NVIDIA (365.19 as of this posting). I hope this help you all and saves you from any further frustration. Enjoy!

 

Link to post
Share on other sites
Posted · Original PosterOP
21 minutes ago, TrigrH said:

must be running on the IGPU:

 

 

That didn't work for me thanks though.

Link to post
Share on other sites
Posted · Original PosterOP
54 minutes ago, LooneyJuice said:

That is a strange one. The menus have no reason to be capped at 20fps. The only other thing I can think of is maybe a framerate cap you stuck on by mistake with something like MSI Afterburner (More specifically Riva Tuner Statistics Server that comes with it). Additionally, make sure you're running dedicated fullscreen. The latter shouldn't make or break your framerate, but gotta start somewhere.

Not only the menu is capped, in game its the same thing. Also I don't have msi afterburner, and the game ran fine about 2 weeks ago. And I am running it in full-screen. There was a patch to the game a few days ago but noone else has this problem so I don't think the patch is the problem.

Link to post
Share on other sites
Posted · Original PosterOP

INTERESTING NOTE: I changed the game to windowed and it runs perfect. (Menus going back to 60 fps) Borderless windowed was still capped to 20.

Link to post
Share on other sites
1 minute ago, Carrots said:

INTERESTING NOTE: I changed the game to windowed and it runs perfect. (Menus going back to 60 fps) Borderless windowed was still capped to 20.

That's kinda funny. Does it run as well in Fullscreen? Bear in mind Vulkan was pretty finicky when it came to dedicated fullscreen, so your mileage may vary between OpenGL and Vulkan.


OS: W10 | MB: ASUS Sabertooth P67 | CPU: i7 2600k @ 4.6 | RAM: 2x8GB Corsair Vengeance 1600mhz | GPU: x2 MSI GTX 980 Gaming 4G | Storage: x2 WD CB 1TB, x1 WD CB 500GB | PSU: Corsair RM850x | Spare a moment for Night Theme Users:

Spoiler

I'm an erudite cave-dwelling Troglodyte
I frequent LinusTechTips past midnight
Dark backgrounds I crave 
For my sun-seared red gaze
I'll molest you if you don't form your text right

 

Link to post
Share on other sites
Posted · Original PosterOP
50 minutes ago, LooneyJuice said:

That's kinda funny. Does it run as well in Fullscreen? Bear in mind Vulkan was pretty finicky when it came to dedicated fullscreen, so your mileage may vary between OpenGL and Vulkan.

Fullscreen it runs at 20 fps. And I tried opengl and it also gave me the same results. This is super strange.

Link to post
Share on other sites
6 minutes ago, Carrots said:

Fullscreen it runs at 20 fps. And I tried opengl and it also gave me the same results. This is super strange.

I'd suggest trying other games to determine whether or not this is a Doom-specific issue if you haven't already. Because 20 fps specifically sounds like some weird frame capping, especially regarding the menu which isn't resource demanding at all. If you wish to do so, you could completely delete your NV or iGPU drivers using DDU and reinstalling. But, if it's just specific to Doom, it may hint at something else, and may be worth reporting.


OS: W10 | MB: ASUS Sabertooth P67 | CPU: i7 2600k @ 4.6 | RAM: 2x8GB Corsair Vengeance 1600mhz | GPU: x2 MSI GTX 980 Gaming 4G | Storage: x2 WD CB 1TB, x1 WD CB 500GB | PSU: Corsair RM850x | Spare a moment for Night Theme Users:

Spoiler

I'm an erudite cave-dwelling Troglodyte
I frequent LinusTechTips past midnight
Dark backgrounds I crave 
For my sun-seared red gaze
I'll molest you if you don't form your text right

 

Link to post
Share on other sites
Posted · Original PosterOP
36 minutes ago, LooneyJuice said:

I'd suggest trying other games to determine whether or not this is a Doom-specific issue if you haven't already. Because 20 fps specifically sounds like some weird frame capping, especially regarding the menu which isn't resource demanding at all. If you wish to do so, you could completely delete your NV or iGPU drivers using DDU and reinstalling. But, if it's just specific to Doom, it may hint at something else, and may be worth reporting.

Black ops 3, Smite, Player Unknown's Battle Grounds, and Gmod all run fine. And I don't think its the drivers because the game is uncapped in windows mode. 

Link to post
Share on other sites

It's the Riva Statistic Server (rss) in my case. When I close it, it works fine. I don't know why and it's the only game I'am currently playing which is using Vulkan. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×