Jump to content
Phishing Emails & YouTube Messages - Fake Giveaway Read more... ×
Search In
  • More options...
Find results that contain...
Find results in...
NovaeRogX

Corsair HD140 RGB Issue

Recommended Posts

Posted · Original PosterOP

Hi,

 

Just received the twin pack for HD140 RGB fans with the HD controller but it seems only 1 fan will light at a time when plugged into no 1. Both fans light but not together. Would this be a controller issue or is there a setting I'm missing?#

 

Thanks

Link to post
Share on other sites
9 minutes ago, NovaeRogX said:

Hi,

 

Just received the twin pack for HD140 RGB fans with the HD controller but it seems only 1 fan will light at a time when plugged into no 1. Both fans light but not together. Would this be a controller issue or is there a setting I'm missing?#

 

Thanks

If you have several fans, they must be plugged into 1-2-3-4-5-6 slots in the order you want them to light up. You can't skip a slot or it won't work. Then you can change the mode of lightning using the appropriate button. 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, ErrantNyles said:

If you have several fans, they must be plugged into 1-2-3-4-5-6 slots in the order you want them to light up. You can't skip a slot or it won't work. Then you can change the mode of lightning using the appropriate button. 

I only have the 2, 1 lights up but 2 doesn't

Link to post
Share on other sites
1 minute ago, NovaeRogX said:

I only have the 2, 1 lights up but 2 doesn't

If you change the position of the two, do they do the same thing ? (The "new" 1 lights up, the "new" 2 doesn't).

Link to post
Share on other sites
Posted · Original PosterOP
Just now, ErrantNyles said:

If you change the position of the two, do they do the same thing ? (The "new" 1 lights up, the "new" 2 doesn't).

Yeah. Just tried something there; if I put a connector into 2 first then into 1, it lights up. Tried doing it with the fans swapped, 1 light up normally, 2 looked distorted. I have a feeling the number 2 RGB connector on the controller is somewhat faulty

Link to post
Share on other sites
Just now, NovaeRogX said:

Yeah. Just tried something there; if I put a connector into 2 first then into 1, it lights up. Tried doing it with the fans swapped, 1 light up normally, 2 looked distorted. I have a feeling the number 2 RGB connector on the controller is somewhat faulty

It seems so. If you just plug the first fin into 1, and the second unplugged and it lights up, then switch the fans and the other lights up as wel.. yeah, it's the controller.

Link to post
Share on other sites
Posted · Original PosterOP
Just now, ErrantNyles said:

It seems so. If you just plug the first fin into 1, and the second unplugged and it lights up, then switch the fans and the other lights up as wel.. yeah, it's the controller.

Going to contact Corsair about a replacement controller. Maybe they'll take pity and give me a free Commander controller haha. Thanks for helping anyway

Link to post
Share on other sites

Sounds like bad fan hub, sorry about that. 

 

Yes, contact our support and I am sure they'll get you sorted out in no time. If you run into any issues with replacement/exchange, let me know. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×