Jump to content

Duplicate IP addresses on VLAN Sourced back to router

Go to solution Solved by legopc,

Maybe you get duplicate addresses because you HAVE duplicate addresses... Your giving vlan 101 on ya cisco an ip of bla.1 and vlan 101 on ya edgemax an ip of bla.1 so yeah, thats duplicate. 

If you need help, just send me a message... 

So here is the issue. I am trying to impliment VLANs on my network but for some reason I keep on getting duplicate Addresses on my VLANs. can anyone help 

 

Ubiquiti ERL Config:

jato@PortalGun:~$ show configuration                                            
firewall {                                                                      
    all-ping enable                                                             
    broadcast-ping disable                                                      
    ipv6-receive-redirects disable                                              
    ipv6-src-route disable                                                      
    ip-src-route disable                                                        
    log-martians enable                                                         
    name WAN_IN {                                                               
        default-action drop                                                     
        description "WAN to internal"                                           
        rule 10 {                                                               
            action accept                                                       
            description "Allow established/related"                             
            state {                                                             
                established enable                                              
                related enable                                                  
            }                                                                   
        }                                                                       
        rule 20 {                                                               
            action drop                                                         
            description "Drop invalid state"                                    
            state {                                                             
                invalid enable                                                  
            }
        }
    }
    name WAN_LOCAL {
        default-action drop
        description "WAN to router"
        rule 10 {
            action accept
            description "Allow established/related"
            state {
                established enable
                related enable
            }
        }
        rule 20 {
            action drop
            description "Drop invalid state"
            state {
                invalid enable
            }
        }
    }
    receive-redirects disable
    send-redirects enable
    source-validation disable
    syn-cookies enable
}
interfaces {
    ethernet eth0 {
        address dhcp
        description Internet
        duplex auto
        firewall {
            in {
                name WAN_IN
            }
            local {
                name WAN_LOCAL
            }
        }
        speed auto
    }
    ethernet eth1 {
        address 10.10.1.1/24
        description Local
        duplex auto
        speed auto
        vif 101 {
            address 10.10.10.1/24
            description Miniverse
        }
        vif 102 {
            address 10.10.20.1/24
            description Microverse
            mtu 1500
        }
        vif 103 {
            address 10.10.30.1/24
            description Tinyverse
            mtu 1500
        }
    }
    ethernet eth2 {
        address 192.168.2.1/24
        description "Local 2"
        duplex auto
        speed auto
    }
    loopback lo {
    }
}
service {
    dhcp-server {
        disabled false
        hostfile-update disable
        shared-network-name LAN1 {
            authoritative enable
            disable
            subnet 10.10.1.0/24 {
                default-router 10.10.1.1
                dns-server 10.10.1.1
                lease 86400
                start 10.10.1.38 {
                    stop 10.10.1.243
                }
            }
        }
        shared-network-name LAN2 {
            authoritative enable
            subnet 192.168.2.0/24 {
                default-router 192.168.2.1
                dns-server 192.168.2.1
                lease 86400
                start 192.168.2.38 {
                    stop 192.168.2.243
                }
            }
        }
        shared-network-name Microverse_DHCP {
            authoritative disable
            subnet 10.10.20.0/24 {
                default-router 10.10.20.1
                dns-server 10.10.20.1
                domain-name Portal.Gun
                lease 86400
                start 10.10.20.9 {
                    stop 10.10.20.137
                }
            }
        }
        shared-network-name Miniverse_DHCP {
            authoritative disable
            subnet 10.10.10.0/24 {
                default-router 10.10.10.1
                dns-server 10.10.10.1
                domain-name Portal.Gun
                lease 86400
                start 10.10.10.9 {
                    stop 10.10.10.137
                }
            }
        }
        shared-network-name Tinyverse_DHCP {
            authoritative disable
            subnet 10.10.30.0/24 {
                default-router 10.10.30.1
                dns-server 10.10.30.1
                domain-name Portal.Gun
                lease 86400
                start 10.10.30.9 {
                    stop 10.10.30.37
                }
            }
        }
        use-dnsmasq enable
    }
    dns {
        forwarding {
            cache-size 150
            listen-on eth1
            listen-on eth2
            listen-on eth1.101
            listen-on eth1.102
            listen-on eth1.103
            name-server 8.8.8.8
            name-server 8.8.4.4
        }
    }
    gui {
        http-port 80
        https-port 443
        older-ciphers enable
    }
    nat {
        rule 5010 {
            description "masquerade for WAN"
            outbound-interface eth0
            type masquerade
        }
    }
    ssh {
        port 22
        protocol-version v2
    }
}
system {
    domain-name Portal.Gun
    host-name PortalGun
    login {
        user jato {
            authentication {
                encrypted-password ****************
            }
            level admin
        }
    }
    name-server 127.0.0.1
    ntp {
        server 0.ubnt.pool.ntp.org {
        }
        server 1.ubnt.pool.ntp.org {
        }
        server 2.ubnt.pool.ntp.org {
        }
        server 3.ubnt.pool.ntp.org {
        }
    }
    syslog {
        global {
            facility all {
                level notice
            }
            facility protocols {
                level debug
            }
        }
    }
    time-zone UTC
}
jato@PortalGun:~$ 

 

Cisco 35060G Config:

C-137#show running-config
Building configuration...

Current configuration : 6363 bytes
!
! Last configuration change at 06:32:26 UTC Wed Mar 3 1993
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname C-137
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
system mtu routing 1500
ip routing
!
!
!
!
crypto pki trustpoint TP-self-signed-2191619712
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2191619712
 revocation-check none
 rsakeypair TP-self-signed-2191619712
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/1
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/2
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/3
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/4
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/5
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/6
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/7
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/8
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/9
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/10
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/11
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/12
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/13
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/14
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/15
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/16
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet0/17
 switchport access vlan 102
 switchport mode access
!
interface GigabitEthernet0/18
 switchport access vlan 102
 switchport mode access
!
interface GigabitEthernet0/19
 switchport access vlan 102
 switchport mode access
!
interface GigabitEthernet0/20
 switchport access vlan 102
 switchport mode access
!
interface GigabitEthernet0/21
 switchport mode access
!
interface GigabitEthernet0/22
 switchport mode access
!
interface GigabitEthernet0/23
 switchport mode access
!
interface GigabitEthernet0/24
 switchport mode access
!
interface GigabitEthernet0/25
 switchport mode access
!
interface GigabitEthernet0/26
 switchport mode access
!
interface GigabitEthernet0/27
 switchport mode access
!
interface GigabitEthernet0/28
 switchport mode access
!
interface GigabitEthernet0/29
 switchport mode access
!
interface GigabitEthernet0/30
 switchport mode access
!
interface GigabitEthernet0/31
 switchport mode access
!
interface GigabitEthernet0/32
 switchport mode access
!
interface GigabitEthernet0/33
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/34
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/35
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/36
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/37
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/38
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/39
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/40
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/41
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/42
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/43
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/44
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/45
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/46
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/47
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/48
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet0/49
 switchport trunk encapsulation dot1q
 switchport trunk allowed vlan 101-103
 switchport mode trunk
!
interface GigabitEthernet0/50
 switchport mode access
!
interface GigabitEthernet0/51
 switchport mode access
!
interface GigabitEthernet0/52
 switchport mode access
!
interface Vlan1
 ip address 10.10.1.1 255.255.255.0
!
interface Vlan101
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan102
 ip address 10.10.20.1 255.255.255.0
!
interface Vlan103
 ip address 10.10.30.1 255.255.255.0
!
ip http server
ip http secure-server
!
!
!
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Thanks for the help.

Processor-Intel - Core i9-7900X 3.3GHz , Motherboard- Gigabyte - X299 AORUS Gaming 7, RAM- G.Skill - TridentZ RGB 32GB (4 x 8GB) DDR4-4000 Memory, GPU-Zotac - GeForce GTX 1080 Ti 11GB AMP Extreme,  Case- Phanteks - Enthoo Evolv ATX Glass, Storage- Samsung - 960 EVO 250GB M.2-2280, Samsung 850 Evo 250GB SSD, Samsung 850 EVO 1TB SSD, Toshiba 4TB (PH3400U) , PSU- SeaSonic 1200W Platinum, Cooling- NZXT - Kraken X62 Rev 2, Sound-Sennheiser - HD 598SE, SURE - SM7B, OS- Windows 10 Pro.

Link to comment
Share on other sites

Link to post
Share on other sites

Maybe you get duplicate addresses because you HAVE duplicate addresses... Your giving vlan 101 on ya cisco an ip of bla.1 and vlan 101 on ya edgemax an ip of bla.1 so yeah, thats duplicate. 

If you need help, just send me a message... 

If you tell a big enough lie and tell it frequently enough it will be believed.

-Adolf Hitler 

Link to comment
Share on other sites

Link to post
Share on other sites

1 hour ago, legopc said:

Maybe you get duplicate addresses because you HAVE duplicate addresses... Your giving vlan 101 on ya cisco an ip of bla.1 and vlan 101 on ya edgemax an ip of bla.1 so yeah, thats duplicate. 

If you need help, just send me a message... 

You beat me to it :P

Link to comment
Share on other sites

Link to post
Share on other sites

Got it figured out thanks for your help. 

Processor-Intel - Core i9-7900X 3.3GHz , Motherboard- Gigabyte - X299 AORUS Gaming 7, RAM- G.Skill - TridentZ RGB 32GB (4 x 8GB) DDR4-4000 Memory, GPU-Zotac - GeForce GTX 1080 Ti 11GB AMP Extreme,  Case- Phanteks - Enthoo Evolv ATX Glass, Storage- Samsung - 960 EVO 250GB M.2-2280, Samsung 850 Evo 250GB SSD, Samsung 850 EVO 1TB SSD, Toshiba 4TB (PH3400U) , PSU- SeaSonic 1200W Platinum, Cooling- NZXT - Kraken X62 Rev 2, Sound-Sennheiser - HD 598SE, SURE - SM7B, OS- Windows 10 Pro.

Link to comment
Share on other sites

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×