Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Doug S

SOLVED: Logitech G700S Software Hangs during Installation

Recommended Posts

Posted · Original PosterOP
SOLVED: The issue is due to a generic Windows 10 driver causing a hardware conflict when the software attempts to initialize and connect to your mouse. I hope my resolution helps others as I could not find anything online for this. I ended going as far as a complete wipe and reinstall of Win 10, using older versions of the program, trying just the dongle, swearing at it, etc. and that did not work. My only resolution was the following. Perhaps Logitech could put a fix into this issue.
 
1) Try to install the software, system will hang. Power cycle your machine.

2) Go to Device Manager, and expand 'Mice and other pointing devices'.

3) Right-click and choose 'Update Device Driver'.

4) Click Browse. Locate the folder 'C:\Program Files\Logitech Gaming Software'.

5) Windows 10 should now update your driver and show the Logitech driver instead of generic one.

6) Reboot. Now you should be able to install the driver.
 
Good luck and I hope someone out there finds this useful! :)
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×