Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Metallus97

Super weird issues running DOOM with Vulkan API on system with AMD R9 290 and Nvidia GTX 780

1 minute ago, Metallus97 said:

Only a setting for selecting the display itself...

Showing only one screen connected -> correct

Hmmmm. I found this:

https://forums.geforce.com/default/topic/950004/pc-games/doom-choosing-my-gtx-970-over-my-1080-multi-gpu-issue-/

Check it out. Maybe it can help....

Recommended Posts

Posted · Original PosterOP

I discovered some relay weird things while playing Doom and trying out the Vulcan API...o.O

 

I am running a AMD R9 290 as my main GPU (my display is connected to this card and it is doing all my gaming work).

But I also have a GTX 780 installed in my PC, because i am using it for folding at home.

GPUs.PNG

Now to the issue i am having:

Running Doom in OpenGL Mode gives me this reading in game:

Spoiler

20170216194114_1.jpg

seems normal and also the MSI afterburner usage Graphs are normal

 

GPU1 is the 290

GPU2 is the 780

Spoiler

afterburner open GL.PNG

GPU1(AMD) is at 100 and GPU2 (Nvidia) is doing nothing -> nice

 

Now lets switch to Vulcan.

Note: No other changes made. Display still connected to the AMD card.

Only change: switched the game to Vulcan

Spoiler

vulcan.jpg

(sorry steam screenshots do not work in vulkan)

Now its is showing my GPU to be the 780...?

Although its not connected to the monitor

 

Also afterburner proves the 780 being the card computing the game:

Spoiler

vulcan afterburner.PNG

Does anyone have any input or ideas on this? Or know how tho switch back to my 290?

I cant believe this is even working.... but for me it looks like the 780 is processing the game and the video somehow gets pushed through the 290 to my monitor...

 

Thanks in advice for any help ;)

 

 

 

 


You don't need anybody to tell you who you are or what you are. You are what you are!

-John Lennon
 

Link to post
Share on other sites

Make sure that you have selected the GPU you want the game to use...

BTW, it's weird not wired, the meaning is completely different. (Sorry if I came off as an asshole xD)


CPU: Intel Core i7-5820K | Motherboard: AsRock X99 Extreme4 | Graphics Card: Gigabyte GTX 1080 G1 Gaming | RAM: 16GB G.Skill Ripjaws4 2133MHz | Storage: 1 x Samsung 840 Series 128GB | 1 x Seagate 1TB | 1 x WD Blue 500GB | PSU: Seasonic M12II Evo 620W | Case: Phanteks Enthoo Pro (White) | Cooling: Arctic Freezer i32

 

 

GTX 1060 vs RX 480 (old)

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, PCGuy_5960 said:

Make sure that you have selected the GPU you want the game to use...

BTW, it's weird not wired, the meaning is completely different. (Sorry if I came off as an asshole xD)

ah shitxD

not cables

thanks ;)

 

So where is the option to select the GPU?


You don't need anybody to tell you who you are or what you are. You are what you are!

-John Lennon
 

Link to post
Share on other sites
2 minutes ago, Metallus97 said:

ah shitxD

not cables

thanks ;)

 

So where is the option to select the GPU?

Np :D

Does it have a display adapter option or something?


CPU: Intel Core i7-5820K | Motherboard: AsRock X99 Extreme4 | Graphics Card: Gigabyte GTX 1080 G1 Gaming | RAM: 16GB G.Skill Ripjaws4 2133MHz | Storage: 1 x Samsung 840 Series 128GB | 1 x Seagate 1TB | 1 x WD Blue 500GB | PSU: Seasonic M12II Evo 620W | Case: Phanteks Enthoo Pro (White) | Cooling: Arctic Freezer i32

 

 

GTX 1060 vs RX 480 (old)

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, PCGuy_5960 said:

Np :D

Does it have a display adapter option or something?

Only a setting for selecting the display itself...

Showing only one screen connected -> correct


You don't need anybody to tell you who you are or what you are. You are what you are!

-John Lennon
 

Link to post
Share on other sites
Posted · Best Answer
1 minute ago, Metallus97 said:

Only a setting for selecting the display itself...

Showing only one screen connected -> correct

Hmmmm. I found this:

https://forums.geforce.com/default/topic/950004/pc-games/doom-choosing-my-gtx-970-over-my-1080-multi-gpu-issue-/

Check it out. Maybe it can help....


CPU: Intel Core i7-5820K | Motherboard: AsRock X99 Extreme4 | Graphics Card: Gigabyte GTX 1080 G1 Gaming | RAM: 16GB G.Skill Ripjaws4 2133MHz | Storage: 1 x Samsung 840 Series 128GB | 1 x Seagate 1TB | 1 x WD Blue 500GB | PSU: Seasonic M12II Evo 620W | Case: Phanteks Enthoo Pro (White) | Cooling: Arctic Freezer i32

 

 

GTX 1060 vs RX 480 (old)

Link to post
Share on other sites

I had this issue in my PC on Doom in any API, I have a 980Ti, but also had a Quadro 600 installed. Whenever I launched Doom, the Quadro would leap in and try to run the game. (Ever had a GPU bottle neck so bad it made the game take 10 minutes to load?) My solution was to just go into device manager and disable the Quadro during gaming. That worked for me anyway, YMMV.


¢υѕтσм ℓσσρ σя ησтнιηg αт αℓℓ

Link to post
Share on other sites

@Metallus97 I did a bit more research and I found out that this is an issue with Doom in general. Everyone who has 2 GPUs that are not in SLI and uses Vulkan has the EXACT same issue :D


CPU: Intel Core i7-5820K | Motherboard: AsRock X99 Extreme4 | Graphics Card: Gigabyte GTX 1080 G1 Gaming | RAM: 16GB G.Skill Ripjaws4 2133MHz | Storage: 1 x Samsung 840 Series 128GB | 1 x Seagate 1TB | 1 x WD Blue 500GB | PSU: Seasonic M12II Evo 620W | Case: Phanteks Enthoo Pro (White) | Cooling: Arctic Freezer i32

 

 

GTX 1060 vs RX 480 (old)

Link to post
Share on other sites
Posted · Original PosterOP
5 minutes ago, Codyman125 said:

I had this issue in my PC on Doom in any API, I have a 980Ti, but also had a Quadro 600 installed. Whenever I launched Doom, the Quadro would leap in and try to run the game. (Ever had a GPU bottle neck so bad it made the game take 10 minutes to load?) My solution was to just go into device manager and disable the Quadro during gaming. That worked for me anyway, YMMV.

DUDE! So simple but works!

THANKS!

 

But this is not 100% satisfying for me ill also try the method from the geforce forums. Because when my GTX is disabled during gameplay it cand fold ;(

 

but anyways thanks to both of you ;)


You don't need anybody to tell you who you are or what you are. You are what you are!

-John Lennon
 

Link to post
Share on other sites
Posted · Original PosterOP

method form gforce forums does also work ;)

Although its a bit fiddly when the other card is AMD


You don't need anybody to tell you who you are or what you are. You are what you are!

-John Lennon
 

Link to post
Share on other sites
1 minute ago, Metallus97 said:

method form gforce forums does also work ;)

Although its a bit fiddly when the other card is AMD

Nice :D

Glad that helped you man!


CPU: Intel Core i7-5820K | Motherboard: AsRock X99 Extreme4 | Graphics Card: Gigabyte GTX 1080 G1 Gaming | RAM: 16GB G.Skill Ripjaws4 2133MHz | Storage: 1 x Samsung 840 Series 128GB | 1 x Seagate 1TB | 1 x WD Blue 500GB | PSU: Seasonic M12II Evo 620W | Case: Phanteks Enthoo Pro (White) | Cooling: Arctic Freezer i32

 

 

GTX 1060 vs RX 480 (old)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×