Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TheBattleLogic

New PC build, weird FPS

Recommended Posts

Posted · Original PosterOP

Hey,

 

I just got a new pc here are my specs:

i7 6700(no k)

GTX 1060 3gb (Gigabyte)

8gb DDR4 2133Mhz (Crucial)

1TB HDD

 

I've been playing Battlefield 1 (Ultra 1080p 40~70 FPS) , Squad (14 FPS) and Company of Heroes 2 (~14FPS) and got low fps. I ran 2 tests a Valley Benchmark test and got a score of 1099 which is weird because I saw people getting a 2600 score. Is this normal?

And now I ran 3DMark and my top score was 6572, the graphics score was 11409, Physic score was 9531 and the combined score was 1415 6FPS, kinda weird isn't it?

 

Help me! Is this okay? Do I need to return my pc? 

Link to post
Share on other sites

install drivers

 


CPU : i5-6600K @4.4ghz | GPU : MSI GTX 1060 | Mobo: Asus Z170-A Pro | Cooler: Kraken x41 | PSU: SSm12-520w | Keyboard :Corsair Strafe RGB /w Cherry mx Red | Mice:Steelseries rival 300 | 

Link to post
Share on other sites

Is your computer actually running the GPU? I've had personal experiences where the graphics card wasn't initially detected so it ran off of the on-board iGPU. If no, then the only other thing I can think of is drivers. CHECK THOSE DAMN DRIVERS SON.


Remember to drink water!

Link to post
Share on other sites
Posted · Original PosterOP
21 minutes ago, toastythomas said:

Is your computer actually running the GPU? I've had personal experiences where the graphics card wasn't initially detected so it ran off of the on-board iGPU. If no, then the only other thing I can think of is drivers. CHECK THOSE DAMN DRIVERS SON.

It´s detected 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×