Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
TeamPlayer22

XFX RX 480 driver won't install (windows 10)

Recommended Posts

Posted · Original PosterOP

I've been running an Sapphire 7870 and wanted to upgrade to a XFX RX480, since I just got a 1440p monitor and it's shipping. I went to my "uninstall a program" section in the control panel and uninstalled my current version of Crimson 16.1. I then ran AMD's CleanUp Utility for good measure.

1.The screen went to low resolution, as it should, since I'd uninstalled the driver. Then I heard the Windows install sound and the screen went back to normal resolution. I went to device manager and found that Windows had already reinstalled the 7870 driver by itself.

2. I unplugged my network cable in hopes that that would stop Windows from reinstalling the driver. I uninstalled the driver from device manager and reran the CleanUp Utility. I restarted the computer and when it booted back the screen was at normal resolution and it looked like Windows had again reinstalled the driver by itself, even with the network cable disconnected.

3. I uninstalled the driver again and shut the computer off. I swapped the graphics cards and put the RX480 in. I booted up using a DVI cable on my Dell E228WFP (my current monitor, the new one is shipping). It booted up normally through the bios screens, but when it got to the Windows desktop, the screen went black after a few seconds and then the monitor went into sleep mode. It only does this when it isn't getting a signal.

4. I then booted into Safe Mode. Worked fine. The screen did not shut off and I looked at the Device Manager, it showed that there was an RX480 as the graphics adapter. I tried to install the Crimson 16.2 driver while in safe mode, but it kept freezing at the "Analyzing System" section and telling me to contact AMD.

5. I put the 7870 back in and booted up. Worked fine, no black screens. I uninstalled all drivers again and tried installing 16.2 driver. Worked fine, no errors. Shut down and put the 480 back in and booted up. Same problem, would go to black screen. Sometimes it will get to the desktop before black screen, other times it will only get past loading screen.

 

I'm not sure where I'm going wrong. My last card upgrade was a lot simpler.

Link to post
Share on other sites

If i were you i would use DDU (display driver uninstaller) to uninstall the old card. This will disable windows from reinstalling the driver. use that utility to untistall all display drivers, and then install the new GPU. install the drivers from AMDs website.

 

Here is the link for DDU - http://www.guru3d.com/files-details/display-driver-uninstaller-download.html


******If you paste in text into your post, please click the "remove formatting" button for night theme users.******

CPU- Intel 6700k OC to 4.69 Ghz GPU- NVidia Geforce GTX 970 (MSI) RAM- 16gb DDR4 2400 SSD-2x500gb samsung 850 EVO(SATA) Raid 0 HDD- 2tb Seagate Case- H440 Red w/ custom lighting Motherboard - MSI Z170 Gaming A OS- Windows 10 Mouse- Razer Naga Epic Chroma, Final Mouse 2016 turney proKeyboard- Corsair k70 Cherry MX brown

Link to post
Share on other sites
  1. Download DDU
  2. Reboot into safe mode
  3. Run DDU and uninstall Crimson drivers
  4. Reboot
  5. Install Crimson drivers for W10 with RX 480 installed

PC Part Picker Link || CPU: Intel i7 4790K @ 5Ghz; MB: ASUS Z97 Maximus VII Ranger; RAM: 16GB Corsair Vengeance 2400; GFX: Asus Strix 1080ti; CASE: Phanteks Enthoo Evolv ATX Glass; STORAGE: 500GB Samsung 960 Pro, 250GB 850 Evo, 500GB 850 Evo, 3TB WD Red; PSU: Corsair AX1200i; MONITOR: Acer Predator X34; PERIPHERALS: Razer Blackwidow Ultimate Chroma; Razer Deathadder Chroma, Audeze Mobius

 

Devices || Macbook Pro 15" (2016); iPad Pro 9.7"; iPhone Xr

 

Audio Gear || Headphones: Audeze iSine20; Audeze LCD-X; Audeze LCD-3; Mr Speakers Ether 2; Focal Clear; B&O H5; Sony MDR-1000x; AMP/DAC: Chord Qutest; Pathos Aurium; Bryston BHA-1; Matrix Audio Element X; Benchmark AHB2; Speakers: AudioEngine A5+; Focal Aria 936

 

 

Link to post
Share on other sites
4 minutes ago, TeamPlayer22 said:

 

Put the 7870 back in. Download DDU (Display Driver Uninstaller). Boot into Safe Mode, run DDU. Shut system down. Install RX 480. Power system on. Try installing drivers again.


Project White Lightning (My ITX Gaming PC): Core i5-4690K | CRYORIG H5 Ultimate | ASUS Maximus VII Impact | HyperX Savage 2x8GB DDR3 | Samsung 850 EVO 250GB | WD Black 1TB | Sapphire RX 480 8GB NITRO+ OC | Phanteks Enthoo EVOLV ITX | Corsair AX760 | LG 29UM67 | CM Storm Quickfire Ultimate | Logitech G502 Proteus Spectrum | HyperX Cloud II | Logitech Z333

Benchmark Results: 3DMark Firestrike: 10,528 | SteamVR VR Ready (avg. quality 7.1) | VRMark 7,004 (VR Ready)

 

Other systems I've built:

Core i3-6100 | CM Hyper 212 EVO | MSI H110M ECO | Corsair Vengeance LPX 1x8GB DDR4  | ADATA SP550 120GB | Seagate 500GB | EVGA ACX 2.0 GTX 1050 Ti | Fractal Design Core 1500 | Corsair CX450M

Core i5-4590 | Intel Stock Cooler | Gigabyte GA-H97N-WIFI | HyperX Savage 2x4GB DDR3 | Seagate 500GB | Intel Integrated HD Graphics | Fractal Design Arc Mini R2 | be quiet! Pure Power L8 350W

 

I am not a professional. I am not an expert. I am just a smartass. Don't try and blame me if you break something when acting upon my advice.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

...why are you still reading this?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×