Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Arise_

Gtx 1080 low fps in some games

Recommended Posts

Posted · Original PosterOP

I bought a gigabyte gtx 1080 windforce about a month ago and have been very happy with its performance in many of my games. I have a 1080p monitor at 85Hz I get a very good score in firestrike (i cant remember the score exactly as im at school right now and cant get the score) and many games run very well. however, some of my favorite games have issues sometimes. for example in csgo i get around 150 fps constant, while that is enough fps for me using an 85Hz monitor, it isnt as high as i think it should be. sometimes i get stutters and freezes and i watched some youtube videos of a gtx 1080 in csgo and someone with my exact config (4790k, gtx 1080, ssd) was getting around 500 fps on the same graphics settings i am running. On the main menu i get almost 2000 fps.

any help would be appreciated, thanks!

Link to post
Share on other sites
Posted · Original PosterOP
Just now, EnemySp0tt3d said:

is your monitor plugged into your gpu?

yes, another thing i wanted to add was that my temps on everything (cpu, gpu, mobo) are just fine while playing.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, 005grn said:

CPU ?

 

Driver ?

4790k non overclocked, nvidia driver 372.90

Link to post
Share on other sites

Umm, if you got new windows update, go into xbox app installed, go to settings, Game DVR, and turn it off.


CPU : i5-6600K @4.4ghz | GPU : MSI GTX 1060 | Mobo: Asus Z170-A Pro | Cooler: Kraken x41 | PSU: SSm12-520w | Keyboard :Corsair Strafe RGB /w Cherry mx Red | Mice:Steelseries rival 300 | 

Link to post
Share on other sites
Posted · Original PosterOP
Just now, Yttrizy said:

Umm, if you got new windows update, go into xbox app installed, go to settings, Game DVR, and turn it off.

Ive done that and it didnt help at all, thanks for the suggestion though!

Link to post
Share on other sites

What was your old GPU?


Cor Caeruleus Reborn v6

Spoiler

CPU: Intel - Core i7-8700K

CPU Cooler: be quiet! - PURE ROCK 
Thermal Compound: Arctic Silver - 5 High-Density Polysynthetic Silver 3.5g Thermal Paste 
Motherboard: ASRock Z370 Extreme4
Memory: G.Skill TridentZ RGB 2x8GB 3200/14
Storage: Samsung - 850 EVO-Series 500GB 2.5" Solid State Drive 
Storage: Samsung - 960 EVO 500GB M.2-2280 Solid State Drive
Storage: Western Digital - Blue 2TB 3.5" 5400RPM Internal Hard Drive
Storage: Western Digital - BLACK SERIES 3TB 3.5" 7200RPM Internal Hard Drive
Video Card: EVGA - 970 SSC ACX (1080 is in RMA)
Case: Fractal Design - Define R5 w/Window (Black) ATX Mid Tower Case
Power Supply: EVGA - SuperNOVA P2 750W with CableMod blue/black Pro Series
Optical Drive: LG - WH16NS40 Blu-Ray/DVD/CD Writer 
Operating System: Microsoft - Windows 10 Pro OEM 64-bit and Linux Mint Serena
Keyboard: Logitech - G910 Orion Spectrum RGB Wired Gaming Keyboard
Mouse: Logitech - G502 Wired Optical Mouse
Headphones: Logitech - G430 7.1 Channel  Headset
Speakers: Logitech - Z506 155W 5.1ch Speakers

 

Link to post
Share on other sites
5 minutes ago, Arise_ said:

Ive done that and it didnt help at all, thanks for the suggestion though!

Download MSI Afterburner and open up the graph, look at the GPU usage and temperature, check if anything is weird

Link to post
Share on other sites
Posted · Original PosterOP
47 minutes ago, ARikozuM said:

What was your old GPU?

my old gpu was an asus gtx 980 strix, i used ddu and installed all the new, fresh drivers for my card and i uninstalled all of asus's software for the gpu

Link to post
Share on other sites
Posted · Original PosterOP
45 minutes ago, Aytex said:

Download MSI Afterburner and open up the graph, look at the GPU usage and temperature, check if anything is weird

i recently uninstalled afterburner because i was getting display driver crashes and i found that the version of afterburner i had didnt agree with pascal cards at all, but i have gigabytes version and everything looks normal when i play games, usage is high-ish most of the time and the temps are just fine (~40c to ~70c under load)

Link to post
Share on other sites
17 minutes ago, Arise_ said:

i recently uninstalled afterburner because i was getting display driver crashes and i found that the version of afterburner i had didnt agree with pascal cards at all, but i have gigabytes version and everything looks normal when i play games, usage is high-ish most of the time and the temps are just fine (~40c to ~70c under load)

Can you try EVGA Precision? It's on the Steam store. 

Have you uninstalled the game? Some ini's contain the video card itself and can present issues.


Cor Caeruleus Reborn v6

Spoiler

CPU: Intel - Core i7-8700K

CPU Cooler: be quiet! - PURE ROCK 
Thermal Compound: Arctic Silver - 5 High-Density Polysynthetic Silver 3.5g Thermal Paste 
Motherboard: ASRock Z370 Extreme4
Memory: G.Skill TridentZ RGB 2x8GB 3200/14
Storage: Samsung - 850 EVO-Series 500GB 2.5" Solid State Drive 
Storage: Samsung - 960 EVO 500GB M.2-2280 Solid State Drive
Storage: Western Digital - Blue 2TB 3.5" 5400RPM Internal Hard Drive
Storage: Western Digital - BLACK SERIES 3TB 3.5" 7200RPM Internal Hard Drive
Video Card: EVGA - 970 SSC ACX (1080 is in RMA)
Case: Fractal Design - Define R5 w/Window (Black) ATX Mid Tower Case
Power Supply: EVGA - SuperNOVA P2 750W with CableMod blue/black Pro Series
Optical Drive: LG - WH16NS40 Blu-Ray/DVD/CD Writer 
Operating System: Microsoft - Windows 10 Pro OEM 64-bit and Linux Mint Serena
Keyboard: Logitech - G910 Orion Spectrum RGB Wired Gaming Keyboard
Mouse: Logitech - G502 Wired Optical Mouse
Headphones: Logitech - G430 7.1 Channel  Headset
Speakers: Logitech - Z506 155W 5.1ch Speakers

 

Link to post
Share on other sites

Can confirm that the FPS is kinda low. I get about 200-300fps on an i5-4460 and GTX1060 @ 1080.

 

Must be a driver issue. Maybe you could try an older driver instead?

Which map did you test on CS? Nuke for instance is notorious for worse fps than the other maps.

 

 


PC Specs - AMD Ryzen 5 3600X MSI B450M Mortar Max 16GB Corsair Vengeance LPX DDR4-3000 - RX5700XT 660p 1TBGB & 256GB 600p Fractal Define Mini C CM V550 - Pop!_OS 20.04

Link to post
Share on other sites
Posted · Original PosterOP
Just now, ARikozuM said:

Can you try EVGA Precision? It's on the Steam store. 

Have you uninstalled the game? Some ini's contain the video card itself and can present issues.

great suggestion to reinstall the game, i dont know why i never though of that, ill try that as soon as i get home thank you. and ill look at evga precision.

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, NelizMastr said:

Can confirm that the FPS is kinda low. I get about 200-300fps on an i5-4460 and GTX1060 @ 1080.

 

Must be a driver issue. Maybe you could try an older driver instead?

Which map did you test on CS? Nuke for instance is notorious for worse fps than the other maps.

 

 

oddly enough, i get that same fps on almost every map. dust II i get the highest, like almost 180 but still thats low

Link to post
Share on other sites
Posted · Original PosterOP

 

8 hours ago, ARikozuM said:

Can you try EVGA Precision? It's on the Steam store. 

Have you uninstalled the game? Some ini's contain the video card itself and can present issues.

ok so i just downloaded evga precision and it only shows about 15% - 20% usage, how do i fix that 

Link to post
Share on other sites

benchmark your card and stress test it

 

multiple guides already posted on how to do this

 

you need a baseline and the ability to isolate if the issue is specific to the game you're playing or other variables 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×