Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
!RoW!

My power suply dont work :(

Recommended Posts

Posted · Original PosterOP

My powersupply dont work,
When i turn om my pc there Will get power in all the parts in my pc but not in my screen, mouse and keyboard.
When i changed to an other powersupply it worked.
Please HELP me With WHAT the problem is.

+i only had the powersupply for 4month

Link to post
Share on other sites
3 minutes ago, !RoW! said:

My powersupply dont work,
When i turn om my pc there Will get power in all the parts in my pc but not in my screen, mouse and keyboard.
When i changed to an other powersupply it worked.
Please HELP me With WHAT the problem is.

+i only had the powersupply for 4month

What PSU

What components in your PC

 

Pictures?

Video preferably.


Roses are red

My name is Roy

We caught the alligator that ate the De Luca boy

Link to post
Share on other sites
Posted · Original PosterOP
Just now, UberGamerKing said:

What PSU

What components in your PC

 

Pictures?

Video preferably.

The parts its not the problem, it worked With no problem before but ONE Day When i was done gaming i just turned off my pc, next day i turn it on and it worn't work

Link to post
Share on other sites
Just now, !RoW! said:

The parts its not the problem, it worked With no problem before but ONE Day When i was done gaming i just turned off my pc, next day i turn it on and it worn't work

I highly doubt its not a hardware issue if it suddenly stopped working.

 

Please just tell me what PSU you have, and i would be able to tell you instantly whether it is the fault of it or not

 

My PSU, which cost $250, just randomly died on me one day. Bad things just sometimes happen randomly.


Roses are red

My name is Roy

We caught the alligator that ate the De Luca boy

Link to post
Share on other sites
1 minute ago, !RoW! said:

The parts its not the problem, it worked With no problem before but ONE Day When i was done gaming i just turned off my pc, next day i turn it on and it worn't work

It may have failed, but we need to know what power supply it is, and what parts your system has. Perhaps it was just borderline in being able to power the system and a replacement of the same type could fail again.


rmurad38

 

i7 6700k | 32GB Kingston HyperX DDR4 | ASUS Z170I Pro Gaming | Zotac GTX1070 FE | Samsung 950 Pro 256MB M.2 SSD | SanDisk X400 1TB SSD | Noctua NH-U9S Cooler | EVGA Hadron Air

Link to post
Share on other sites
Posted · Original PosterOP
3 minutes ago, UberGamerKing said:

I highly doubt its not a hardware issue if it suddenly stopped working.

 

Please just tell me what PSU you have, and i would be able to tell you instantly whether it is the fault of it or not

 

My PSU, which cost $250, just randomly died on me one day. Bad things just sometimes happen randomly.

Its a coolermaster g650m

Link to post
Share on other sites
Posted · Original PosterOP

My full pc build: Asus strix Gtx 960, gigabyte z97p-d3, coolermaster g650m, i7-4770k, Corsair h60, Zalman z11neo, kinston hyperx fury ddr3 2x4gb 1600hz.

Link to post
Share on other sites
10 minutes ago, !RoW! said:

Its a coolermaster g650m

The "G" series Cooler Master power supplies have 3 year warranty. Since its only 4 months old I'd suggest contacting them and requesting an RMA.

I did notice that that particular power supply is modular. Check all the connections on both ends of each cable to make sure they are secure. Without any more detail, thats all I can really suggest.

 

EDIT: I see you posted your specs while I was posting. That PSU looks fine for your hardware so unless a cable came loose, The unit may have just failed. Contact Cooler Master for an RMA.


rmurad38

 

i7 6700k | 32GB Kingston HyperX DDR4 | ASUS Z170I Pro Gaming | Zotac GTX1070 FE | Samsung 950 Pro 256MB M.2 SSD | SanDisk X400 1TB SSD | Noctua NH-U9S Cooler | EVGA Hadron Air

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, rmurad38 said:

The "G" series Cooler Master power supplies have 3 year warranty. Since its only 4 months old I'd suggest contacting them and requesting an RMA.

I did notice that that particular power supply is modular. Check all the connections on both ends of each cable to make sure they are secure. Without any more detail, thats all I can really suggest.

I have already checked

Link to post
Share on other sites
Posted · Original PosterOP
14 minutes ago, rmurad38 said:

The "G" series Cooler Master power supplies have 3 year warranty. Since its only 4 months old I'd suggest contacting them and requesting an RMA.

I did notice that that particular power supply is modular. Check all the connections on both ends of each cable to make sure they are secure. Without any more detail, thats all I can really suggest.

 

EDIT: I see you posted your specs while I was posting. That PSU looks fine for your hardware so unless a cable came loose, The unit may have just failed. Contact Cooler Master for an RMA.

I need to pay 30dollars just to ring :(

Link to post
Share on other sites

No need to actually call, use the form here:

 

https://account.coolermaster.com/LogOn.aspx

 

You WILL be responsible for shipping costs of the faulty unit to Coolermaster, you may need to decide if replacement is worth the cost.


rmurad38

 

i7 6700k | 32GB Kingston HyperX DDR4 | ASUS Z170I Pro Gaming | Zotac GTX1070 FE | Samsung 950 Pro 256MB M.2 SSD | SanDisk X400 1TB SSD | Noctua NH-U9S Cooler | EVGA Hadron Air

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×