Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ssj metroid

Wi-Fi slow on desktop, but fine on other devices

Recommended Posts

Posted · Original PosterOP

Here's my build:

http://pcpartpicker.com/list/Vc8gbj - If I use the T8E, I can't connect to the Internet. The TL-WN881ND does connect, but is very slow. Details below.

 

I'm currently running Windows 10 Home 64 bit, on build 10240 as a clean install.

 

So this all started yesterday after Windows decided to push an update. Before the update happened, my Wi-Fi adapter was working fine. At that time I was running the previous Windows Anniversary Update. But once the update was done and my computer restarted, I couldn't connect to the Wi-Fi anymore. At first, I thought it was a problem with the router, since my landlord has been known to have problems with routers before. Nothing I could do, since he doesn't give tenants access to the apartment routers. But then I noticed that my laptop and phone were getting onto the network perfectly fine. My fiancee uses a USB adapter (also from TP-Link), and she could also connect to the network perfectly fine as well. When I tried using the troubleshooter, it told me "'Wi-Fi' does not have a valid IP configuration". So I borrowed her adapter, and found that I could connect with it, but the speeds were incredibly slow. My desktop was getting over 2000ms ping, with 0.4Mbps download and 0.4Mbps upload speeds, while my laptop and phone were both getting around 3.0Mbps download and 1.0Mbps upload speeds on the same network, with only a 50ms ping to the same server. I've since gave the USB adapter back, and am now using TL-WN881ND, which gets similar speeds to the USB adapter. 

 

I've tried to figure out what was going on and fix it, but I've had no luck. I'm about ready to give up and lug my desktop to the Microcenter to see if they have better luck.

 

Here's what I've tried so far:

 

* Uninstall and reinstall the driver

* Reset the adapter

* Use a new adapter

* Reset the PC

* Clean install of Windows

* Various command line attempts to manually reset Internet Protocols

* Posted on /r/techsupport for advice

 

If you need images or logs, I can post links to them as soon as I can.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×