Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ArkTheYO

FTP Server

Recommended Posts

Posted · Original PosterOP

Hey All,

 i have created a FTP server using IIS which seems to work all fine on all the devices on my network but doesnt seem to work on devices outside the network, please help!

P.S.: I have done all the other necessary steps like port forwarding(creatinng port 21 and 20 on my router) and shutting down my antivirus as well as windows firewall! Even created port 21 on firewall ! please please help!

Link to post
Share on other sites
1 hour ago, ArkTheYO said:

Hey All,

 i have created a FTP server using IIS which seems to work all fine on all the devices on my network but doesnt seem to work on devices outside the network, please help!

P.S.: I have done all the other necessary steps like port forwarding(creatinng port 21 and 20 on my router) and shutting down my antivirus as well as windows firewall! Even created port 21 on firewall ! please please help!

What do you mean outside the network? As in the internet?


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites

Go to http://www.canyouseeme.org/ and test port 21

 

If it fails either your port forwarding isn't correct or the firewall is blocking it. Its very likely going to fail... but its quick to test and if it does pass then it eliminates a lot of troubleshooting steps.

Link to post
Share on other sites
52 minutes ago, ArkTheYO said:

Hey I have tried it a lot of times, it shows connection timed out all the time.  @Scheer please help! 

Are you using your public ISP address and not your local sever address?


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP
18 minutes ago, Abdul201588 said:

Are you using your public ISP address and not your local sever address?

If u r asking for what I am using while port checking then yes I am using my public ip address 

Link to post
Share on other sites
2 minutes ago, ArkTheYO said:

If u r asking for what I am using while port checking then yes I am using my public ip address 

Okay. One thing, the server did you assign a static IP address?


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP
1 minute ago, Abdul201588 said:

Okay. One thing, the server did you assign a static IP address?

Well I assigned it the ip address I found after typing in ipconfig, I. E., IPv4 address so yeah a static IP address! 

Link to post
Share on other sites
2 minutes ago, ArkTheYO said:

Well I assigned it the ip address I found after typing in ipconfig, I. E., IPv4 address so yeah a static IP address! 

Check your firewall on the server. Make sure inbound and outbound connections are set "accept" 


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Abdul201588 said:

Check your firewall on the server. Make sure inbound and outbound connections are set "accept" 

Hey i created my server using IIS, so i really dont know how to allow inbound/outbound connections. 

Though i have allowed all inbound as well as outbound rules in the windows firewall for the FTP Server.

I am extremally sorry for the late reply, thanks a lot for helping me and please continue to help plssss. :)

Link to post
Share on other sites
23 minutes ago, ArkTheYO said:

Hey i created my server using IIS, so i really dont know how to allow inbound/outbound connections. 

Though i have allowed all inbound as well as outbound rules in the windows firewall for the FTP Server.

I am extremally sorry for the late reply, thanks a lot for helping me and please continue to help plssss. :)

I know. I work with Windows server OSes. Which Server are you using? 2008 R2 2012 R2? 

 

 


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP
34 minutes ago, Abdul201588 said:

I know. I work with Windows server OSes. Which Server are you using? 2008 R2 2012 R2? 

 

 

Hey,  I actually created it using Windows 10.

Link to post
Share on other sites
3 minutes ago, ArkTheYO said:

Hey,  I actually created it using Windows 10.

Okay. Open up "windows firewall with advanced security" Then go to inbound rules, on the right hand side which says "New rule" click on it. Now you'll get a new window with options, now select "port" and click next. Now It'll ask for a specific port. Enter 20, 21, then click next again. Once you done that, click on "allow connection" And do the say for "outgoing rule"


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP
31 minutes ago, Abdul201588 said:

Okay. Open up "windows firewall with advanced security" Then go to inbound rules, on the right hand side which says "New rule" click on it. Now you'll get a new window with options, now select "port" and click next. Now It'll ask for a specific port. Enter 20, 21, then click next again. Once you done that, click on "allow connection" And do the say for "outgoing rule"

I did that too, still now working ! Please help up bro!

Link to post
Share on other sites
Posted · Original PosterOP
1 hour ago, Abdul201588 said:

Okay. Open up "windows firewall with advanced security" Then go to inbound rules, on the right hand side which says "New rule" click on it. Now you'll get a new window with options, now select "port" and click next. Now It'll ask for a specific port. Enter 20, 21, then click next again. Once you done that, click on "allow connection" And do the say for "outgoing rule"

I did that too, still now working !

any other solution please helppp

Link to post
Share on other sites
1 hour ago, ArkTheYO said:

I did that too, still now working !

any other solution please helppp

There's nothing I can think of. Unless your ISP has blocked certain ports.


CPU: i7 4790K |CPU Cooler: CM Hyper 212 Evo | Motherboard: Z97-A | RAM: 4x4GB Kingston Memory 1600mhz | GPU: Nvidia GTX 1060 6GB Zotac Mini | Case: K280 Case | PSU: Cooler Master B600 Power supply | SSD: 120GB Kingston V300 SSD | HDDs: 1x 250GB & 1x 1TB WD Blue | Monitors: 24" Acer S240HLBID + 24" Samsung  | OS: Win 10 Pro

 

Audio: Behringer 302USB Xenyx 5 Input Mixer | Neewer® NW-700 Microphone | Behringer PS400 Micropower Phantom Power Supply

 

Networking gear:  Lenovo ThinkCenter M82 ESXi 6.7 | Dell PowerEdge R210 II MDT/PDQ | TP-LINK TL-SG1024D 24-Port Gigabit | Cisco ASA 5505 VPN  | Cisco Catalyst 3750 Gigabit Switch

 

 

Link to post
Share on other sites
Posted · Original PosterOP
6 minutes ago, Abdul201588 said:

There's nothing I can think of. Unless your ISP has blocked certain ports.

but i did setup port 21 forwarding and additionally they have the option itself to select FTP on the port forwarding page which automatically puts in 21 value in the local and remote port range. :(

Link to post
Share on other sites
Posted · Original PosterOP
3 hours ago, Abdul201588 said:

There's nothing I can think of. Unless your ISP has blocked certain ports.

hey i forgot to tell u this but in the port forwarding option , there is also a field for remote host which i left as i didnt know what to fill in thogh i filled in my IPv4 address in the local host and then i clicked apply and it applied or saved without showing any error! I hope this piece of information helps resolving the problem!

Link to post
Share on other sites
Posted · Original PosterOP
10 hours ago, ddswh1pk0s said:

Most residential ISPs block port 21 try using a 4 digit port

Ok so what port should i type on it, if i am using or wishing to acces my ftp server?

but on the router page they have the option itself to select FTP on the port forwarding page which automatically puts in 21 value in the local and remote port range.

Link to post
Share on other sites
1 hour ago, ArkTheYO said:

Ok so what port should i type on it, if i am using or wishing to acces my ftp server?

but on the router page they have the option itself to select FTP on the port forwarding page which automatically puts in 21 value in the local and remote port range.

On the router try forwarding an unused 4 digit port. I use 1025 but yours can be different. When you are accessing your server you should type ftp://[external ip address]:1025

Link to post
Share on other sites
Posted · Original PosterOP
22 minutes ago, ddswh1pk0s said:

On the router try forwarding an unused 4 digit port. I use 1025 but yours can be different. When you are accessing your server you should type ftp://[external ip address]:1025

It still isnt working! :(

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×