Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
bryanlkh19

core clocks jumping up and down

Recommended Posts

Posted · Original PosterOP

I have a saphire r9 390x

And my core clocks keep jumping up and down while I play games.

causing it to stutter I think? Fps keeps jumping up and down too. Any advises?

My system specs is 

Amd FX 8350 OC 4.6ghz | Kingston hyper x beast 16gb ddr3 at 2133mhz | msi 970 gaming motherboard | saphire r9 390x tri X | 120gb Kingston V300 ssd boot drive | 500 gb Seagate barracuda | Cooler Master 140xl seidon cpu cooler | NZXT H440

Biginner here desperate for help!!

Link to post
Share on other sites

You can try to disable your OC. And work from there. 


CPU: Intel I7 4790K 4.8 Ghz || Mobo: ASUS ROG Maximus Hero 6 Z87 || Ram: Corsair Vengeance 16 GB 1600 Mhz || GPU: ASUS GTX 980 Ti STRIX || Storage: 2 x SSD Samsung 840 EVO 250 GB RAID 0 HDD Western Digital 1 TB Black || PSU: Corsair AX 860 watt || Cooling: 2 x AF 140mm (front), 2 AF120 Blue LED (bottom and back), 2 SP120 (top on radiator) ||  CPU cooler: Corsair H100i GTX || Case: Corsair obsidian 750D <3 <3 <3 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, jurian123 said:

You can try to disable your OC. And work from there. 

Gpu Oc or cpu Oc?  Or just disable them all and slowly work my way back up?

Link to post
Share on other sites
4 minutes ago, bryanlkh19 said:

Gpu Oc or cpu Oc?  Or just disable them all and slowly work my way back up?

At the start i would only do gpu. Because that core clock is going up and down right?


CPU: Intel I7 4790K 4.8 Ghz || Mobo: ASUS ROG Maximus Hero 6 Z87 || Ram: Corsair Vengeance 16 GB 1600 Mhz || GPU: ASUS GTX 980 Ti STRIX || Storage: 2 x SSD Samsung 840 EVO 250 GB RAID 0 HDD Western Digital 1 TB Black || PSU: Corsair AX 860 watt || Cooling: 2 x AF 140mm (front), 2 AF120 Blue LED (bottom and back), 2 SP120 (top on radiator) ||  CPU cooler: Corsair H100i GTX || Case: Corsair obsidian 750D <3 <3 <3 

Link to post
Share on other sites
Posted · Original PosterOP
2 minutes ago, jurian123 said:

At the start i would only do gpu. Because that core clock is going up and down right?

Yup I'm at 1147 mhz now. Default is at 1050. 

Link to post
Share on other sites
Just now, bryanlkh19 said:

Yup I'm at 1147 mhz now. Default is at 1050. 

Okay let the card run on stock clocks for a while. Play a game. See how it goes. 


CPU: Intel I7 4790K 4.8 Ghz || Mobo: ASUS ROG Maximus Hero 6 Z87 || Ram: Corsair Vengeance 16 GB 1600 Mhz || GPU: ASUS GTX 980 Ti STRIX || Storage: 2 x SSD Samsung 840 EVO 250 GB RAID 0 HDD Western Digital 1 TB Black || PSU: Corsair AX 860 watt || Cooling: 2 x AF 140mm (front), 2 AF120 Blue LED (bottom and back), 2 SP120 (top on radiator) ||  CPU cooler: Corsair H100i GTX || Case: Corsair obsidian 750D <3 <3 <3 

Link to post
Share on other sites
Posted · Original PosterOP
17 minutes ago, jurian123 said:

Okay let the card run on stock clocks for a while. Play a game. See how it goes. 

Could it be the game that is causing the trouble? Cause some game runs fairly stable like the witcher 3. But far cry 4 is still the same dipping down to 600-800mhz and stays there. Barely even keeping the frames above 30 fps at 1440p ultra settings. I've tried dialing the details down and tried it at 1080p with low settings the fps is the same but the clock speed drop to 400-600mhz. I haven't patch my game yet. Still downloading the patch.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×