Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
ankit_k

FIFA 15 100% cpu usage on i3 3220

Recommended Posts

Posted · Original PosterOP

I am getting occasional stutter while FIFA 15 on my PC with Gtx 750ti, i3 3220 and 8gb of ram. On inspecting it further it seems, these stutters occur when the cpu usage crosses 95%. Also the CPU temps are always above 100 degrees C whenever I start the game.

 

Is any there anyway to lower this CPU usage?? or while I have to live with it and CPU upgrade being the only option.

 

I have even tested with lowering the resolution to 720p and turn off MSAA completely but nothing seems to have helped.

 

I have seen this question being asked on lot of forums , but no satisfying answer. 

Please guide.

 

Thanks

Link to post
Share on other sites

Your processor is most likely thermal throttling, what cooler do you have?


CPU: i5 6600k OCed to 4.5Ghz @ 1.35v, GPU: R9 390 Nitro, Motherboard: Asus z170-A, CPU Cooler: H100i GTX, RAM: HyperX 2x8 16gb DDR4, PSU: Seasonic x650, Storage: 850 EVO 500gb, WD 1tb blue, Case: H440 White/Black

Link to post
Share on other sites

FIFA 15 on my PC

go home.

 

in all seriousness, it seems like a processor bottleneck or a thermal throttling issue. If you upgraded to a 3570k or 3770k, your issue would be solved if it's a processor bottleneck. You should consider upgrading your cooler and changing the thermal paste if you're thermal throttling.

You can get both of those processors on the cheap. Also see the 2700k and the 2500k.

Link to post
Share on other sites

go home.

 

in all seriousness, it seems like a processor bottleneck or a thermal throttling issue. If you upgraded to a 3570k or 3770k, your issue would be solved if it's a processor bottleneck. You should consider upgrading your cooler and changing the thermal paste if you're thermal throttling.

You can get both of those processors on the cheap. Also see the 2700k and the 2500k.

Pentium 3xxx series is haswel.
Link to post
Share on other sites

Stock cooler.

 

Afterburner shows ~104 

jfc yeah, you need to get rid of the dust in your computer and re-apply the thermal paste.

 

If the issue continues, consider getting a bigger cooler but you shouldn't need to because temps shouldn't be high at all with the stock cooler.

Link to post
Share on other sites
Posted · Original PosterOP

Your processor is most likely thermal throttling, what cooler do you have?

How do confirm I that it is thermal throttling?

 

 

jfc yeah, you need to get rid of the dust in your computer and re-apply the thermal paste.

 

If the issue continues, consider getting a bigger cooler but you shouldn't need to because temps shouldn't be high at all with the stock cooler.

Will try it and post an update here. Any optimal temp range that I should look for?

Link to post
Share on other sites

Will try it and post an update here. Any optimal temp range that I should look for?

For a stock cooler and your processor, 65c max. With the more hungry i5 and i7s, you're looking at 75c max

Link to post
Share on other sites

How do confirm I that it is thermal throttling?

 

 

Will try it and post an update here. Any optimal temp range that I should look for?

Open XTU, it has a tab at the bottom for thermal throttling.

5ezqfYJ.png


My current build - Ever Changing.

Number 1 On LTT LGA 1150 CPU Cinebench R15

http://hwbot.org/users/TheGamingBarrel

Link to post
Share on other sites
Posted · Original PosterOP

Got it fixed thanks everyone in this thread. Was a thermal throttling issue

 

- Removed and cleaned CPU heatsink and fan. Applied new thermal paste.

- The rear fan on the case was pulling air in. Turned it around the other way.

- The cpu fan was originally connected to the sys fan header. Changed it to cpu fan header. Not sure though if it did any difference.

 

The idle temps are now around 35 deg C and in game peak temps are around 56 with CPU usage maxing out to 80% in previous cases where it was 100 and the game used to lag.

 

Again thanks everyone here for helping me out!

Link to post
Share on other sites

Got it fixed thanks everyone in this thread. Was a thermal throttling issue

 

- Removed and cleaned CPU heatsink and fan. Applied new thermal paste.

- The rear fan on the case was pulling air in. Turned it around the other way.

- The cpu fan was originally connected to the sys fan header. Changed it to cpu fan header. Not sure though if it did any difference.

 

The idle temps are now around 35 deg C and in game peak temps are around 56 with CPU usage maxing out to 80% in previous cases where it was 100 and the game used to lag.

 

Again thanks everyone here for helping me out!

Nice to see another fifa player on PC :)


I7 4790K-----ASUS Z97-A-----GTX 1080-----CORSAIR H105-----CORSAIR VENGEANCE PRO 16GB-----ASUS PG278Q-----LOGITECH G900-----MASTERKEYS PRO L-----Sennheiser GSX 1000

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×