Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
JJJaaammmeeesss

TP-Link Archer C2 Router Subnet Issues

What port on the TP-Link router you've connected the 8 port switch to? You should just use its LAN port to avoid double NATting.

 

To configure it as an AP/switch only, set its LAN IP to 192.168.0.50(or other number), subnet mask to 255.255.255.0 (assuming it's the same as your modem/router). set its WAN IP to a different IP as 192.168.0.0/24, and disable its DHCP service. You can then just use its LAN ports for other wired devices and don't connect anything on its WAN port.

 

Those settings assume you don't require the TP-Link to use a different network.

Recommended Posts

Posted · Original PosterOP

I have a TP-Link archer c2 wifi router behind an 8-Port auto configuring network switch. All devices on the 2 network switches and the modem/router are on the 192.168.0.1 subnet but the TP-Link router can only be on a subnet that is different so in this case 192.168.1.1. From my Desktop connected to the 8 Port switch I can ping the routers static IP on my main network as it has a static IP, but when I ping anything on the routers subnet e.g 192.168.1.2 some of the packets time out and the rest are >100ms. The only possible setting I could see that affects this is the routers NAT feature but enabling or disabling it hasn't helped. I tried to run tracert in CMD on my desktop to trace a device on the router but it timed out, devices on the router cannot detect network devices that aren't on the router and vice versa. Has anyone had this issue or does anyone know a solution to this issue?

 

Diagram  :)

post-259776-0-59071100-1451734357_thumb.


01000100 01100001 01110010 01110101 01100100 01100101 00100000 00101101 00100000 01010011 01100001 01101110 01100100 01110011 01110100 01101111 01110010 01101101

Link to post
Share on other sites
Posted · Best Answer

What port on the TP-Link router you've connected the 8 port switch to? You should just use its LAN port to avoid double NATting.

 

To configure it as an AP/switch only, set its LAN IP to 192.168.0.50(or other number), subnet mask to 255.255.255.0 (assuming it's the same as your modem/router). set its WAN IP to a different IP as 192.168.0.0/24, and disable its DHCP service. You can then just use its LAN ports for other wired devices and don't connect anything on its WAN port.

 

Those settings assume you don't require the TP-Link to use a different network.

Link to post
Share on other sites
Posted · Original PosterOP

Alright I'll try this out. Thanks


01000100 01100001 01110010 01110101 01100100 01100101 00100000 00101101 00100000 01010011 01100001 01101110 01100100 01110011 01110100 01101111 01110010 01101101

Link to post
Share on other sites
Posted · Original PosterOP

What port on the TP-Link router you've connected the 8 port switch to? You should just use its LAN port to avoid double NATting.

 

To configure it as an AP/switch only, set its LAN IP to 192.168.0.50(or other number), subnet mask to 255.255.255.0 (assuming it's the same as your modem/router). set its WAN IP to a different IP as 192.168.0.0/24, and disable its DHCP service. You can then just use its LAN ports for other wired devices and don't connect anything on its WAN port.

 

Those settings assume you don't require the TP-Link to use a different network.

Thanks ill try it out


01000100 01100001 01110010 01110101 01100100 01100101 00100000 00101101 00100000 01010011 01100001 01101110 01100100 01110011 01110100 01101111 01110010 01101101

Link to post
Share on other sites
Posted · Original PosterOP

What port on the TP-Link router you've connected the 8 port switch to? You should just use its LAN port to avoid double NATting.

 

To configure it as an AP/switch only, set its LAN IP to 192.168.0.50(or other number), subnet mask to 255.255.255.0 (assuming it's the same as your modem/router). set its WAN IP to a different IP as 192.168.0.0/24, and disable its DHCP service. You can then just use its LAN ports for other wired devices and don't connect anything on its WAN port.

 

Those settings assume you don't require the TP-Link to use a different network.

Thanks heaps this worked perfectly. Appreciate the help


01000100 01100001 01110010 01110101 01100100 01100101 00100000 00101101 00100000 01010011 01100001 01101110 01100100 01110011 01110100 01101111 01110010 01101101

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×