Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
zxkev

Problem after assemble my part

Recommended Posts

Posted · Original PosterOP

after i assemble my parts, my motherboard blinked once when i turn the power on and that's it, nothing happen.

i checked my psu by use paper clip and the fan move, so  i don't know what to do, because i don't know what part of my pc is not working.

Link to post
Share on other sites

Make sure everything is pushed in correctly. Don't be afraid to use a little force, most parts can take it!  (Except the CPU. Do not RAM that in)

(•_•) / ( •_•)>⌐■-■ / (⌐■_■) YYEEAAHH!


Build: i5-4460 | GT 720 | Logitech G710+ Keyboard | Corsair M65 Mouse | Dell e2314h Monitor | Windows 10

Generic Dell: Mobo, 8gb RAM, 430w PSU, 1TB Storage, XPS 8700 Case

Link to post
Share on other sites

Check everything is plugged in, try without the GPU, try with different combinations of RAM, if you have a spare PSU, try with that. If you've still not fixed it or identified the problem component then try your parts in a friends PC if you can.


i7-7700 | Asrock H270M-ITX | Fractal Design Core 500 | 16GB Corsair Vengeance LPX | EVGA GTX 1080 Ti | 850 EVO 500GB | 850 EVO 250GB | WD CavGreen 2TB

EVGA SuperNOVA 550W | Steel Series Elite Prism | Final mouse 2015 | WASD Keyboards V2 (MX Blue) | Acer Predator 1440p 144Hz

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Newegg

×