Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Youssef Medhat

Need help - laptop problem

Recommended Posts

Posted · Original PosterOP

so i have a toshiba l505 - es5018 a week ago after restarting the laptop my screen went black (the back light is on) and the laptop boots up but i get no image - i connected it to an external monitor and it's working fine but when i switch back to laptop monitor is just black. (Laptop monitor and connector are fine took them off and tested them) so i tried uninstalling display drivers and re-installing them and it worked the monitor worked but once i restart the laptop or shut it down - the black screen problems comes back after that every time i have to un-install and re-install the drivers for the monitor to work and sometimes i have to uninstall and reinstall like 5 times till it work :( where is the problem is it the graphics card ? (it's built-in intel graphics)

Edit: i thought it might be a virus so i installed kaspersky and scanned but there were nothing / installed a new fresh copy of windows 7 still nothing.

Link to post
Share on other sites

If it has a dedicated GPU, then it could be dying and giving you these issues. But sounds like its just using intels iGPU. So maybe there could be other hardware issues if all the drivers are fine. You might need to take it into a shop to be properly checked and tested.


My Rigs:

Gaming/CAD/Rendering Rig
Case:
 Corsair Air 240 , CPU: i7-4790K, Mobo: ASUS Gryphon Z97 mATX,  GPU: Gigabyte G1 Gaming GTX 970, RAM: G.Skill Sniper 16GB, SSD: SAMSUNG 1TB 840 EVO, Cooling: Corsair H80i PCPP: https://au.pcpartpicker.com/b/f2TH99SFF HTPC
Case:
Silverstone ML06B, CPU: Pentium G3258, Mobo: Gigabyte GA-H97N-WiFi, RAM: G.Skill 4GB, SSD: Kingston SSDNow 120GB PCPP: https://au.pcpartpicker.com/b/JmZ8TW
Link to post
Share on other sites
Posted · Original PosterOP

If it has a dedicated GPU, then it could be dying and giving you these issues. But sounds like its just using intels iGPU. So maybe there could be other hardware issues if all the drivers are fine. You might need to take it into a shop to be properly checked and tested.

i did they were like we think it's the monitor "which it's not i tried it on another laptop"  and it's probably the intel graphics card" $_$" and they were like it will be 250$ for monitor and 250$ for fixing the intel graphics card so i just left and came here for help :D

Link to post
Share on other sites

i did they were like we think it's the monitor "which it's not i tried it on another laptop"  and it's probably the intel graphics card" $_$" and they were like it will be 250$ for monitor and 250$ for fixing the intel graphics card so i just left and came here for help :D

 

Damn yeah tech IT shops overcharge so much...

 

Not sure what else to suggest man. Might be a long shot but maybe a fresh re-install of windows can sometimes fix random issues.


My Rigs:

Gaming/CAD/Rendering Rig
Case:
 Corsair Air 240 , CPU: i7-4790K, Mobo: ASUS Gryphon Z97 mATX,  GPU: Gigabyte G1 Gaming GTX 970, RAM: G.Skill Sniper 16GB, SSD: SAMSUNG 1TB 840 EVO, Cooling: Corsair H80i PCPP: https://au.pcpartpicker.com/b/f2TH99SFF HTPC
Case:
Silverstone ML06B, CPU: Pentium G3258, Mobo: Gigabyte GA-H97N-WiFi, RAM: G.Skill 4GB, SSD: Kingston SSDNow 120GB PCPP: https://au.pcpartpicker.com/b/JmZ8TW
Link to post
Share on other sites
Posted · Original PosterOP

Damn yeah tech IT shops overcharge so much...

 

Not sure what else to suggest man. Might be a long shot but maybe a fresh re-install of windows can sometimes fix random issues.

did that today nothing still :( 

Link to post
Share on other sites

did that today nothing still :(

 

Damn..

 

How old is the laptop?


My Rigs:

Gaming/CAD/Rendering Rig
Case:
 Corsair Air 240 , CPU: i7-4790K, Mobo: ASUS Gryphon Z97 mATX,  GPU: Gigabyte G1 Gaming GTX 970, RAM: G.Skill Sniper 16GB, SSD: SAMSUNG 1TB 840 EVO, Cooling: Corsair H80i PCPP: https://au.pcpartpicker.com/b/f2TH99SFF HTPC
Case:
Silverstone ML06B, CPU: Pentium G3258, Mobo: Gigabyte GA-H97N-WiFi, RAM: G.Skill 4GB, SSD: Kingston SSDNow 120GB PCPP: https://au.pcpartpicker.com/b/JmZ8TW
Link to post
Share on other sites

5 years :D

 

ah okay, might be some random hardware issue then man. You could try paying taking it to a tech shop but tbh its probably just at the end of its life and would be cheaper to just buy a new laptop than repair this one.


My Rigs:

Gaming/CAD/Rendering Rig
Case:
 Corsair Air 240 , CPU: i7-4790K, Mobo: ASUS Gryphon Z97 mATX,  GPU: Gigabyte G1 Gaming GTX 970, RAM: G.Skill Sniper 16GB, SSD: SAMSUNG 1TB 840 EVO, Cooling: Corsair H80i PCPP: https://au.pcpartpicker.com/b/f2TH99SFF HTPC
Case:
Silverstone ML06B, CPU: Pentium G3258, Mobo: Gigabyte GA-H97N-WiFi, RAM: G.Skill 4GB, SSD: Kingston SSDNow 120GB PCPP: https://au.pcpartpicker.com/b/JmZ8TW
Link to post
Share on other sites
Posted · Original PosterOP

ah okay, might be some random hardware issue then man. You could try paying taking it to a tech shop but tbh its probably just at the end of its life and would be cheaper to just buy a new laptop than repair this one.

i know i would just get a new laptop if i had the 500$ they asked for tbh xD well thanks anyway will see what i can do about it 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×