Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Peejay

i5 4690K Dynamic overclock

Recommended Posts

Posted · Original PosterOP

Hi!

 

I've been looking in to dynamic overclocking for a while now. I've been reading a lot of forums, but I can't seem to find a conclusive guide on how to get started and set up such an overclock. 

At the moment, i'm running my i5 4690K at a 4.3Ghz core clock. I've been thinking about a dynamic overclock, because I don't want it to be running at this speed all the time. 

 

I just want to CPU to run at about ~3.8 Ghz stock, and speed up to ~4.5 Ghz while gaming or during intensive tasks. 

 

Like I said, I can't find a conclusive guide on how to do this, so i'm kind of stuck here. 

 

 

Is there anyone who can link me a clear guide, or help me understand how I can do this? 

 

 

Thanks a lot in advance!


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

well, you can turn on intel speedstep technology in the bios, which basically underclocks the cpu if you don't need the horsepower.

Link to post
Share on other sites
Posted · Original PosterOP

well, you can turn on intel speedstep technology in the bios, which basically underclocks the cpu if you don't need the horsepower.

 

Yea, I already did that. The thing is, my core clock will always remain at 4.3Ghz. It doesn't drop down, even at idle..


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

Yea, I already did that. The thing is, my core clock will always remain at 4.3Ghz. It doesn't drop down, even at idle..

Did you set the CPU ratio on fixed? Because if you enabled speedstep with a fixed ratio, it won't doing anything lol. Put it on dynamic instead.

Link to post
Share on other sites
Posted · Original PosterOP

Did you set the CPU ratio on fixed? Because if you enabled speedstep with a fixed ratio, it won't doing anything lol. Put it on dynamic instead.

 

I'll look into that. So with that dynamic setting, I can set a idle speed and a max speed? 

Another quesion: Do I need to disable turbo boost while doing this?


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

I'll look into that. So with that dynamic setting, I can set a idle speed and a max speed? 

Another quesion: Do I need to disable turbo boost while doing this?

What you also can do is the following:

 

Leave the CPU clock ratio on stock, enable intel's turbo boost and set a custom boost clock speed for every core. That way, you can set the boost to whatever you like (4,3 for example) and run the clock speeds when you're not doing intensive gaming of multitasking.

Link to post
Share on other sites

If you enable turbo boost and speed step while oc'd it will treat your cpu like normal, you'll down clock at idle, and turbo to 4.3 on all cores when those cores are under heavy load


My rig:
CPU: i5 4690k 24/7 @4.4ghz (1.165v) Max 4.7ghz (1.325v) COOLER: NZXT Kraken X61 MOBO: Asus Z97-A   RAM: 16GB Crucial Ballistix Tactical   GPU: EVGA GTX 970 SSC   PSU: EVGA GS 650W   CASE: NZXT Phantom 530 HDD: WD Caviar Blue 1TB + WD Black 2TB

Link to post
Share on other sites

Even with speedstep enabled your CPU won't downclock if your windows profile isn't balanced/powersaver. Change to balanced power management and check again :)

 

P.S. You also need to set adaptive voltage instead of manual.


CPU: Intel® Core™ i5-4690K 4.7GHz 1.28V | GPU: Gigabite GTX 970 G1 Gaming 1529/1873 | Motherboard: Asus Z97-P | RAM: Crucial Ballistix Sport 16GB (4 x 4GB) DDR3-1600 | Case: Cooler Master N500 | Storage: 128GB PNY Optima SSD | PSU: EVGA 500W 80+ | Displays: ACER 23'' 1080p G237HLbi + 2x HP L2035 | Cooling: CM Nepton 240M on CPU + 2 Cooler Master case fans | Keyboard: Logitech K360 | Mouse: Trust GXT 152 | Buildlog

Link to post
Share on other sites
Posted · Original PosterOP

Even with speedstep enabled your CPU won't downclock if your windows profile isn't balanced/powersaver. Change to balanced power management and check again :)

P.S. You also need to set adaptive voltage instead of manual.

Ahhh okay, that could be the issue.. I'm running my pc at full performance, always. I also have all the c states enabled, so it's odd that it doesn't drop. Does adaptive voltage deliver too much power? I recall that I read a out that,but I can be wrong.. Is offset a better option?


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

Ahhh okay, that could be the issue.. I'm running my pc at full performance, always. I also have all the c states enabled, so it's odd that it doesn't drop. Does adaptive voltage deliver too much power? I recall that I read a out that,but I can be wrong.. Is offset a better option?

Adaptive mode is great. I run it on my 24/7 oc. Also check your power plan in Windows to make sure the cpu isn't set to 100% performance for the minimum


My rig:
CPU: i5 4690k 24/7 @4.4ghz (1.165v) Max 4.7ghz (1.325v) COOLER: NZXT Kraken X61 MOBO: Asus Z97-A   RAM: 16GB Crucial Ballistix Tactical   GPU: EVGA GTX 970 SSC   PSU: EVGA GS 650W   CASE: NZXT Phantom 530 HDD: WD Caviar Blue 1TB + WD Black 2TB

Link to post
Share on other sites

Hi!

 

I've been looking in to dynamic overclocking for a while now. I've been reading a lot of forums, but I can't seem to find a conclusive guide on how to get started and set up such an overclock. 

At the moment, i'm running my i5 4690K at a 4.3Ghz core clock. I've been thinking about a dynamic overclock, because I don't want it to be running at this speed all the time. 

 

I just want to CPU to run at about ~3.8 Ghz stock, and speed up to ~4.5 Ghz while gaming or during intensive tasks. 

 

Like I said, I can't find a conclusive guide on how to do this, so i'm kind of stuck here. 

 

 

Is there anyone who can link me a clear guide, or help me understand how I can do this? 

 

 

Thanks a lot in advance!

 

check out my cpu overclocking guide; link in my forum signature


BigDay

Link to post
Share on other sites
Posted · Original PosterOP

Adaptive mode is great. I run it on my 24/7 oc. Also check your power plan in Windows to make sure the cpu isn't set to 100% performance for the minimum

Yea i have to check that first, could fix a lot.. I'll keep you guys updated on the progress


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites
Posted · Original PosterOP

Adaptive mode is great. I run it on my 24/7 oc. Also check your power plan in Windows to make sure the cpu isn't set to 100% performance for the minimum

Yea i have to check that first, could fix a lot.. I'll keep you guys updated on the progress


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites
Posted · Original PosterOP

Even with speedstep enabled your CPU won't downclock if your windows profile isn't balanced/powersaver. Change to balanced power management and check again :)

 

P.S. You also need to set adaptive voltage instead of manual.

 

Okay, so the balanced mode works like a charm! The thing is, I can't seem to find any options to set my voltage to adaptive in my bios..


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites
Posted · Original PosterOP

Got my cpu running at 4.5Ghz stable with an average temp of 75C and peaks of 85C max. I'm running a small fft in prime95


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

@Peejay

This thread will probably tell you what you need to know. 

If you run into instability at lower speeds, use this thread to troubleshoot. If that doesn't fix the problem, post back here. 

 

Also, don't run a stress test on anything other than manual voltage. The CPU will pull way more voltage than you tell it to if you use any other mode. Additionally, last I heard the general consensus was that prime95 doesn't fully validate haswell overclocks (something about the instruction set), try AIDA64 instead. 


Isopropyl alcohol is all you need for cleaning CPU's and motherboard components.  No, you don't need [insert cleaning solution here].  -Source: PhD Student, Chemistry


Why overclockers should understand Load-Line Calibration.


ASUS Rampage IV Black Edition || i7 3930k @ 4.5 GHz || 32 GB Corsair Vengeance CL8 || ASUS GTX 780 DCuII || ASUS Xonar Essence STX || XFX PRO 1000W

Link to post
Share on other sites
Posted · Original PosterOP

@Peejay

This thread will probably tell you what you need to know. 

If you run into instability at lower speeds, use this thread to troubleshoot. If that doesn't fix the problem, post back here. 

 

Also, don't run a stress test on anything other than manual voltage. The CPU will pull way more voltage than you tell it to if you use any other mode. Additionally, last I heard the general consensus was that prime95 doesn't fully validate haswell overclocks (something about the instruction set), try AIDA64 instead. 

 

Thanks for your response, i'm running manual voltages (can't find adaptive anywhere in my bios). I will give AIDA a go.


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

Thanks for your response, i'm running manual voltages (can't find adaptive anywhere in my bios). I will give AIDA a go.

That's interesting. I thought it was a standard Z97 feature. 

So where it says "CPU Core Voltage" there is no adaptive option?


Isopropyl alcohol is all you need for cleaning CPU's and motherboard components.  No, you don't need [insert cleaning solution here].  -Source: PhD Student, Chemistry


Why overclockers should understand Load-Line Calibration.


ASUS Rampage IV Black Edition || i7 3930k @ 4.5 GHz || 32 GB Corsair Vengeance CL8 || ASUS GTX 780 DCuII || ASUS Xonar Essence STX || XFX PRO 1000W

Link to post
Share on other sites
Posted · Original PosterOP

That's interesting. I thought it was a standard Z97 feature. 

So where it says "CPU Core Voltage" there is no adaptive option?

 

No, I can only put in a voltage number. Beneath that is an offset voltage option, but it is greyed out. Weird.. Still looking into it :)


CPU: I5 4690K@4.3GHz - Motherboard: Gigabyte Z97 Gaming 5 - GPU: Gigabyte G1 GTX 960 4GBRAM: 16GB HyperX Fury@1600MhzPSU: Cooler Master G750M (750W)Case: Corsair Carbide Spec-01SSD: Kingston HyperX 120GBHard drive: 500GB Western Digital

Link to post
Share on other sites

Intels overclocking software (forgot the name) has the ability to set your voltage to adaptive. I made the mistake of trying to change it while the CPU was stress testing, caused an error. Haven't tried it since.


If anyone asks you never saw me.

Link to post
Share on other sites

No, I can only put in a voltage number. Beneath that is an offset voltage option, but it is greyed out. Weird.. Still looking into it :)

 

It may not be called "Adaptive," it's probably an option to set the voltage to "Auto." Just be aware that Auto voltage settings often push higher voltage through the CPU than is actually needed, resulting in higher temperatures. There have even been some known issues with Haswell CPUs with voltage on Auto being overvolted and damaged when running certain versions of Prime95. It may be better to find the lowest stable fixed voltage and stick with that.

 

What you also can do is the following:

 

Leave the CPU clock ratio on stock, enable intel's turbo boost and set a custom boost clock speed for every core. That way, you can set the boost to whatever you like (4,3 for example) and run the clock speeds when you're not doing intensive gaming of multitasking.

 

Can this affect the overclock's stability? Is it possible that the given overclock might be stable when set via the clock ratio, but unstable when applied the way you described?

 

I might give this a shot on my 4.5 GHz 6600K. Sounds useful.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×