Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
SilentHopes

7970 refuses to run properly with drivers installed...

Recommended Posts

Posted · Original PosterOP

Back in January, I was playing a game of Civ V, and when I went to exit to desktop, my screen locked up. It went black, it started flashing, and there were artifacts all over the place. Then my computer bluescreened. It said the cause of the bluescreen was due to two files in my drivers, atikmpag.sys and atikmdag.sys. The problem would go away if I uninstalled the graphics drivers but would return if I reinstalled them. 

Since then, I have upgraded to Windows 8 and I no longer bluescreen with drivers installed. However, when I try to boot into Windows, it becomes extremely laggy and all I get is a black screen. If I'm lucky I might be able to click on something and a window might open up. The problem is that the drivers are crashing, or that's what Windows is telling me. I've tried to fix this problem on many occasions, and I've yet to find a fix that worked. I did a fresh install of Windows four times when I was using Windows 7, and that did me no good. From what I've read, this problem has happened to many people with different graphics cards and drivers. There is no solution that fixes it for everyone. One thing may fix it for someone, but not for another. 

I know the card isn't dead because the fans still spin and everything, and it will do everything as it's supposed to without drivers installed. Once drivers are installed, it stops working normally. One thing I've noticed is that when drivers are installed, there's a very quiet zapping noise about every five seconds. I'm not sure what it is, but I'm hoping it didn't kill anything. I don't think it did because it still appears to be working just fine. 

CPU: i5-3570K
Motherboard: ASRock Z77 Extreme4
RAM: Corsair Vengeance 8GB & G.Skill Ares 8GB
Graphics Card: Sapphire Radeon HD 7970 (This one
PSU: OCZ MXSP 700W

The components shouldn't matter, I've tried putting it in a different machine and I got the same problem.

Anyone have an idea of what I should do? 

Link to post
Share on other sites

If you can try integrated graphics or another graphics card to rule that out.  Sounds to me either a GPU or PSU problem but it could be a mobo issue as well.


Specs: Core I7-2600K @ 4.5GHz @ 1.35V, 4x4GB Corsair Vengeance Black 1600MHz CL9, Cooler Master Evo 212, MSI Z77 Mpower Motherboard, Sapphire Radeon HD 7950 Vapor-X @ 1000/1400, Cooler Master HAF 932 Blue Edition w/ 3 Cougar Hydraulic Bearing 120MM fans (2 up top 1 in the bottom) replaced side panel with a window, and rear fan with a Cougar Hydraulic Bearing 140MM, Cooler Master GX 650 80+ Bronze PSU, Samsung DVD-RW, Samsung 840 Pro 128GB SSD, Seagate 750GB SATA III 7200RPM

 

Link to post
Share on other sites

The other machine use Window 8 as well?


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×