Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
terrahertz

Cant connect to my Teamspeak 3 server using wan ip...

Recommended Posts

Posted · Original PosterOP

Okay, so.

 

First of all, you installed the server normally and all that stuff.

Then you port forwarded it? Both as port 9987 and the protocol as both? And the IP adress of 192.168.1.105?

Then you tried to connect with Localhost and you could connect, but when connecting with the IP it did not connect? Also, ports show as closed. 

Everyone trying to connect is on the same network but Wireless? Or by Ethernet? Or both? Or are they in a different location?

 

If you have not done some of these, try doing it.

 

I think it is a port problem (80% sure), so try to re-install the server on a different port and then port forward on that new port.

I did all of that.. I manage to connect from my main computer with 192.168.1.105 which acts as localhost on server pc... My friend are connecting from different locations.


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites
Posted · Original PosterOP

I think the 0.0.0.0 IP address means it is applying for every IP, I guess he could change it to 192.168.1.1 maybe? Or is it looking for 192.168.1.105?

I checked 0.0.0.0 is an alias to "every IP in system" according to the teamspeak forums


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

I did all of that.. I manage to connect from my main computer with 192.168.1.105 which acts as localhost on server pc... My friend are connecting from different locations.

The only other thing I would suggest is checking firewall for blocking. Maybe a new anti-virus install or update could of caused it compared to last time?


CPU: i5 4670k @ 3.4GHz + Corsair H100i      GPU: Gigabyte GTX 680 SOC (+215 Core|+162 Mem)     SSD: Kingston V300 240GB (OS)      Headset: Logitech G930 

Case: Cosair Vengance C70 (white)                RAM: 16GB TeamGroup Elite Black DDR3 1600MHz       HDD: 1TB WD Blue                              Mouse: Logitech G602

OS: Windows 7 Home Premium                       PSUXFX Core Edition 750w                                                Motherboard: MSI Z97-G45               Keyboard: Logitech G510

Link to post
Share on other sites
Posted · Original PosterOP

The only other thing I would suggest is checking firewall for blocking. Maybe a new anti-virus install or update could of caused it compared to last time?

Ill check firewall again because i formated server a few times since then... Thx for your help


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

Ill check firewall again because i formated server a few times since then... Thx for your help

It's alright, come back if you have more problems and we can dig deeper.  :)


CPU: i5 4670k @ 3.4GHz + Corsair H100i      GPU: Gigabyte GTX 680 SOC (+215 Core|+162 Mem)     SSD: Kingston V300 240GB (OS)      Headset: Logitech G930 

Case: Cosair Vengance C70 (white)                RAM: 16GB TeamGroup Elite Black DDR3 1600MHz       HDD: 1TB WD Blue                              Mouse: Logitech G602

OS: Windows 7 Home Premium                       PSUXFX Core Edition 750w                                                Motherboard: MSI Z97-G45               Keyboard: Logitech G510

Link to post
Share on other sites

The 0.0.0.0 is definitely fine. This is ts3server.ini from one of my TS3 servers:

machine_id=default_voice_port=9987voice_ip=0.0.0.0liscensepath=filetransfer_port=30033filetransfer_ip=0.0.0.0query_port=10011query_ip=0.0.0.0dbplugin=ts3db_mysqldbpluginparameter=ts3db_mysql.inidbsqlpath=sql/dbsqlcreatepath=create_mysql/logpath=logslogquerycommands=0

and it works fine.

 

The question I have for you is whether or not you can connect to the query port externally? Pop open your favourite telnet client such as PuTTy (or use the CLI), put your WAN IP in the connect to box, 10011 in the port, and select telnet as the protocol (CLI: telnet wan-IP 10011).

 

It should give you something like this:

root@omn:/etc/apache2/sites-enabled# telnet avz.<redacted> 10011Trying <redacted>...Connected to avz.<redacted>.Escape character is '^]'.TS3Welcome to the TeamSpeak 3 ServerQuery interface, type "help" for a list of commands and "help <command>" for information on a specific command.

If it works type 'quit' and hit enter or close the window.

 

I'd also be curious how TS3 handles being on a non-standard port in case your ISP is blocking it. In your ts3server.ini change default_voice_port to something like 10123 and forward that port in your router. Then in your TS3 client use 10123 as the server port.

 

As a side note, although it doesn't matter... In your router you have "both" selected as the protocol for your forwards and you can be more specific: TS3 voice (9987) is UDP, and the query and file transfer ports are TCP. This is from a Linux firewall (iptables) but these are the rules I use:

# Allow TS3## Primary TS3 (500 client)-A INPUT -i eth0 -p udp --dport 9987 -j ACCEPT## Test instance (12 client)-A INPUT -i eth0 -p udp --dport 9989 -j ACCEPT## Query and File Transfer-A INPUT -i eth0 -p tcp --dport 10011 -j ACCEPT-A INPUT -i eth0 -p tcp --dport 30033 -j ACCEPT

You can see I specify UDP and TCP. It won't actually make a difference in your case but it's best to only open the things you need.

Link to post
Share on other sites

0.0.0.0 Should be fine. My server says the same


My beast (PC):

  • ASUS R.O.G. Rampage IV Black Edition, X79, LGA2011, AC4
  • 2x ASUS Fury X
  • Intel Core i7 4930K BOX (LGA 2011, 3.40GHz) OC @4.4GHz
  • Corsair H100i, CPU Cooler (240mm)
  • Samsung SSD 830 Series (512GB)
  • Samsung SSD 850 Pro 1TB
  • Western Digital 512GB HDD
  • TridentX 4x 8GB 2400MHz
  • Corsair Obsidian 900D

Link to post
Share on other sites
Posted · Original PosterOP

The 0.0.0.0 is definitely fine. This is ts3server.ini from one of my TS3 servers:

machine_id=default_voice_port=9987voice_ip=0.0.0.0liscensepath=filetransfer_port=30033filetransfer_ip=0.0.0.0query_port=10011query_ip=0.0.0.0dbplugin=ts3db_mysqldbpluginparameter=ts3db_mysql.inidbsqlpath=sql/dbsqlcreatepath=create_mysql/logpath=logslogquerycommands=0

and it works fine.

 

The question I have for you is whether or not you can connect to the query port externally? Pop open your favourite telnet client such as PuTTy (or use the CLI), put your WAN IP in the connect to box, 10011 in the port, and select telnet as the protocol (CLI: telnet wan-IP 10011).

 

It should give you something like this:

root@omn:/etc/apache2/sites-enabled# telnet avz.<redacted> 10011Trying <redacted>...Connected to avz.<redacted>.Escape character is '^]'.TS3Welcome to the TeamSpeak 3 ServerQuery interface, type "help" for a list of commands and "help <command>" for information on a specific command.

If it works type 'quit' and hit enter or close the window.

 

I'd also be curious how TS3 handles being on a non-standard port in case your ISP is blocking it. In your ts3server.ini change default_voice_port to something like 10123 and forward that port in your router. Then in your TS3 client use 10123 as the server port.

 

As a side note, although it doesn't matter... In your router you have "both" selected as the protocol for your forwards and you can be more specific: TS3 voice (9987) is UDP, and the query and file transfer ports are TCP. This is from a Linux firewall (iptables) but these are the rules I use:

# Allow TS3## Primary TS3 (500 client)-A INPUT -i eth0 -p udp --dport 9987 -j ACCEPT## Test instance (12 client)-A INPUT -i eth0 -p udp --dport 9989 -j ACCEPT## Query and File Transfer-A INPUT -i eth0 -p tcp --dport 10011 -j ACCEPT-A INPUT -i eth0 -p tcp --dport 30033 -j ACCEPT

You can see I specify UDP and TCP. It won't actually make a difference in your case but it's best to only open the things you need.

I actually just tried to change the port from 9987 to 27020 with putty. it worked because in the log it says that it is searching on 0.0.0.0:27020. I also forwarded that port and ive tried to specify 27020 to udp and 10011 and 30033 to tcp but still nothing.


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

I actually just tried to change the port from 9987 to 27020 with putty. it worked because in the log it says that it is searching on 0.0.0.0:27020. I also forwarded that port and ive tried to specify 27020 to udp and 10011 and 30033 to tcp but still nothing.

 

Just out of curiosity have you had a friend try and connect to TS3 using your WAN IP remotely? It's unlikely but your router could be doing something weird when it realises it's your WAN IP. Alternatively you could use a mobile TS3 client on a smart phone over LTE (disconnect from WiFi) to test.

 

Another question is whether or not another computer on your network can connect using 192.168.1.105 instead of just using localhost from the server itself. 

A few things to try as well:

 

  • Disable the Windows Firewall.
    • Start
    • open Windows Firewall with Advanced Security
    • Right-click Windows Firewall with Advanced Security on the left and select Properties
    • Private Profile -> Firewall State: Off
    • Public Profile -> Firewall State: Off
  • If you have anti-virus that includes network monitoring or "internet security" such as Norton Internet Security, turn it off. 

    UDP traffic is often filtered and blocked by security software unless it's common UDP traffic like NTP or DNS.

    • Find the icon on your task bar by the clock and right-click it. 
    • There will generally be a disable option.
Link to post
Share on other sites
Posted · Original PosterOP

 

Just out of curiosity have you had a friend try and connect to TS3 using your WAN IP remotely? It's unlikely but your router could be doing something weird when it realises it's your WAN IP. Alternatively you could use a mobile TS3 client on a smart phone over LTE (disconnect from WiFi) to test.

 

Another question is whether or not another computer on your network can connect using 192.168.1.105 instead of just using localhost from the server itself. 

A few things to try as well:

 

  • Disable the Windows Firewall.
    • Start
    • open Windows Firewall with Advanced Security
    • Right-click Windows Firewall with Advanced Security on the left and select Properties
    • Private Profile -> Firewall State: Off
    • Public Profile -> Firewall State: Off
  • If you have anti-virus that includes network monitoring or "internet security" such as Norton Internet Security, turn it off. 

    UDP traffic is often filtered and blocked by security software unless it's common UDP traffic like NTP or DNS.

    • Find the icon on your task bar by the clock and right-click it. 
    • There will generally be a disable option.

 

Yes a few friends of mine have tried to connect but the same error pops up.

Yes i managed to acces the server from my main pc using 192.168.1.105.

I have tried disabling the firewall on windows and on my router...still notzhing and i do not use any anti virus.


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

That's odd, I've connected to systems on my LAN network via my public IP plenty of times without problem.

Some routers support loopback and some don't.

Link to post
Share on other sites

Yes a few friends of mine have tried to connect but the same error pops up.

Yes i managed to acces the server from my main pc using 192.168.1.105.

I have tried disabling the firewall on windows and on my router...still notzhing and i do not use any anti virus.

 

One other thing I can think of: is your modem also a router? For example I have a Linksys Docsis modem/router combo my ISP gave me and I have a Netgear wireless router plugged into that. When I set up any kind of forwarding I have to forward to the Netgear in the modem/router combo and then forward to the actual computer in the Netgear router... but then again you said you're running a Minecraft server and that all forwarded correctly eh?

 

I host both of my TeamSpeak servers on virtual private servers so the configuration and setup is a little different... but if you're not in a huge hurry when I get home tonight I can fire up a TS3 server on one of my computers at home and see if there's any weird configuration necessary to get it working. 

Link to post
Share on other sites
Posted · Original PosterOP

if anyone is intersted hete is my ini file

machine_id=default_voice_port=9987voice_ip=0.0.0.0licensepath=filetransfer_port=30033filetransfer_ip=0.0.0.0query_port=10011query_ip=0.0.0.0query_ip_whitelist=query_ip_whitelist.txtquery_ip_blacklist=query_ip_blacklist.txtdbplugin=ts3db_sqlite3dbpluginparameter=dbsqlpath=sql/dbsqlcreatepath=create_sqlite/dbconnections=10logpath=logslogquerycommands=0dbclientkeepdays=30logappend=0query_skipbruteforcecheck=0

CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites
Posted · Original PosterOP

One other thing I can think of: is your modem also a router? For example I have a Linksys Docsis modem/router combo my ISP gave me and I have a Netgear wireless router plugged into that. When I set up any kind of forwarding I have to forward to the Netgear in the modem/router combo and then forward to the actual computer in the Netgear router... but then again you said you're running a Minecraft server and that all forwarded correctly eh?

 

I host both of my TeamSpeak servers on virtual private servers so the configuration and setup is a little different... but if you're not in a huge hurry when I get home tonight I can fire up a TS3 server on one of my computers at home and see if there's any weird configuration necessary to get it working. 

No the isp just gave us a modem and i bought router separately  


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

No the isp just gave us a modem and i bought router separately  

 

Gotcha. When I get home tonight I'll do some testing and fire you the results. Grand scheme of things TeamSpeak should be stupidly simple to manage... With the Windows Firewall off and forwarding set up it should work. There's always a chance 9987 is blocked by your ISP but since you tested a port in the 20000- range that's unlikely to be the issue. 

 

I'll get back to you tonight unless you/someone figures out a solution before then. 

Link to post
Share on other sites
Posted · Original PosterOP

Gotcha. When I get home tonight I'll do some testing and fire you the results. Grand scheme of things TeamSpeak should be stupidly simple to manage... With the Windows Firewall off and forwarding set up it should work. There's always a chance 9987 is blocked by your ISP but since you tested a port in the 20000- range that's unlikely to be the issue. 

 

I'll get back to you tonight unless you/someone figures out a solution before then. 

Thank you so much... Because of time zones ill probably be asleep but ill answer in the morning or just stay up all night :) Thanks alot!


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

Thank you so much... Because of time zones ill probably be asleep but ill answer in the morning or just stay up all night :) Thanks alot!

 

Hey, sorry, got busy last night and didn't have a chance to do any testing. Will do it tonight.

 

By the way are you on Windows 7, 8, 8.1. or 10 so I can test on the same?

Link to post
Share on other sites
Posted · Original PosterOP

Hey, sorry, got busy last night and didn't have a chance to do any testing. Will do it tonight.

 

By the way are you on Windows 7, 8, 8.1. or 10 so I can test on the same?

The server is on win 8.1 64bit while my main pc (client) is on win 10 64bit.


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

Some routers support loopback and some don't.

I see, that makes sense, thanks.


System specs
  • Graphics card: Asus GTX 980 Ti (Temp target: 60c, fan speed: slow as hell)
  • CPU: Intel 6700k @ 4.2Ghz
  • CPU Heatsink: ThermalRight Silver Arrow Extreme
  • Motherboard: Asus Maximus Viii Gene
  • Ram: 8GB of DDR4 @ 3000Mhz
  • Headphone source: O2 + Odac 
  • Mic input: Creative X-Fi Titanium HD
  • Case: Fractal Design Arc midi R2
  • Boot Drive: Samsung 840 Pro 128GB 
  • Storage: Seagate SSHD 2TB
  • PSU: Be quiet! Dark Power Pro 550w

Peripherals

  • Monitor: Asus ROG Swift PG278Q
  • Mouse: Razer DeathAdder Chroma (16.5 inch/360)
  • Mouse surface: Mionix Sargas 900
  • Tablet: Wacom Intuos Pen
  • Keyboard: Filco Majestouch Ninja, MX Brown, Ten Keyless 
  • Headphones: AKG K7xx
  • IEMs: BrainWavs S1
Link to post
Share on other sites

Heres a basic checklist:

does your router allow the port forward: port 9987udp. Does the port forward go to your server local IP?   If your ip is 192.168.1.101 for your server, then it should be port 9987 allowing all clients in and be on the local computer of 192.168.1.100. 

 

Also, make sure Windows firewall allows it.  A very important one I've actually had to help a few people with is if they have to NATs.  Meaning, if your modem isn't in bridged mode it will need to be bridged or port forwarded.  If you can bridge directly to your router, then you have to port forward from your modem to your router and from your router to your server.

 

Make sure no antivirus is blocking it, and that the teamspeak settings are correct. 

Link to post
Share on other sites
Posted · Original PosterOP

Heres a basic checklist:

does your router allow the port forward: port 9987udp. Does the port forward go to your server local IP?   If your ip is 192.168.1.101 for your server, then it should be port 9987 allowing all clients in and be on the local computer of 192.168.1.100. 

 

Also, make sure Windows firewall allows it.  A very important one I've actually had to help a few people with is if they have to NATs.  Meaning, if your modem isn't in bridged mode it will need to be bridged or port forwarded.  If you can bridge directly to your router, then you have to port forward from your modem to your router and from your router to your server.

 

Make sure no antivirus is blocking it, and that the teamspeak settings are correct. 

I can confirm that all you mentioned is done! im just gonna give up and use mumble :/ It just works!


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

I can confirm that all you mentioned is done! im just gonna give up and use mumble :/ It just works!

Wow.  what the hell?!?  Teamspeak servers are supposed to be easy to manage!

Link to post
Share on other sites
Posted · Original PosterOP

Wow.  what the hell?!?  Teamspeak servers are supposed to be easy to manage!

I guess not for me :/


CPU - Intel core i7 4790K @ 4.00Ghz | GPU - MSI GTX970 G4 4GB | RAM - Corsair 16GB LP @ 1600Mhz | MOBO - MSI Gaming 5 Z97


HHDs - WD blue 1TB, Toshiba 500GB, Samsung 240GB(ssd) | Case - NZXT H440 | Cooler - NZXT kraken x61(soon) | PSU - Corsair RM 850W


Monitors - 2x BenQ RL2455HM | Headset - Steel Series Siberia Elite prism | MouseSteel Series Rivals | Keyboard - Steel Series Apex M800

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×