Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
chrisrice93

USB 3 Not working after upgrading to windows 8

Recommended Posts

Posted · Original PosterOP

I recently upgraded to windows 8 and just realized that my usb 3 ports no longer work at full speed. Whenever I use my usb3 flash drive it transfers at usb 2 speeds whether I plug it into a usb 2 or usb 3 port. I have tried updating my motherboard bios and drivers but the problem persists. Any ideas? Thanks.

Link to post
Share on other sites
Posted · Original PosterOP

I have a gigabyte p67a-ud7-b3. I can't actually find usb3 drivers on gigabyte's website but when I look in device manager it recognizes them as usb3 ports.

Link to post
Share on other sites

If you look at this it says it has 2 x Renesas D720200 chips and 2 x VLI VL810 hubs, so if you would search for that chip maybe you can find some drivers? that's what I did for my Asrock P67 board, they weren't listed on the Asrock website either ;)


i5 2500K - Asrock Extreme4 Gen3 - G.Skill RipjawsX 8GB- Asus GTX660 Ti - Crucial M4 256Gb

 

Link to post
Share on other sites
Try and see if the link attached works. It SHOULD be fine' date=' but I suggest you just try it, really.[/quote']

Along with these, here are some chipset drivers; not sure if you will need these aswell, but it's always good to ensure you have everything:

This

And this

Link to post
Share on other sites

Try the original driver disc as well, but if that and the downloads fail, try to install the driver through manually choosing it in the "Have disk" option in Device Manager


MEH

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

Buy VPN

×