Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
jedylan

One of my sound cards makes noises.

Recommended Posts

Posted · Original PosterOP

I have a few sound cards in my system but the one I use most often is my SoundBlaster Z for the 5.1 Optical out. 

Since I made a fresh install of Windows 10 the card makes weird popping noises when PC is under load.

 

I have installed Latest Drivers and Softwares from the SoundBlaster website, I have tried changing the card to another slot, still makes the noise.

 

The Noises start when PC is under load and there is a lot of sound. Exemples: Video Games, Streaming Movies/ Youtube videos , Editing Sound in Adobe CC.

 

The problems seems to be overheating. At first I thought it was because of the video cards, but when I touched the backplates, the video cards were cooler than the sound card, while in a game.

 

I contacted Sound Blaster customer support, and they take days to answer, and only repeat the same F***ing things over and over again, I built my own PC don't you think I tried reinstalling the Drivers -_-.

 

 

DxDiag.txt

DxDiag.txt

Link to post
Share on other sites
        Sound Tab 5: The file umc_audioks_x64.sys is not digitally signed, which means that it has not been tested by Microsoft's Windows Hardware Quality Labs (WHQL).  You may be able to get a WHQL logo'd driver from the hardware manufacturer.

          Input Tab: No problems found.

 

Nothing to do with that?


“I'm telling you, people. Everyday we wake up is another blessing. Follow your dreams and don't let anyone stop you. Never say never.” ― Justin Bieber

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×