Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
ddbtkd456

Laptop Lid Is Killing My Connection

Windows 7 did it too so there's no way to fix it?

There's not much you could do about it from what I know of. I would just leave the lid open I guess?

Recommended Posts

Posted · Original PosterOP

So I shut my laptop lid and according to windows I'm still connected to my internet router. It fails to load webpages. Not even google will load when my laptop lid is shut. Open it, works like it should. I am HDMI this to a tv, and its getting really annoying. I have it set on maximum power settings when plugged in and to not go to sleep (do nothing). Still nothing. Went into the adapter settings and unchecked the box that says "computer can kill connection to save power" still acting like its on. Advice?


If you've previously won the build off please pm me so we can get something worked out.

Link to post
Share on other sites

Have you check this option? The "When I close lid" part

 

post-221594-0-55212700-1440387572_thumb.


Frost | 7700K @ 4.9GHz 1.36v, delidded | Asus DUAL GTX 1060 6GB OC | Corsair LPX 16GB DDR4 2800MHz | Samsung 960 EVO 250GB SSD + Toshiba 1TB HDD + Toshiba 2TB HDD + Samsung 860 EVO 1TB SSD for macOS | Asus PRIME Z270-A | Fractal Design Celsius S24 | Seasonic M12-II 620W PSU | Corsair 400C White | NZXT Hue+

Samsung Galaxy S8 | Stock

Ticwatch E (Black) | Ticwatch Brown Leather Strap

Link to post
Share on other sites
Posted · Original PosterOP

Have you check this option? The "When I close lid" part

Capture.PNG

Yes it's been a problem since I got it. I've also unchecked the box in the network adapter as well


If you've previously won the build off please pm me so we can get something worked out.

Link to post
Share on other sites

So I shut my laptop lid and according to windows I'm still connected to my internet router. It fails to load webpages. Not even google will load when my laptop lid is shut. Open it, works like it should. I am HDMI this to a tv, and its getting really annoying. I have it set on maximum power settings when plugged in and to not go to sleep (do nothing). Still nothing. Went into the adapter settings and unchecked the box that says "computer can kill connection to save power" still acting like its on. Advice?

The WiFi antennas are in the lid, and for some reason closing the lid hurts the connection on almost every laptop I've tested. If your laptop has a metal lid, then that's why(my current latitude e6420 has an area cut out on its lid, so when its closed it still barely works, just with a lower speed and shorter distance).

Link to post
Share on other sites

So I shut my laptop lid and according to windows I'm still connected to my internet router. It fails to load webpages. Not even google will load when my laptop lid is shut. Open it, works like it should. I am HDMI this to a tv, and its getting really annoying. I have it set on maximum power settings when plugged in and to not go to sleep (do nothing). Still nothing. Went into the adapter settings and unchecked the box that says "computer can kill connection to save power" still acting like its on. Advice?

If you did what the guy above said and still doesn't work, in the worst case scenario possibly it could be a hardware problem because a lot of laptops have their wireless connection cables running through the part which connects the monitor and the bottom half and stops the internet from working perhaps? But it's probably a software issue.

Link to post
Share on other sites
Posted · Original PosterOP

If you did what the guy above said and still doesn't work, in the worst case scenario possibly it could be a hardware problem because a lot of laptops have their wireless connection cables running through the part which connects the monitor and the bottom half and stops the internet from working perhaps? But it's probably a software issue.

Windows 7 did it too so there's no way to fix it?


If you've previously won the build off please pm me so we can get something worked out.

Link to post
Share on other sites
Posted · Best Answer

Windows 7 did it too so there's no way to fix it?

There's not much you could do about it from what I know of. I would just leave the lid open I guess?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Buy VPN

×