Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
yudothat2me

My location in Chrome Notifications & Speedtest are wrong

Recommended Posts

Posted · Original PosterOP

Hi All,

 

I have recently noticed that when I have Chrome Notifications come up that the location (for weather notification) will list the wrong location. I am currently in Michigan and I am being given notifications for Maryland. I also went to Speedtest and the location there is also using the Washington DC area for my location, even though I am in Michigan. I have run Kaspersky Antivirus 2013 and MBAM in safe mode and they come up with nothing detected for malware/viruses, so I don't have a clue what could be causing this. Anyone have any ideas on what causes this and how it can be fixed?

Link to post
Share on other sites

are you using a VPN or something like Hola?


Case: NZXT Phantom PSU: EVGA G2 650w Motherboard: Asus Z97-Pro (Wifi-AC) CPU: 4690K @4.2ghz/1.2V Cooler: Noctua NH-D15 Ram: Kingston HyperX FURY 16GB 1866mhz GPU: Gigabyte G1 GTX970 Storage: (2x) WD Caviar Blue 1TB, Crucial MX100 256GB SSD, Samsung 840 SSD Wifi: TP Link WDN4800


Horses are love, Horses are life.                    "No answer means no problem!" - Luke 2015

Link to post
Share on other sites

Maybe your ISP has you connected to a server in Washington


Intel Core i7 9700k - EVGA FTW GTX 970

Link to post
Share on other sites

:o another michigander!

 

All it's doing is taking your IP address and tracing it to the nearest ISP hub, if you use some sort of VPN or something then that could have an impact on it.


Specs: CPU - Intel i7 8700K @ 5GHz | GPU - Gigabyte GTX 970 G1 Gaming | Motherboard - ASUS Strix Z370-G WIFI AC | RAM - XPG Gammix DDR4-3000MHz 32GB (2x16GB) | Main Drive - Samsung 850 Evo 500GB M.2 | Other Drives - 7TB/3 Drives | CPU Cooler - Corsair H100i Pro | Case - Fractal Design Define C Mini TG | Power Supply - EVGA G3 850W

Link to post
Share on other sites

Hi All,

 

I have recently noticed that when I have Chrome Notifications come up that the location (for weather notification) will list the wrong location. I am currently in Michigan and I am being given notifications for Maryland. I also went to Speedtest and the location there is also using the Washington DC area for my location, even though I am in Michigan. I have run Kaspersky Antivirus 2013 and MBAM in safe mode and they come up with nothing detected for malware/viruses, so I don't have a clue what could be causing this. Anyone have any ideas on what causes this and how it can be fixed?

Make sure your chrome location settings are set like this 

EDIT: I've also seen kaspersky do stupid shit like this, remove it. 


 

Spoiler

I7 4790K @4.5 Ghz 1.294V

VALIDATION, MSI Z97 Gaming 7, 24GB DDR3 1600, Asus Strix 1070 8GB OC@ 2.2Ghz, Corsair graphite series 760T (Black), Cooler master V850, NH-D15 w/LNA ,1TB Samsung 850 Evo,  480GB Sandisk Ultra II SSD, 3TB Seagate Barracuda x 3, 1 TB WD Passport (Backup drive), 2 TB WD Passport (Backup Drive 2),  Windows 10 Pro x64 (uhg), Logitech G900 Chaos (Main), Steelseries Rival (FADE) (Courtesy of Edzel Yago, Thanks Ed), Steelsieres Rival 300 Hyperbeast Special Edition, Coolermaster Quickfire TKL (MX Blue), Razer Blackwidow Tournament edition (Greens).  Audio: Sennheiser HD598 SE, Edifier S1000DB, AudioEngine D1 DAC; Yamaha MG06X Mixer & AudioTechnica AT2020.

 

Phones; Daily drivers: Nexus 6P 64GB/iPhone 6 (Music), Apple Watch, Apple AirPods.

Laptop: 2015 Macbook Pro 13, 8GB of RAM, 2.7Ghz i5, 240GB Apple SSD. 

 

Spoiler

Plex Server: i7 3770, Gigabyte Board, 16GB DDR3 1600, Asus Strix GTX 1050ti 4GB, 120GB SSD Boot Drive, 8 x 3TB Seagate Barracuda, Rosewill RSV-R4000 With 2 Rosewill Hot Swap 4x Backplane Bays, 1050 Watt Corsair HX Series PSU,Hyper T2, Windows 10 Pro 

 

I also do Youtube, check me out!

Link to post
Share on other sites

:o another michigander!

 

All it's doing is taking your IP address and tracing it to the nearest ISP hub, if you use some sort of VPN or something then that could have an impact on it.

Michigan FTW

 

ATT does this to me, apparently i live in ohio, only happens with ipv6 though, my ipv4 location is right


 

 

 

Link to post
Share on other sites
Posted · Original PosterOP

Make sure your chrome location settings are set like this 

EDIT: I've also seen kaspersky do stupid shit like this, remove it. 

I set my Chrome up like this, but it still shows wrong location for Speedtest. I want to keep Kaspersky until I find something better. Any recommendations on anti-virus to use?

Link to post
Share on other sites
Posted · Original PosterOP

Michigan FTW

 

ATT does this to me, apparently i live in ohio, only happens with ipv6 though, my ipv4 location is right

How do I check what my IP address is in ipv4 and ipv6?

Link to post
Share on other sites

I set my Chrome up like this, but it still shows wrong location for Speedtest. I want to keep Kaspersky until I find something better. Any recommendations on anti-virus to use?

Windows defender is all you need. 


 

Spoiler

I7 4790K @4.5 Ghz 1.294V

VALIDATION, MSI Z97 Gaming 7, 24GB DDR3 1600, Asus Strix 1070 8GB OC@ 2.2Ghz, Corsair graphite series 760T (Black), Cooler master V850, NH-D15 w/LNA ,1TB Samsung 850 Evo,  480GB Sandisk Ultra II SSD, 3TB Seagate Barracuda x 3, 1 TB WD Passport (Backup drive), 2 TB WD Passport (Backup Drive 2),  Windows 10 Pro x64 (uhg), Logitech G900 Chaos (Main), Steelseries Rival (FADE) (Courtesy of Edzel Yago, Thanks Ed), Steelsieres Rival 300 Hyperbeast Special Edition, Coolermaster Quickfire TKL (MX Blue), Razer Blackwidow Tournament edition (Greens).  Audio: Sennheiser HD598 SE, Edifier S1000DB, AudioEngine D1 DAC; Yamaha MG06X Mixer & AudioTechnica AT2020.

 

Phones; Daily drivers: Nexus 6P 64GB/iPhone 6 (Music), Apple Watch, Apple AirPods.

Laptop: 2015 Macbook Pro 13, 8GB of RAM, 2.7Ghz i5, 240GB Apple SSD. 

 

Spoiler

Plex Server: i7 3770, Gigabyte Board, 16GB DDR3 1600, Asus Strix GTX 1050ti 4GB, 120GB SSD Boot Drive, 8 x 3TB Seagate Barracuda, Rosewill RSV-R4000 With 2 Rosewill Hot Swap 4x Backplane Bays, 1050 Watt Corsair HX Series PSU,Hyper T2, Windows 10 Pro 

 

I also do Youtube, check me out!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Newegg

×