Jump to content
CoolaxGaming

[AMD-GPU] Increase performance by disabling downclocking

Recommended Posts

Posted · Original PosterOP

Hello!

 

The text underneath is just justification to disable powerplay, the actual guide is underneath the bold note.

 

Today for ya all I have gotten a really simple but nontheless useful guide!

This will teach you how to permanently disable GPU downclocking for Core and Memory, thus increasing performance. But you may ask, why the hell would you do that?

Well, AMD has something they call PowerPlay, which downclocks the gpu to decrease power consumption. It is a nifty feature, but as always, AMD did it wrong. It sometimes decreases performance is these cases -

1. You are playing a high-quality

2. You are playing a game in windowed mode

3. You are playing the game in fullscreen.

So why does this happen? Well you see, the main culprit is the memory speed, which in AMD has two speeds , one at idle the other at load. The Idle value is 150mhz and the load is whatever your GPU's advertised speed is (For a 290x, 1250mhz) Now that is a big difference, a difference of over a GHZ even in NON effective speeds.

So if you are playing a 4k60 fps video, your GPU might be on the edge and activate PowerPlay, causing your speed to go down to 150 and since that is too low for 4k60, causing your video to lag. Same thing happens in Windowed mode for games, the Core and MEM may downclock, causing the FPS to drop. And lets say you are playing BF4, suddenly you look at an non-intense area and your gpu starts to drop the core by a mhz or two. Your fps might go down by a frame.

So by disabling PowerPlay and forcing speeds to be at max, you may increase performance.

 

NOTE: THIS WILL ONLY  INCREASE YOUR TEMPRATURES BY ~10 DEGREES C AT IDLE

 

---------------------------Actual Guide-------------------------------------

 

1. Download and Install MSI Afterburner

2. Now go to settings button and click it

3. A screen like this will pop up -

post-165109-0-23763200-1429393900_thumb.

NOTE: Please ignore all settings except the ones surrounded by the red pen.

4. Check Disable ULPS 

5. Click the dropdown of "Unoffical overclocking mode"

6. Select Without PowerPlay Support

7. Press OK and you will be asked to restart MSI AB.

8. Restart it

9. Voila you are done!
 

 

----------------------------Results---------------------------------------------

 

1. I noticed MASSIVE improvement in windowed games

2. I could play 4k60 without hitchiching and stuttering

3. BF4 And BFH Frame rates were more consistent

 

 

 

So hope you guys like this! 

Enjoy!

 


Lets all ripperoni in pepperoni

Link to post
Share on other sites

Made a huge difference in world of tanks.


CPU: AMD FX 8320  CPU Cooler: 212 Evo GPU: Asus GTX 750 Ti @ 1400MHz RAM: Crucial Ballistix Sport 8GB (2x4gb) MOBO: ASUS M5A97 R2.0 Power Supply: Evga G2 650 Storage: Western Digital Caviar Blue 1TB, San Disk Ultra 240 GB SSD Case: Corsair 230t Orange

 

Link to post
Share on other sites
Posted · Original PosterOP

is that risky?

specs :-

GPU : R9 285 dual-x

CPU: FX-6300 (stock)

PSU: thermaltake smart se 730w

MOBO : 78lmt-s2p REV5, ye i know its low but i dont even oc so.. np

umm and ye i have weak cooling system.

Shouldnt be.


Lets all ripperoni in pepperoni

Link to post
Share on other sites

How many fps?

Around 10fps and no dips into the 30s


CPU: AMD FX 8320  CPU Cooler: 212 Evo GPU: Asus GTX 750 Ti @ 1400MHz RAM: Crucial Ballistix Sport 8GB (2x4gb) MOBO: ASUS M5A97 R2.0 Power Supply: Evga G2 650 Storage: Western Digital Caviar Blue 1TB, San Disk Ultra 240 GB SSD Case: Corsair 230t Orange

 

Link to post
Share on other sites
Posted · Original PosterOP

Thanks for the help! It helped keep my clocks consistent, which helped increase performance!

 

Is it safe to have PowerPlay disabled at all times?

Sure. Will take more power, but who cares.

The max power and temp should be same.


Lets all ripperoni in pepperoni

Link to post
Share on other sites

my current gpu temps as the sensor says : 37C to 47C and and maybe 55C as max for now.. its the first use for this card, so which temps do you expect for my gpu ?

Absolutely fine. I would even go as far as to saying below 60°C while gaming is the optimum.

I for example can't achieve temps better than that and my card is already configured pretty agressive.

Backl to what i was saying: As long as you stay below 80 your GPUs live spend shoudl not be negativly affected. therefore even 70°C would be fine.


http://linustechtips.com/main/topic/334934-unofficial-ltt-beginners-guide/ (by Minibois) and a few things that will make our community interaction more pleasent:
1. FOLLOW your own topics                                                                                2.Try to QUOTE people so we can read through things easier
3.Use
PCPARTPICKER.COM - easy and most importantly approved here        4.Mark your topics SOLVED if they are                                
Don't change a running system

Link to post
Share on other sites

I tried to tweak these settings again, but for some reason my clocks still idle around 300 core and 150 memory. How do I fix this? I did everything you said. It worked before, but I had to reinstall my drivers and reinstall MSI AB due to other issues.

 

I can apply my overclock settings and they will stick. They are not volatile. However, when I hit "Reset" in MSI AB, my clocks go to 300 core and 150 memory when they should be going to their default values of 800 core and 1250 memory. This is how it worked in the past.


Check out my Intel Haswell & Haswell-Refresh CPU Overclocking Guide & my NVIDIA & AMD GPU Overclocking Guide

MSG me if you need help w/ your PC build

Link to post
Share on other sites

Sure. Will take more power, but who cares.

Pretty much anyone who bought an amd card lol. I did.

Link to post
Share on other sites

Hey Op,

 

This is like a dream come true for me :'D I just can't thank you enough man! I tried everything..literally every possible way to stop my laptop FPS drop, but none of them worked. High Performace settings, overclocking, upgrading and downgrading driver, numerous software, cooling pad, checking temperature and shit but none of them worked. I always knew my laptop had the potential to play games without any problem, but I always used to have sudden FPS drop in between games for just a few minutes, again my FPS used to go back to normal. I never knew what was going on until I read your post, I am really very much grateful to you. I just can't explain how happy I am at the moment. I just followed your instructions and can now play my games without any FPS drops :D:D:D:D:D:D with everything set to balanced instead of high performance and shit :DD once again thank you so much :)) I just can't thank you enough. :)))

Link to post
Share on other sites

Somehow just found this out, gained an average of 5% in games and benchs ... only from checking a box!!!


Google Play Daily Deals Thread

Ethereum Mining Guide

Spoiler

My Gaming Rig - Motherboard: Asus Z87-PLUS CPU: i5-4670k @ 4.1Ghz RAM: 16GB DDR3 2400(4x4GB) GPU: Gigabyte Windforce OC 7870 OS SSD: 240GB Avexir E100 Storage: 1x 500GB WD PSU: Seasonic G650 OS: Windows 10 Pro 64bits Monitor: Acer G205H

Spoiler

My HomeMade NAS - Motherboard: Dell Intel Q35 CPU: Core2Quad Q6600 RAM: 4GB DDR2 (2x2GB) OS HDD: 80GB Seagate Storage: 3x 500GB WD PSU: Dell modded to fit SFF size 250w OS: OpenMediaVault

 

The Community StandardsPSU Tier list | PSU Whitelist

Link to post
Share on other sites

Ah, the old ULPS... I'm intimately familiar from enduring AMD's switchable graphics on my laptop.  Not surprised it would rear its ugly head in another way like this.

Link to post
Share on other sites
On ‎4‎/‎18‎/‎2015 at 5:57 PM, CoolaxGaming said:

Hello!

 

The text underneath is just justification to disable powerplay, the actual guide is underneath the bold note.

 

Today for ya all I have gotten a really simple but nontheless useful guide!

This will teach you how to permanently disable GPU downclocking for Core and Memory, thus increasing performance. But you may ask, why the hell would you do that?

Well, AMD has something they call PowerPlay, which downclocks the gpu to decrease power consumption. It is a nifty feature, but as always, AMD did it wrong. It sometimes decreases performance is these cases -

1. You are playing a high-quality

2. You are playing a game in windowed mode

3. You are playing the game in fullscreen.

So why does this happen? Well you see, the main culprit is the memory speed, which in AMD has two speeds , one at idle the other at load. The Idle value is 150mhz and the load is whatever your GPU's advertised speed is (For a 290x, 1250mhz) Now that is a big difference, a difference of over a GHZ even in NON effective speeds.

So if you are playing a 4k60 fps video, your GPU might be on the edge and activate PowerPlay, causing your speed to go down to 150 and since that is too low for 4k60, causing your video to lag. Same thing happens in Windowed mode for games, the Core and MEM may downclock, causing the FPS to drop. And lets say you are playing BF4, suddenly you look at an non-intense area and your gpu starts to drop the core by a mhz or two. Your fps might go down by a frame.

So by disabling PowerPlay and forcing speeds to be at max, you may increase performance.

 

NOTE: THIS WILL ONLY  INCREASE YOUR TEMPRATURES BY ~10 DEGREES C AT IDLE

 

---------------------------Actual Guide-------------------------------------

 

1. Download and Install MSI Afterburner

2. Now go to settings button and click it

3. A screen like this will pop up -

Capture.PNG

NOTE: Please ignore all settings except the ones surrounded by the red pen.

4. Check Disable ULPS 

5. Click the dropdown of "Unoffical overclocking mode"

6. Select Without PowerPlay Support

7. Press OK and you will be asked to restart MSI AB.

8. Restart it

9. Voila you are done!
 

 

----------------------------Results---------------------------------------------

 

1. I noticed MASSIVE improvement in windowed games

2. I could play 4k60 without hitchiching and stuttering

3. BF4 And BFH Frame rates were more consistent

 

 

 

So hope you guys like this! 

Enjoy!

 

I really wished you would have put a disclaimer that it will increase the power draw, fairly significantly, for the part.


Please spend as much time writing your question, as you want me to spend responding to it.  Take some time, and explain your issue, please!

Spoiler

If you need to learn how to install Windows, check here:  http://linustechtips.com/main/topic/324871-guide-how-to-install-windows-the-right-way/

Event Viewer 101: https://youtu.be/GiF9N3fJbnE

 

Link to post
Share on other sites
On 4/18/2015 at 5:57 PM, CoolaxGaming said:

Hello!

 

The text underneath is just justification to disable powerplay, the actual guide is underneath the bold note.

 

Today for ya all I have gotten a really simple but nontheless useful guide!

This will teach you how to permanently disable GPU downclocking for Core and Memory, thus increasing performance. But you may ask, why the hell would you do that?

Well, AMD has something they call PowerPlay, which downclocks the gpu to decrease power consumption. It is a nifty feature, but as always, AMD did it wrong. It sometimes decreases performance is these cases -

1. You are playing a high-quality

2. You are playing a game in windowed mode

3. You are playing the game in fullscreen.

So why does this happen? Well you see, the main culprit is the memory speed, which in AMD has two speeds , one at idle the other at load. The Idle value is 150mhz and the load is whatever your GPU's advertised speed is (For a 290x, 1250mhz) Now that is a big difference, a difference of over a GHZ even in NON effective speeds.

So if you are playing a 4k60 fps video, your GPU might be on the edge and activate PowerPlay, causing your speed to go down to 150 and since that is too low for 4k60, causing your video to lag. Same thing happens in Windowed mode for games, the Core and MEM may downclock, causing the FPS to drop. And lets say you are playing BF4, suddenly you look at an non-intense area and your gpu starts to drop the core by a mhz or two. Your fps might go down by a frame.

So by disabling PowerPlay and forcing speeds to be at max, you may increase performance.

 

NOTE: THIS WILL ONLY  INCREASE YOUR TEMPRATURES BY ~10 DEGREES C AT IDLE

 

---------------------------Actual Guide-------------------------------------

 

1. Download and Install MSI Afterburner

2. Now go to settings button and click it

3. A screen like this will pop up -

Capture.PNG

NOTE: Please ignore all settings except the ones surrounded by the red pen.

4. Check Disable ULPS 

5. Click the dropdown of "Unoffical overclocking mode"

6. Select Without PowerPlay Support

7. Press OK and you will be asked to restart MSI AB.

8. Restart it

9. Voila you are done!
 

 

----------------------------Results---------------------------------------------

 

1. I noticed MASSIVE improvement in windowed games

2. I could play 4k60 without hitchiching and stuttering

3. BF4 And BFH Frame rates were more consistent

 

 

 

So hope you guys like this! 

Enjoy!

 

You are awesome dude! Thank you.

(thread is old but it still helped me a lot in ESO and Fallout 4)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.


×