Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
ace2k8

GTA V ERR_GFX_D3D_INIT

Turn off Fraps. That seemed to work for me.

Recommended Posts

Posted · Original PosterOP

My GTA V keeps crashing after 5 to 15 min of game play. Does not matter if its online or SP.  Tried to uninstall the game from my HDD and put it on my SSD Raid to see if it would help and nothing. Running Windows 7 and a Bad ass rig. I know my PC is over the top and can play the game so that is not the problem. I do have the newest Nvidia drivers and I tried SLI and non SLI.

post-37299-0-83025900-1429016213.png

Link to post
Share on other sites
Posted · Original PosterOP

Yea I hate when I pay for games and they don't work.  Its almost like the people that Pirate don't have the same problems. 

Link to post
Share on other sites
Posted · Original PosterOP

So was any one running fraps. I am using fraps too. I will cut it off and give it a try. 

Link to post
Share on other sites

So was any one running fraps. I am using fraps too. I will cut it off and give it a try. 

 

Hopefully that works for ya.

Link to post
Share on other sites

I have the error still, even with no OSD program running while playing the game. This bugs me... I can't play GTA V without it crashing with that error.


Case: Fractal Define R6 USB-C Tempered Glass CPU: i7 5930K @ 4.0GHz Motherboard: EVGA X99 Classified RAM: 48GB DDR4 2666MHz G.Skill GPU: MSi GTX 980 Ti Lightning Edition PSU: Corsair HX1000i 80+ Platinum Drives: 500GB SSD (2x), 960GB SSD, 120GB SSD, 2TB (2x) HDD, 4TB HDD, & 500GB HDD Displays: Acer Predator 27" XB271HU 165Hz G-Sync (1440p) & 2x Dell P2715Q 27" (2160p) 

Link to post
Share on other sites

I have the issue, I dont have Fraps. Clean install of Windows 1 day before GTA V.


PC Specs


Asus Rampage IV Extreme | Intel i7 3930K @ 4.7GHz | Corsair Vengeance 1600MHz 32GB (8x4GB) | MSI GTX 980 +200MHz +200MHz | Corsair HX1050i PSU


Corsair Force 120GB SSD | Western Digital 2TB Green HDD | Corsair Carbide 500R Midtower | Random DVD Burner | Corsair H100 for CPU

Link to post
Share on other sites

Having this issue as well. Sometimes can't even get into the game. Extremely frustrating...


Specs:

 

Intel i7-4790K @ 4.7 GHz cooled by Corsair H80i | ASUS Maximus VII Formula |  G.Skill 8 GB (2 x 4GB) 2133 | EVGA 980 Superclocked (Fry) | 128GB Samsung 840 Pro OS Drive | WD Black HDD | 500GB Samsung 850 EVO | Corsair Vengeance K70 | Logitech G502 Proteus Core

 

 

lol @ AMD 8350

 

Link to post
Share on other sites

Turn off Fraps. That seemed to work for me.

What if I don't have Fraps running?


PC Specs   - Black and White Build

    Intel Core i5 4690k MSI Z97S Krait LGA 1150

    Crucial Ballistix Sport 1x8GB 1600MHZ

    Sapphire Radeon R9 270 (Will be upgrading this soon)

    EVGA 500W PSU

    Phanteks Enthoo Pro - White

    

Link to post
Share on other sites

I was having this problem and, for me, it seems to be related to MSI Afterburner... I thought my overclock was stable so I'm not sure if it's that or they just don't get along.

Edited by Chrjz
Link to post
Share on other sites

Hi Guys,

 

i had this problem too. Nothing helped. Clocking down, not using afterburner, nothing.

 

Then a buddy gave me a hint i should try to disable vsync and Tesselation. Vsync was disabled from the beginning, so i disabled Tesselation. And what shall I say: It worked. :D :D

 

So try to disable Tesselation and see if it runs well then. I had no issues in an one hour session, before it crashed at least every 5 mins into the game.

 

I hope they will fix this though, because Tesselation looks nice, but for the moment I can  live without it :D

 

Greetings

 

Sixi

Link to post
Share on other sites

Hi Guys,

 

i had this problem too. Nothing helped. Clocking down, not using afterburner, nothing.

 

Then a buddy gave me a hint i should try to disable vsync and Tesselation. Vsync was disabled from the beginning, so i disabled Tesselation. And what shall I say: It worked. :D :D

 

So try to disable Tesselation and see if it runs well then. I had no issues in an one hour session, before it crashed at least every 5 mins into the game.

 

I hope they will fix this though, because Tesselation looks nice, but for the moment I can  live without it :D

 

Greetings

 

Sixi

Sounds like that would work, I don't want to disable V-sync because of tearing (getting g-sync soon so that will be fixed). Tesselation is nice to have but I might disable it next time I play. Usually I play for around 2-3 hours before I crash.


i7 6700K - ASUS Maximus VIII Ranger - Corsair H110i GT CPU Cooler - EVGA GTX 980 Ti ACX2.0+ SC+ - 16GB Corsair Vengeance LPX 3000MHz - Samsung 850 EVO 500GB - AX760i - Corsair 450D - XB270HU G-Sync Monitor

i7 3770K - H110 Corsair CPU Cooler - ASUS P8Z77 V-PRO - GTX 980 Reference - 16GB HyperX Beast 1600MHz - Intel 240GB SSD - HX750i - Corsair 750D - XB270HU G-Sync Monitor
Link to post
Share on other sites

I have the same problem, although it doesn't seem to happen on regular intervals. I will try some solutions given here and see if they fix the issue.


My System
Intel Core i7-7700 ♦ EVGA 1080Ti FTW3 ♦ 16GB (2x8GB) G.SKILL TridentZ RGB DDR4 3200
ASUS Strix Z270I ♦ Intel 600p 256GB ♦ Dan Case A4-SFX

Link to post
Share on other sites

Last night I was able to play for 4 hours without a crash, the solution was to delete the campaign progress and delete the Rockstar folder in my user/AppData/. Then I ran the game without touching the graphics settings (auto detected settings). No problems. I also un-installed MSI Afterburner and Fraps. Hopefully they get this issue resolved soon.


Case: Fractal Define R6 USB-C Tempered Glass CPU: i7 5930K @ 4.0GHz Motherboard: EVGA X99 Classified RAM: 48GB DDR4 2666MHz G.Skill GPU: MSi GTX 980 Ti Lightning Edition PSU: Corsair HX1000i 80+ Platinum Drives: 500GB SSD (2x), 960GB SSD, 120GB SSD, 2TB (2x) HDD, 4TB HDD, & 500GB HDD Displays: Acer Predator 27" XB271HU 165Hz G-Sync (1440p) & 2x Dell P2715Q 27" (2160p) 

Link to post
Share on other sites

I heard that toggling your VSYNC will fix this.


Case: Fractal Design R4 (x2 Noctua 140mm Fans, x2 Fractal Design Fans)            Processor: Intel Core i7 3770k @4.2GHz (Hyper 212 Evo)             Audioengine A5+ Black Speakers

Motherboard: MSI Z77A-G45 ATX LGA1155 Z77 DDR3                                           Graphics Card: EVGA GTX 1080 SC                                               Corsair K65 RGB Cherry MX Red

Memory: G.SKILL Ripjaws X 4X4GB DDR3-1600                                                     Power Supply: OCZ Z-Series Semi Modular Gold 850W                 ASUS & LG 21.5 Monitor (Dual monitor arm)

Link to post
Share on other sites

I have all my settings on minimum, this error occurs every now and again, I THINK it is somehow related to graphical buffer overflow. Or this is a DirectX issue, because the problem persisted on dx 10, 10.1 and 11

Any way, it is clearly not our fault, guys

Link to post
Share on other sites

I played for a few hours last night without changing any of my settings and the crash never happened. So I'm not exactly sure what's going on.


My System
Intel Core i7-7700 ♦ EVGA 1080Ti FTW3 ♦ 16GB (2x8GB) G.SKILL TridentZ RGB DDR4 3200
ASUS Strix Z270I ♦ Intel 600p 256GB ♦ Dan Case A4-SFX

Link to post
Share on other sites

I have all my settings on minimum, this error occurs every now and again, I THINK it is somehow related to graphical buffer overflow. Or this is a DirectX issue, because the problem persisted on dx 10, 10.1 and 11

Any way, it is clearly not our fault, guys

I posted my results and answer to the err_gfx_d3d_init bug in the GTA V Little Big Problem thread explaining why I was experiencing that annoying crash.


Case: Fractal Define R6 USB-C Tempered Glass CPU: i7 5930K @ 4.0GHz Motherboard: EVGA X99 Classified RAM: 48GB DDR4 2666MHz G.Skill GPU: MSi GTX 980 Ti Lightning Edition PSU: Corsair HX1000i 80+ Platinum Drives: 500GB SSD (2x), 960GB SSD, 120GB SSD, 2TB (2x) HDD, 4TB HDD, & 500GB HDD Displays: Acer Predator 27" XB271HU 165Hz G-Sync (1440p) & 2x Dell P2715Q 27" (2160p) 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×