Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
armyboy50

Installed new components and usb devices don't work after bios

Recommended Posts

Posted · Original PosterOP

Just installed my computer into a bitfenix prodigy with a Gigabyte z97n gaming mobo with a RM650 psu and my mouse and keyboard don't work!!!! Nor any of the USB ports for that matter. They work fine during bios but when 'starting windows' comes up they all go off. I have a ps2 keyboard which I tried to use to download drivers for the motherboard but since I don't have a dvd drive I can install from disc without ghetto img the old computer.

I've tried clearing cmos also and I'm hoping my mobo isn't dead, please help!!!

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×