Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Vobruh

r9 290 crossfire mismatched usages causing hangs & crashing.

are you using the PCIE 3.0 8x8x slots are you using the x16/x4 slots.

 

x16/x4 is not enough bandwidth for xDMA bridgeless crossfire. I had similar issues until I changed to 8x8x

 

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.

Haha! That's all it was... Jeebus chrust! Literally. An entire week of trying to get crossfire to frickin' work, and all I actually needed to do was update my bios. Rip gaben. Rip me. Rip all that is luv. Rip all that is LYF. Thank you guys for your help! :D Honestly.

Recommended Posts

Posted · Original PosterOP

Specs-
 
i7 3770K
Asus Sabertooth z77
EVGA SuperNOVA G2 1000w
2x MSi reference r9 290's
8 gigabytes of ram

 
Before you read:
 
*Heat is not the issue
*Both cards work fine by themselves
*Both PCIe slots work fine
*All of the cords I'm using from the psu, and the psu itself are working correctly
*I have plenty of power
*I have the most updated versions of my drivers
*I have crossfire enabled
*I'm monitoring the usage via gpu-z

*I have the latest bios update for my mobo.
 
The issue at hand:
 
My issue is that when I go into games both gpu's will rise with a similar load, but then after a few seconds the gpu usages will become mismatched i.e. One card will sit at 100% while the other will sit at 0-10%, and then they'll switch so that the opposite gpu is sitting at 100%, and the one that was at 100% is now sitting at 0-10%. Any ideas?

Link to post
Share on other sites
Posted · Original PosterOP

That happens when your GPU's aren't being stressed to 100%. They'll split the load between them. Usually it's because of some kind of framerate limiter like V-Sync or a built-in game framerate cap, or a CPU bottleneck.

not running v-sync in any games, and it happens even in stress tests like furmark and valley. The load isn't really being split either :l It just lays the load on one and this causes a stuttery instable mess.

Link to post
Share on other sites

not running v-sync in any games, and it happens even in stress tests like furmark and valley. The load isn't really being split either :l It just lays the load on one and this causes a stuttery instable mess.

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.
Link to post
Share on other sites
Posted · Original PosterOP

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.

Was waiting to get Far Cry 4 until I get this figured out :P and I do have v-sync manually disabled through ccc as well, as well as in game. Should've mentioned that. sorry :l

Link to post
Share on other sites
Posted · Original PosterOP

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.

Should I dare attempt a 3rd reinstall of windows?

Link to post
Share on other sites
Posted · Original PosterOP

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.

I became skeptical and decided to double check my bios.... Apparently it's not up to date anymore. I'm updating, and I'll be back. Wish me luck. Toi Toi Toi

 

and let's pray to our lords gaben, linus, and sometimes luke that I don't brick my computer.

Link to post
Share on other sites

Specs-

 

i7 3770K

Asus Sabertooth z77

EVGA SuperNOVA G2 1000w

2x MSi reference r9 290's

8 gigabytes of ram

 

Before you read:

 

*Heat is not the issue

*Both cards work fine by themselves

*Both PCIe slots work fine

*All of the cords I'm using from the psu, and the psu itself are working correctly

*I have plenty of power

*I have the most updated versions of my drivers

*I have crossfire enabled

*I'm monitoring the usage via gpu-z

*I have the latest bios update for my mobo.

 

The issue at hand:

 

My issue is that when I go into games both gpu's will rise with a similar load, but then after a few seconds the gpu usages will become mismatched i.e. One card will sit at 100% while the other will sit at 0-10%, and then they'll switch so that the opposite gpu is sitting at 100%, and the one that was at 100% is now sitting at 0-10%. Any ideas?

 

are you using the PCIE 3.0 8x8x slots are you using the x16/x4 slots.

 

x16/x4 is not enough bandwidth for xDMA bridgeless crossfire. I had similar issues until I changed to 8x8x


Sim Rig:  Oculus Quest with Link - Acer XV273KP - 3700x @ 4.35 - GTX 2080ti - X470 RoG C7H - 32 GB ddr4 @ 3600mhz - DG-85 - HX1200 - Dark Rock Pro 4

Quote

Long Live VR. Pancake gaming is dead.

Link to post
Share on other sites
Posted · Original PosterOP

are you using the PCIE 3.0 8x8x slots are you using the x16/x4 slots.

 

x16/x4 is not enough bandwidth for xDMA bridgeless crossfire. I had similar issues until I changed to 8x8x

I'm using 8x8x (the first two slots)

Link to post
Share on other sites
Posted · Original PosterOP

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.

 

are you using the PCIE 3.0 8x8x slots are you using the x16/x4 slots.

 

x16/x4 is not enough bandwidth for xDMA bridgeless crossfire. I had similar issues until I changed to 8x8x

 

Alright, successfully updated my bios to the most recent version. I'm going to uninstall everything amd/ati, and then reinstall with only one card, once again. Let's see how that goes. I'm hoping that it was just the bios not playing nice with both cards at once.

Link to post
Share on other sites
Posted · Original PosterOP · Best Answer

are you using the PCIE 3.0 8x8x slots are you using the x16/x4 slots.

 

x16/x4 is not enough bandwidth for xDMA bridgeless crossfire. I had similar issues until I changed to 8x8x

 

Interesting. I'm not sure that furmark uses multiple GPU's properly, I haven't looked into it though. Make sure you disable V-Sync in the CCC, although some games (especially particularly broken ones like Far Cry 4) will have FPS limited to 60 even when V-Sync is off ingame and in the CCC. Go figure.

Haha! That's all it was... Jeebus chrust! Literally. An entire week of trying to get crossfire to frickin' work, and all I actually needed to do was update my bios. Rip gaben. Rip me. Rip all that is luv. Rip all that is LYF. Thank you guys for your help! :D Honestly.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×