Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
declined

Hey guys, first post, multi monitor Battlefield4, help.

Recommended Posts

Posted · Original PosterOP

So I've set up 3 Asus 24" VG248Qe 144hz screens.
I have enabled SLI and Surround. I got World of warcraft to work proper with no difficulties what so ever on ultra settings nice fps nice gameplay all that nice stuff.
But The problem now is Battlefield 4. I have set the resolution to 5760*1080 and the loadscreen goes on the middle screen while the other two are dark, but when I get in the game I cant use my mouse or keyboard, it's stuck in the menu and I can't do anything.

Is there anyone that knows of this problem and could help?

I have 2 GTX Titan cards.

Link to post
Share on other sites

Have you tried running in windowed mode, then switching to fullscreen?

That's an issue i've had in the past with one monitor...

WELCOME TO THE LTT FORUMS!!!  :D I hope you enjoy your stay

Please read the C.O.C (in my signature) and if you'd like, change your theme to 'Night' (directions located in my signature)


Are you new? Please read CoC  Before posting! PLEASE SELECT 'AUTOMATIC' FOR FONT COLOR FOR US DARK THEME USERS (Only for dark shades)If you can read this, it means you need to change to NIGHT THEME (bottom left above LMG logo) Please follow your threads and Quote people when replying to them. Mark your problem as solved if answered. Don't spam, nobody likes a spammer. DO NOT QUOTE IMAGES! BE NICE!

Link to post
Share on other sites
Posted · Original PosterOP

Have you tried running in windowed mode, then switching to fullscreen?

That's an issue i've had in the past with one monitor...

WELCOME TO THE LTT FORUMS!!!  :D I hope you enjoy your stay

Please read the C.O.C (in my signature) and if you'd like, change your theme to 'Night' (directions located in my signature)

Hey I just tried windowed, and that didnt work, I tried borderless windowed and then I can play all of a sudden. but when I changed to fullscreen the same problem happened. I cant use my mouse/keyboard and I have to quit the game through task manager.

Link to post
Share on other sites

Hey I just tried windowed, and that didnt work, I tried borderless windowed and then I can play all of a sudden. but when I changed to fullscreen the same problem happened. I cant use my mouse/keyboard and I have to quit the game through task manager.

All drivers are up to date? Also, have you tried it with SLI off?

Sorry, I really can't help much as im not experienced with SLI and multi-monitors.


Are you new? Please read CoC  Before posting! PLEASE SELECT 'AUTOMATIC' FOR FONT COLOR FOR US DARK THEME USERS (Only for dark shades)If you can read this, it means you need to change to NIGHT THEME (bottom left above LMG logo) Please follow your threads and Quote people when replying to them. Mark your problem as solved if answered. Don't spam, nobody likes a spammer. DO NOT QUOTE IMAGES! BE NICE!

Link to post
Share on other sites

I have the same issue, something with the latest origin. I disabled origin overlay and I haven't had the problem since. When it wasn't on all three screens I did the widowed thing the full screen and it fixed that issue.


Main RIg Corsair Air 540, I7 8700k, ASUS ROG Strix Z370-H, G.Skill TridentZ 16GB, EVGA 1080TI SC Black, EVGA 850 GQ, Acer xG270HU 2560x1440@144hz

 

Spare RIg Corsair Air 540, I7 4770K, Asus Maximus VI Extreme, G.Skill Ares 32Gb, EVGA 1080sc & 1060 SSC, Corsair CX850M, Acer KG251Q 1920x1080@240hz 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×