Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
jnmbhj

AMD Graphics card driver News

Recommended Posts

Posted · Original PosterOP

On my 7970ghz (280x)

1150 Core

1550 Mem 

 

I have installed CCC 14.9 and ran Heaven Benchmark 4.0 Score of 1047 (41.6 FPS)

I then uninstalled the 14.9 and installed a previous driver. 14.4 And to my surprise the score went up 1172 (46.5 FPS)

This was an increase of almost 5 fps. 

 

Note: this was tested using the Extreme preset 

Dx 11

1600x900 8xAA windowed

Extreme preset 


[CPU] i7 4790K OC [CPU Cooler] H100i [GPU] Evga GTX 980 SuperClocked [Ram] Corsair Vengeance 16 GB 1866 mhz [PSU] Cooler Master 1000w Silent Pro [storage] 256 GB Samsung 840 Pro, 1TB Seagate SSHD, 1 TB WD Blue 4 TB Seagate Nas. [Motherboard] Msi Z97 Gaming 5 [Case] Phantom 410 Red [sound] Onboard ALC 1150 [Headphones] Sennheiser HD 558 [Keyboard] Razer BlackWidow Chroma  [Mouse] Razer Deathadder Chroma [Mouse] Razer FireFly [Monitor] Asus MG278Q

Link to post
Share on other sites

Something not quite right with your pc. My 7950 get 1k score in Heaven@1080p with the same clockspeed.


| Intel i7-3770@4.2Ghz | Asus Z77-V | Zotac 980 Ti Amp! Omega | DDR3 1800mhz 4GB x4 | 300GB Intel DC S3500 SSD | 512GB Plextor M5 Pro | 2x 1TB WD Blue HDD |
 | Enermax NAXN82+ 650W 80Plus Bronze | Fiio E07K | Grado SR80i | Cooler Master XB HAF EVO | Logitech G27 | Logitech G600 | CM Storm Quickfire TK | DualShock 4 |

Link to post
Share on other sites

I got almost that score with a 7700Ghz 2GB @ 1400Mhz. 

Link to post
Share on other sites
Posted · Original PosterOP

Something not quite right with your pc. My 7950 get 1k score in Heaven@1080p with the same clockspeed.

It depends on what settings you use. 


[CPU] i7 4790K OC [CPU Cooler] H100i [GPU] Evga GTX 980 SuperClocked [Ram] Corsair Vengeance 16 GB 1866 mhz [PSU] Cooler Master 1000w Silent Pro [storage] 256 GB Samsung 840 Pro, 1TB Seagate SSHD, 1 TB WD Blue 4 TB Seagate Nas. [Motherboard] Msi Z97 Gaming 5 [Case] Phantom 410 Red [sound] Onboard ALC 1150 [Headphones] Sennheiser HD 558 [Keyboard] Razer BlackWidow Chroma  [Mouse] Razer Deathadder Chroma [Mouse] Razer FireFly [Monitor] Asus MG278Q

Link to post
Share on other sites

il try running this and see if i get the same results i update to the new drivers.


My PC

[ I5 4690k (no oc) - Gigabyte Z97 D3H - 8GB Ram - Sapphire R9 280X Vapor-X ]

Link to post
Share on other sites

This is what i got (im running everything at stock)

Unigine Heaven Benchmark 4.0 FPS:

45.8

Score:

1154

Min FPS:

21.1

Max FPS:

108.4

System Platform:

Windows 7 (build 7600) 64bit

CPU model:

Intel® Core i5-4690K CPU @ 3.50GHz (3499MHz) x4

GPU model:

AMD Radeon R9 200 Series 14.301.1001.0/Intel® HD Graphics 4600 10.18.10.3540 (3072MB) x1

Settings Render:

Direct3D11

Mode:

1600x900 8xAA fullscreen

Preset

Custom

Quality

Ultra

Tessellation:

Extreme

My PC

[ I5 4690k (no oc) - Gigabyte Z97 D3H - 8GB Ram - Sapphire R9 280X Vapor-X ]

Link to post
Share on other sites
Posted · Original PosterOP

 

This is what i got (im running everything at stock)

Unigine Heaven Benchmark 4.0 FPS:

45.8

Score:

1154

Min FPS:

21.1

Max FPS:

108.4

System Platform:

Windows 7 (build 7600) 64bit

CPU model:

Intel® Core i5-4690K CPU @ 3.50GHz (3499MHz) x4

GPU model:

AMD Radeon R9 200 Series 14.301.1001.0/Intel® HD Graphics 4600 10.18.10.3540 (3072MB) x1

Settings Render:

Direct3D11

Mode:

1600x900 8xAA fullscreen

Preset

Custom

Quality

Ultra

Tessellation:

Extreme

 

was this the 14.4 drivers or was it the 14.9 drivers?


[CPU] i7 4790K OC [CPU Cooler] H100i [GPU] Evga GTX 980 SuperClocked [Ram] Corsair Vengeance 16 GB 1866 mhz [PSU] Cooler Master 1000w Silent Pro [storage] 256 GB Samsung 840 Pro, 1TB Seagate SSHD, 1 TB WD Blue 4 TB Seagate Nas. [Motherboard] Msi Z97 Gaming 5 [Case] Phantom 410 Red [sound] Onboard ALC 1150 [Headphones] Sennheiser HD 558 [Keyboard] Razer BlackWidow Chroma  [Mouse] Razer Deathadder Chroma [Mouse] Razer FireFly [Monitor] Asus MG278Q

Link to post
Share on other sites

was this the 14.4 drivers or was it the 14.9 drivers?

14.9

Downloading the 14.4 drivers now to see if theres any diff in fps.


My PC

[ I5 4690k (no oc) - Gigabyte Z97 D3H - 8GB Ram - Sapphire R9 280X Vapor-X ]

Link to post
Share on other sites
Posted · Original PosterOP

14.9

Downloading the 14.4 drivers now to see if theres any diff in fps.

This seems a little strange. It seems like it might be the same performance if I was on 14.4 drivers.  But you are running a better CPU which might make a difference of a few FPS


[CPU] i7 4790K OC [CPU Cooler] H100i [GPU] Evga GTX 980 SuperClocked [Ram] Corsair Vengeance 16 GB 1866 mhz [PSU] Cooler Master 1000w Silent Pro [storage] 256 GB Samsung 840 Pro, 1TB Seagate SSHD, 1 TB WD Blue 4 TB Seagate Nas. [Motherboard] Msi Z97 Gaming 5 [Case] Phantom 410 Red [sound] Onboard ALC 1150 [Headphones] Sennheiser HD 558 [Keyboard] Razer BlackWidow Chroma  [Mouse] Razer Deathadder Chroma [Mouse] Razer FireFly [Monitor] Asus MG278Q

Link to post
Share on other sites

This seems a little strange. It seems like it might be the same performance if I was on 14.4 drivers.  But you are running a better CPU which might make a difference of a few FPS

Okay so i don't know why but 14.4 drivers just wont't install for me D:


My PC

[ I5 4690k (no oc) - Gigabyte Z97 D3H - 8GB Ram - Sapphire R9 280X Vapor-X ]

Link to post
Share on other sites
Posted · Original PosterOP

Okay so i don't know why but 14.4 drivers just wont't install for me D:

For amd graphics drivers you first have to uninstall the 14.9 drivers in order to install the 14.4 drivers


[CPU] i7 4790K OC [CPU Cooler] H100i [GPU] Evga GTX 980 SuperClocked [Ram] Corsair Vengeance 16 GB 1866 mhz [PSU] Cooler Master 1000w Silent Pro [storage] 256 GB Samsung 840 Pro, 1TB Seagate SSHD, 1 TB WD Blue 4 TB Seagate Nas. [Motherboard] Msi Z97 Gaming 5 [Case] Phantom 410 Red [sound] Onboard ALC 1150 [Headphones] Sennheiser HD 558 [Keyboard] Razer BlackWidow Chroma  [Mouse] Razer Deathadder Chroma [Mouse] Razer FireFly [Monitor] Asus MG278Q

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×