Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
J12894

How to disable displayport auto detection on Windows 7?

Recommended Posts

Posted · Original PosterOP

As I have a Dell U2414H monitor which only have HDMI and Displayport input, I was forced to use displayport for connection.

 

I found that this cause the resolution of Windows resize every time when I turn off my monitor. (I need to turn the monitor off when I am not at home but need my PC to be turned on)

 

Is there anyway to disable the auto detection for displayport?

 

I had tried bought a DVI to Displayport cable but it doesn't seems working. I did some Googling and I think that is because the cable is passive.


CPU i5 3570k - - - - - - - - GPU Inno3D Nvidia GTX 780 - - - - - - - - - - RAM Corsair Dominator Platinum 1899MHz CL9 2x8GB

Motherboard MSI Z77A G45 - - Storage Samsung 840Pro 256GB + WD Green 2TB - PSU ANTEC EA750 EARTHWATTS 750W 80Plus Brown

Cooling Stock Intel cooler - Case Cooler Master Elite431 - - - - - - - - - Displays Dell U2414H + ViewSonic VA1948

Sound ATH-M50x, Lenovo unknown speaker - - Keyboard Ducky Shine 4 - - - - - Mouse Zowie EC1-A + G-TF Rough

 

Link to post
Share on other sites

I'd rather use hdmi.


The most underrated user and unsung hero of LTT Forum.

Casual Gamer and part time Youtuber.

Day Dreamer but lazy and lethargic when it comes to goals.

Always procrastinating. Avoiding challenges and getting out of comfort zone.

Link to post
Share on other sites
Posted · Original PosterOP

I'd rather use hdmi.

I think the problem is still exist for hdmi


CPU i5 3570k - - - - - - - - GPU Inno3D Nvidia GTX 780 - - - - - - - - - - RAM Corsair Dominator Platinum 1899MHz CL9 2x8GB

Motherboard MSI Z77A G45 - - Storage Samsung 840Pro 256GB + WD Green 2TB - PSU ANTEC EA750 EARTHWATTS 750W 80Plus Brown

Cooling Stock Intel cooler - Case Cooler Master Elite431 - - - - - - - - - Displays Dell U2414H + ViewSonic VA1948

Sound ATH-M50x, Lenovo unknown speaker - - Keyboard Ducky Shine 4 - - - - - Mouse Zowie EC1-A + G-TF Rough

 

Link to post
Share on other sites

Did you find a solution for your problem? I seem to be having the same issue.
I have 2 u2414h using DP and HDMI + an asus monitor using DVI. when i turn off the asus monitor, none of my windows on that monitor does not get moved.  But if i turn off one of the u2414h, the windows(skype, chrome) gets shifted to the other u2414h.

 

Thanks,

Vincent

Link to post
Share on other sites
Posted · Original PosterOP

Sorry to report that no, seems this is a Windows problem about DP and HDMI detection

 

Windows determines the turn off as unplug and there is no fix for that. Only way is to buy an active DVI to DP adapter, not DP to DVI specifically.  :(


CPU i5 3570k - - - - - - - - GPU Inno3D Nvidia GTX 780 - - - - - - - - - - RAM Corsair Dominator Platinum 1899MHz CL9 2x8GB

Motherboard MSI Z77A G45 - - Storage Samsung 840Pro 256GB + WD Green 2TB - PSU ANTEC EA750 EARTHWATTS 750W 80Plus Brown

Cooling Stock Intel cooler - Case Cooler Master Elite431 - - - - - - - - - Displays Dell U2414H + ViewSonic VA1948

Sound ATH-M50x, Lenovo unknown speaker - - Keyboard Ducky Shine 4 - - - - - Mouse Zowie EC1-A + G-TF Rough

 

Link to post
Share on other sites

Have you thought about instead of a screen saver, shutting off the monitor after x time? this would not act like a disconnect, and then if u need to remote in with something like Teamviewer just use the option to blank the far screen. so even if it starts nobody can see your interaction? 

 

aside from that if your pc is password protected if you let it do this you could also demand a login when the screen re-activates


ICT professional, Addicted to PC

Link to post
Share on other sites

 

 

Have you thought about instead of a screen saver, shutting off the monitor after x time? this would not act like a disconnect, and then if u need to remote in with something like Teamviewer just use the option to blank the far screen. so even if it starts nobody can see your interaction? 

 

The issue is hardware polling. Displayport is hotswappable thus hardaware polling monitors the connected screens state, if you disconnect, windows simply removes that display, in single monitor mode, this equates to having no screen at all and windows defaults to the generic 800x600 for compatibility reasons. This happens for me whether I simply turn off my monitor, it goes into sleep mode, or screen saver comes on. 

 

Using DVI is not an option for me, as I need displayport 1.2 to get the 60Hz @ 4k resolution. 

 

I've struggled with this recently and have done extensive research on the subject, the issue was brought up as early as 2009 to Microsoft and there is still no solution. A google search will lead you to a few different software fixes, such as registry edits, nvidia control panel settings, the whole works, all of which did not work for me. 

 

Very unfortunate as my new 4k monitor will have to be returned because of this issue :(

 

Monitor: ASUS PB287Q (4k @ 60Hz. DP 1.2 required to get full 60Hz)

Graphics: NVIDIA GeForce GTX 750 Ti

OS: Win 7 Ultimate

Link to post
Share on other sites

Gurrhack, you might have just stopped me from returning my monitor :D works a treat, just need to see if it works when i turn my monitors off overnight, to see if it remembers the way they were even though the monitor has been off for a couple of hours

Link to post
Share on other sites

Same problem bothered me after I switched to DP monitors. I found a solution that works for me: instead of turning off the monitors by pressing the button on monitor, I turn off screen from windows.
I'm using a lenovo PC and its Power Manager software has a feature to put a 'power off monitor' option if i rightclick desktop. I believe for other pc you can download a tool like NirCmd or Monitor Off to do that. When I turn off monitor in this way, my monitors would go to sleep mode but stay connected; And when I wake them up all the windows stay where they were.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×