Jump to content
Sign in to follow this  
Wiff

enable MBR on UEFI

Recommended Posts

Posted · Original PosterOP

How do I activate the possibility to boot on an UEFI BIOS from an Master Boot Record (MBR) Drive?

Can you tell me exact things that I have to change

Link to post
Share on other sites

If your drive is just partitioned in MBR, it should work out-of-the-box. If you plan on using the MBR for booting(Non-EFI boot), you need to adjust those settings in your BIOS. Usually under bppt, called boot mode or something. Change this to legacy. If it's disabled, try searching for fast boot(Or similar) and disable it. Then you should be able to boot using MBR.

Link to post
Share on other sites

How do I activate the possibility to boot on an UEFI BIOS from an Master Boot Record (MBR) Drive?

Can you tell me exact things that I have to change

In BIOS there should be a setting for the boot mode you want to use. I you have a UEFI BIOS then you need to have that setting on AHCI as that allows you to boot the GPT partition that is required for UEFI BIOS. MBR is used for EFI BIOS so if you don't have one don't used the MBR or Legacy option.

Link to post
Share on other sites
Posted · Original PosterOP

why cant you guys just tell me the things I have to change, so I have to change just the boot mode in the UEFI

Link to post
Share on other sites
Posted · Original PosterOP

MBR is not used for UEFI BIOS's you need to have the sata controller in the BIOS set to AHCI if you have a UEFI BIOS is you have EFI you need to put it to Legacy or IDE in order to use MBR.

the sata controller is always on AHCI, so I dont have to change anything

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.


×