Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
Spoilt

Asus Laptop USB issues

Recommended Posts

Posted · Original PosterOP

Disclaimer: I already solved the issue but I'm posting my workaround so that others with similar problems can find it.

 

So I have a first gen Razer Mamba that I bought late 2009. The mouse have been working flawlessly since then (I know, amazing luck i have. Touch wood). In 2013, I got myself an Asus N550LF laptop for my studies in the UK. It came with only USB 3.0 ports. When I first plugged in the mouse in wireless it wouldn't work at all. I've tried updating the firmware for both the base station and the mouse even though I've kept it up to date. The mouse still won't work on wireless. It works just fine in wired mode.

 

I managed to move the cursor using the mouse if I keep my track-pad's left and right button pressed. If I let go of the buttons the cursor will have a massive lag on it and it seems to overload the laptop with like 5792837594820 left and right clicks per second (Closing windows, deleting files, opening IE. It was horrifying to watch. The laptop was like possessed by a demon :lol:). My only thought at that time was somehow the flight screwed up the base station (all those x-ray scanners and what not). I've tried to open it up to look for any signs of burnt circuits. Looks fine and dandy inside.

 

I tried google-ing the issue on the net but it seems that no one else have the same problem as mine or couldn't be bothered to ask around or there is no solution. So I tried the mouse on wireless mouse once in a while for the past 6 months or so just in case Asus or Windows or Razer updated their drivers or something. Last month I got a USB 3.0 hub from amazon and casually tried the wireless mode again. IT WORKED!! But if I tried to plug the base station directly to the laptop, it won't work. For some reason the controller in hub allows my Mamba to work like normal again. I never would've thought the controller itself to be the issue. I expected the USB ports on the laptop itself would have the least amount of compatibility issue.

 

So yeah...try to use a USB hub if your peripherals is acting weird. If anyone finds another solution to this problem please share it here as well. Would love to use the wireless mode but I don't really want to carry the hub around.

 

 

 

 

Also, my quickfire tk won't work on the hub. Only direct connection will. I've tried both N-key and 6-key rollover modes. Any ideas?

 

If it helps, here is the link to the USB hub

 


Main PC:
CPU: 3700x Motherboard: X570  RAM: 2x16GB 3600Mhz GPU: RTX 2080 TI Case: NZXT H440 Storage: 1TB NVMe 2x250GB SSD RAID 0 2TB HDD PSU: 850W Platinum Display: Acer X34A Peripherals: Corsair K95 RGB Red, Razer Mamba 2012
 
Laptop:
Lenovo Thinkbook 13s  CPU: i5-8265U RAM: 8GB  Storage: 256GB SSD Display: Dell P2414H Peripherals: CMStorm Quickfire TK Brown, Razer Atheris 
 
Audio:
Beyerdynamic DT770 Pro 250 Ohm, FiiO E11, Stoner Acoustics UD100, Shure SE-215, Logitech Z906, Mission 731, Altec Lansing ADA-885, xDuoo UA-05, AKG K7XX,FiiO X3
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×