Jump to content
Search In
  • More options...
Find results that contain...
Find results in...
JORGEs34

My bf4 runs at 50-40 when yesterday was at 60-100 FPS

Recommended Posts

Do you have "Power saving" features enabled?  Or have you updated windows, downloaded anything?


Stuff:  i7 7700k @ (dat nibba succ) | ASRock Z170M OC Formula | G.Skill TridentZ 3600 c16 | EKWB 1080 @ 2100 mhz  |  Acer X34 Predator | R4 | EVGA 1000 P2 | 1080mm Radiator Custom Loop | HD800 + Audio-GD NFB-11 | 850 Evo 1TB | 840 Pro 256GB | 3TB WD Blue | 2TB Barracuda

Hwbot: http://hwbot.org/user/lays/ 

FireStrike 980 ti @ 1800 Mhz http://hwbot.org/submission/3183338 http://www.3dmark.com/3dm/11574089

Link to post
Share on other sites

I don't even know what you expected, BF4 still is not very stable

i have never had a single crash or lag spike or whatever in bf4...


msi z97m gaming - i5 4690k @4.4ghz 1.2V corsair h110 powercolor r9 290x pcs+ - 8GB corsair vengeance dual channel @2133mhz - thermaltake smart power se 730watts - intel 530 series 240GB ssd seagate 1tb 7200rpm - corsiar obsidian 350D - 2x enermax tb silence 140mm - logitech x-530 - sony mdr xb600 - medion 24'' 1080P cm storm quickfire tk white edition with cherry mx red cheap but awesome mouse #GloriousPaintMasterRace

Link to post
Share on other sites

thats all I get when I play battlefield on Ultra 


Computer and other things (My Phanteks Enthoo Elite build is done)

Spoiler

Main Computer

Spoiler

Processor: Intel Core i7 6850k @4.5GHz
Motherboard: Asus Rampage V ROG Edition 10
Heatsink: Custom Hardline
Memory: Corsaor Dominator 16GB (4GB x2) DDR4 3000MHz 
Video Card: EVGA GTX 1080 FTW
Hard Drive: x2 OCZ ARC 100 240GB RAID 0 (Boot), Western Digital 4TB SSHD (Steam), x2 Adata 512GB (Steam)
Main GUI: Windows 10 Pro 64-bit

All That Extra Stuff

 

Spoiler

Monitor: x2 Dell U2414H
Keyboard: Ducky Shine 5 RGB (Cherry MX Blue)
Mouse: Logitech G502
Headset: AKG K553 Pro Studio Headphones
Speakers: Boston Accustics Home Media Theater 2.1 + Boston Accustics Soundbar
Microphone: Audio Technica AT-2035 w/ Focusrite Scarlett Solo
Sound: Creative Sound Blaster E5 DAC

Server

Spoiler

Case: Rosewill 4U Rackmount RSV-L4500

Processor: Intel Xeon E5-2670 V3 12C/24T

Motherboard: Asrock x99 Extreme 4

Ram: Kingston HyperX DDR4 2133 4x4GB

Video Card: Nvidia GT520

OS Drive: Kingston Hyperx 240GB SSD

Raid Card: LSI MegaRaid  9261-8i 8-port

Hard Drives: x7 HGST 4TB Nas

 

 

Link to post
Share on other sites

If you updated Windows it may have re-enabled some bs Windows Aero features that you previously disabled. Also check for GPU overheats because if it is too hot it will automatically underclock thus giving you lower frames. Final suggestion is make sure you haven't accidentally upped the video settings from what they were yesterday. If something happened to your documents folder it might have overwritten your old settings with the default ones that are on High usually. 


8700k @5.0Ghz - Gigabyte Z370 Gaming 5 - GTX 1080ti - Corsair RMx850 - 2x 256gb 970Pro NVMe  - 16GB HyperX Black DDR4 - Acer 24" 240hz

Logitech G502 - Logitech Orion - Sennheiser HD598 SE

SpeedTest.net result

 

Link to post
Share on other sites
Posted · Original PosterOP

it is on max 75 Celcius

the settings are fine.

 

justa a question 

does aero affect performance, like a lot???

Link to post
Share on other sites

it is on max 75 Celcius

the settings are fine.

 

justa a question 

does aero affect performance, like a lot???

If you are running a single monitor and in full screen mode it won't affect it really at all. 

 

If you have multiple monitors especially 3 or more and running aero, your FPS will drop a ton. 


8700k @5.0Ghz - Gigabyte Z370 Gaming 5 - GTX 1080ti - Corsair RMx850 - 2x 256gb 970Pro NVMe  - 16GB HyperX Black DDR4 - Acer 24" 240hz

Logitech G502 - Logitech Orion - Sennheiser HD598 SE

SpeedTest.net result

 

Link to post
Share on other sites
Posted · Original PosterOP

If you are running a single monitor and in full screen mode it won't affect it really at all. 

 

If you have multiple monitors especially 3 or more and running aero, your FPS will drop a ton. 

i have just 1 monitor

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×